You are not logged in.

#1 2022-10-05 12:44:45

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 588

[Solved]failed to validate module [nvidia] BTF: -22

I saw there was a problem with pahole back in August.
https://bbs.archlinux.org/viewtopic.php?id=279157

I had  pahole 1:1.24-1 from testing installed yesterday and had to rebuild my dkms modules for something else and ran into this.

Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:25 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:26 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:26 carlos kernel: failed to validate module [spl] BTF: -22
Oct 04 21:39:26 carlos kernel: failed to validate module [spl] BTF: -22
Oct 04 21:39:26 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:27 carlos kernel: failed to validate module [nvidia] BTF: -22
Oct 04 21:39:35 carlos kernel: failed to validate module [spl] BTF: -22

I downgraded to pahole 1:1.23-1, rebuilt my dkms modules, and everything is fine again.

I didn't see any bug reports in flyspray, is this still considered to be the same or a new issue?

Edit: I had to go back a little further to see where it was also effecting zfs dkms modules.

Edit: Solved, pahole 1:1.24-1 is needed for kernel 6.0 I also needed to patch nvidia-390xx-dkms for kernel 6.0. So, too many moving parts. Sorry for the noise.

For what it's worth, up to date zfs works with the new kernel also.

Last edited by Zod (2022-10-05 15:20:49)

Offline

#2 2022-10-05 13:46:37

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,734

Re: [Solved]failed to validate module [nvidia] BTF: -22

It's the same issue, not sure why this would be reattempted without any patches after that exact version was downgraded due to exactly this issue.

Offline

Board footer

Powered by FluxBB