You are not logged in.

#1 2022-10-25 22:14:31

Tetti
Member
Registered: 2022-10-25
Posts: 5

Unable to upgrade after ignoring one package upgrade

Hi!

A few days ago I had to exclude thunderbird from the update because the 102 versions no longer work with my imap server.

With the update from icu, a system update is no longer possible.

Does anyone have an idea how I can solve this?

sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: thunderbird: ignoring package upgrade (91.12.0-1 => 102.4.0-2)
warning: thunderbird-i18n-de: ignoring package upgrade (91.12.0-1 => 102.4.0-2)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (72.1-1) breaks dependency 'libicui18n.so=71-64' required by thunderbird
:: installing icu (72.1-1) breaks dependency 'libicuuc.so=71-64' required by thunderbird

With best regards

Offline

#2 2022-10-25 22:31:36

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,647

Re: Unable to upgrade after ignoring one package upgrade

Tetti wrote:

Does anyone have an idea how I can solve this?

By including thunderbird in the update.
Arch doesn't support partial updates.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2022-10-25 22:34:59

loqs
Member
Registered: 2014-03-06
Posts: 15,509

Re: Unable to upgrade after ignoring one package upgrade

What is the compatibility issue with the IMAP server?  If you can not get thunderbird 102 to work with your IMAP server you will need to rebuild thunderbird 91 locally against the current icu.

Last edited by loqs (2022-10-25 22:35:26)

Offline

#4 2022-10-25 22:43:52

Tetti
Member
Registered: 2022-10-25
Posts: 5

Re: Unable to upgrade after ignoring one package upgrade

Slithery wrote:
Tetti wrote:

Does anyone have an idea how I can solve this?

By including thunderbird in the update.
Arch doesn't support partial updates.


Okay, then what is the point of the IgnorePkg option in the file /etc/pacman.conf ?

Offline

#5 2022-10-25 22:47:59

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,296
Website

Re: Unable to upgrade after ignoring one package upgrade

Tetti wrote:
Slithery wrote:
Tetti wrote:

Does anyone have an idea how I can solve this?

By including thunderbird in the update.
Arch doesn't support partial updates.


Okay, then what is the point of the IgnorePkg option in the file /etc/pacman.conf ?

To remind you to rebuild packages before you attempt a system upgrade...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#6 2022-10-25 22:49:53

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,647

Re: Unable to upgrade after ignoring one package upgrade

Tetti wrote:

Okay, then what is the point of the IgnorePkg option in the file /etc/pacman.conf ?

It can be useful if you are using a distro which uses pacman that isn't Arch.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2022-10-25 22:51:30

Tetti
Member
Registered: 2022-10-25
Posts: 5

Re: Unable to upgrade after ignoring one package upgrade

loqs wrote:

What is the compatibility issue with the IMAP server?  If you can not get thunderbird 102 to work with your IMAP server you will need to rebuild thunderbird 91 locally against the current icu.

I don't know the exact cause yet. After the thunderbird package upgrade the left folder pane is empty.

Offline

#8 2022-10-25 23:08:08

loqs
Member
Registered: 2014-03-06
Posts: 15,509

Re: Unable to upgrade after ignoring one package upgrade

Basic tests shutdown thunderbird then:

thunderbird --safe-mode # disable extensions
thunderbird --ProfileManage #create a new profile and see if you can add your account to that

Offline

#9 2022-10-25 23:10:16

Tetti
Member
Registered: 2022-10-25
Posts: 5

Re: Unable to upgrade after ignoring one package upgrade

Slithery wrote:

It can be useful if you are using a distro which uses pacman that isn't Arch.

In other words, I didn't understand arch linux. Ok, thanks for solving the problem.

Offline

#10 2022-10-26 03:56:43

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,853

Re: Unable to upgrade after ignoring one package upgrade

Tetti wrote:

Okay, then what is the point of the IgnorePkg option in the file /etc/pacman.conf ?

It can be useful if you know a package shouldn't be upgraded and you know what the consequences are. For example, I have

IgnorePkg   = texlive-bin
IgnoreGroup = texlive-most texlive-lang

But the packages specified here are not from the repos. They are placeholders. They don't install anything. All they do is satisfy dependencies by convincing pacman it has installed them even though it hasn't. This means I can use vanilla TeX Live from upstream (under /usr/local and nothing to do with pacman) but still install my TeX editor from the repos.

Occasionally, this breaks. Not often, but it has happened. It could happen again. If it does, that's my problem. I'd rather use vanilla TL and deal with the very occasional breakage (usually perl-related). I avoid much more problematic and frequent breakages this way. (I have custom code which may well break - avoiding that when a deadline looms is important.)

I also keep multiple versions of TL installed, which is not possible with Arch's packages.

So it is a useful feature if you want to lie to pacman, but it only works because TL is *almost* completely independent of everything else.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#11 2022-10-26 20:56:01

Tetti
Member
Registered: 2022-10-25
Posts: 5

Re: Unable to upgrade after ignoring one package upgrade

loqs wrote:

Basic tests shutdown thunderbird then:

thunderbird --safe-mode # disable extensions
thunderbird --ProfileManage #create a new profile and see if you can add your account to that

Thank you for that information.
Found by accident: thunderbird does not work with the locale de_DE@euro. export LANG=C && thunderbird => thunderbird 102.4.0 is working

Offline

#12 2022-10-29 15:36:19

walkingstickfan
Member
From: USA
Registered: 2021-05-10
Posts: 63

Re: Unable to upgrade after ignoring one package upgrade

Maybe you could have tried ignoring icu as well.


Arch Linux with Openbox & Tint2

Offline

#13 2022-10-29 16:17:12

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: Unable to upgrade after ignoring one package upgrade

walkingstickfan wrote:

Maybe you could have tried ignoring icu as well.

Which will break everything else using icu, which is a lot. Don't do this.

Offline

#14 2022-11-08 02:06:28

walkingstickfan
Member
From: USA
Registered: 2021-05-10
Posts: 63

Re: Unable to upgrade after ignoring one package upgrade

Scimmia wrote:
walkingstickfan wrote:

Maybe you could have tried ignoring icu as well.

Which will break everything else using icu, which is a lot. Don't do this.

Thank you for correcting my ignorance.


Arch Linux with Openbox & Tint2

Offline

Board footer

Powered by FluxBB