You are not logged in.

#1 2023-01-16 05:59:52

ktatar156
Member
Registered: 2012-10-01
Posts: 79

Ethernet port not working // MSI B450 Gaming Plus board

Hello,

My wired connection not working properly, the device going up and down all the time hmm

 $ sudo dmesg | grep r816
[    9.206583] r8168: loading out-of-tree module taints kernel.
[    9.206698] r8168: module verification failed: signature and/or required key missing - tainting kernel
[    9.210001] r8168 Gigabit Ethernet driver 8.051.02-NAPI loaded
[    9.222351] r8168: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
[    9.224388] r8168  Copyright (C) 2022 Realtek NIC software team <nicfae@realtek.com> 
[    9.380250] r8168 0000:22:00.0 enp34s0: renamed from eth0
[   28.430272] r8168: enp34s0: link up
[  100.366827] r8168: enp34s0: link down
[  112.563954] r8168: enp34s0: link up
[  113.566825] r8168: enp34s0: link down
[  119.683583] r8168: enp34s0: link up

Any advice how to solve this?
This website shows that I have here (Realtek® 8111H) .

Offline

#2 2023-01-16 06:16:36

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,776

Re: Ethernet port not working // MSI B450 Gaming Plus board

What's the output of...

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2023-01-16 18:37:32

ktatar156
Member
Registered: 2012-10-01
Posts: 79

Re: Ethernet port not working // MSI B450 Gaming Plus board

cups.path                                | multi-user.target.wants
cups.service                             | printer.target.wants
cups.socket                              | sockets.target.wants
dbus-org.freedesktop.nm-dispatcher.service | system
display-manager.service                  | system
getty@tty1.service                       | getty.target.wants
NetworkManager.service                   | multi-user.target.wants
NetworkManager-wait-online.service       | network-online.target.wants
p11-kit-server.socket                    | sockets.target.wants
pipewire-media-session.service           | pipewire.service.wants
pipewire-session-manager.service         | user
pipewire.socket                          | sockets.target.wants
pulseaudio.socket                        | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
xdg-user-dirs-update.service             | default.target.wants

Offline

#4 2023-01-16 18:48:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,093

Re: Ethernet port not working // MSI B450 Gaming Plus board

Looks ok, have you tried removing the r8168 package to use r8169 in the kernel instead?

Offline

#5 2023-01-16 18:50:36

ktatar156
Member
Registered: 2012-10-01
Posts: 79

Re: Ethernet port not working // MSI B450 Gaming Plus board

Yes - now it's removed and this changed nothing hmm The same behavior.

EDIT: I blacklisted r8168 and now it's working smile

Last edited by ktatar156 (2023-01-16 19:01:06)

Offline

#6 2023-01-16 21:29:21

seth
Member
Registered: 2012-09-03
Posts: 53,202

Re: Ethernet port not working // MSI B450 Gaming Plus board

If you remved the r8168 package, blacklisting the module is idempotent unless it's lingering around in the initramfs.

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#7 2023-01-16 21:33:53

ktatar156
Member
Registered: 2012-10-01
Posts: 79

Re: Ethernet port not working // MSI B450 Gaming Plus board

I've restarted the computer and again it's not working... hmm

[ 1577.013725] r8169 0000:22:00.0 enp34s0: Link is Up - 100Mbps/Full (downshifted) - flow control rx/tx
[ 1577.015824] r8169 0000:22:00.0 enp34s0: Link is Down
[ 1583.064656] r8169 0000:22:00.0 enp34s0: Link is Down
[ 1589.703058] Generic FE-GE Realtek PHY r8169-0-2200:00: Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!
[ 1589.703068] r8169 0000:22:00.0 enp34s0: Link is Up - 100Mbps/Full (downshifted) - flow control rx/tx
[ 1589.705395] r8169 0000:22:00.0 enp34s0: Link is Down
[ 1595.727943] r8169 0000:22:00.0 enp34s0: Link is Down
[ 1602.122472] Generic FE-GE Realtek PHY r8169-0-2200:00: Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!
[ 1602.122570] r8169 0000:22:00.0 enp34s0: Link is Up - 100Mbps/Full (downshifted) - flow control rx/tx
[ 1602.124874] r8169 0000:22:00.0 enp34s0: Link is Down
[ 1608.161300] r8169 0000:22:00.0 enp34s0: Link is Down

Offline

#8 2023-01-16 21:35:07

seth
Member
Registered: 2012-09-03
Posts: 53,202

Re: Ethernet port not working // MSI B450 Gaming Plus board

Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!

Offline

#9 2023-01-16 21:54:09

ktatar156
Member
Registered: 2012-10-01
Posts: 79

Re: Ethernet port not working // MSI B450 Gaming Plus board

Yes, I've checked this - probably my switch is downshifting the connection (it's strange because I connected router and computer to 1gbps uplink ports - but it also works on Windows with 100 mbps). So I would say that cabling is correct.

Offline

#10 2023-01-16 21:58:01

seth
Member
Registered: 2012-09-03
Posts: 53,202

Re: Ethernet port not working // MSI B450 Gaming Plus board

I connected router and computer to 1gbps uplink ports - but it also works on Windows with 100 mbps). So I would say that cabling is…

… the problem for pretty much sure. But also see the 3rd link below!

Do you have another cable (ideally shorter and/or cat6)?

Offline

Board footer

Powered by FluxBB