You are not logged in.

#1 2023-06-26 18:57:57

therealcyclist
Member
Registered: 2023-05-31
Posts: 1

Package pcsclite 2.0.0-1 requires surprising polkit

hello,

i'm using pcsclite but don't polkit. i'm using seatd.
today i'm updating a archlinux system and wonder why i have to install polkit+duktape.

the new pcsclite version 2.0 add build option "- Add '--disable-polkit' option" upstream [1]

the archlinux package pcsclite before 2.0 never pull polkit. why it's now enabled if the upstream developer add "--disable-polkit" ?

i know how to build my own package and will try "--disable-polkit" in future for now i don't want to upgrade to 2.0 just as side note.


[1] https://salsa.debian.org/rousseau/PCSC/ … /ChangeLog

Offline

#2 2023-06-27 11:07:35

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,167

Re: Package pcsclite 2.0.0-1 requires surprising polkit

The archlinux package in 1.9.9-3  from march 2023 was the first one to add polkit support, https://gitlab.archlinux.org/archlinux/ … 205d18c2b2 .

You may want to stick to 1.9.9-2 .

No idea why polkit support was added, you can try creating a bug report to ask the arch devs to disable it .

Last edited by Lone_Wolf (2023-06-27 11:08:21)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB