You are not logged in.

#1 2023-09-15 06:42:10

Registered: 2023-09-15
Posts: 1

Download Speeds Are 2x Slower Than Windows and Massively Unstable.

I have been daily driving arch for around a month now with pretty much no issues other than this huge annoyance which is my download speed. It runs 2 time slower than it did on Windows, but it also will just sometimes not work at all. So things like steam, curl, and pacman/yay all work slow.

I tested this about 3 ways. First method was just using ookla's speed test online. Which correctly shows that I should be getting around 550 mbps. Second method is using speedtest-cli. This method shows that I can sometimes get around 330 mbps and all the way down to 100 mbps. Third and final method was just downloading from Steam. again this was unstable and I download around 30-20 MB/s and then it'll sometimes just stop working.

One difference I noted from Windows is that my fans on my pc got super loud when downloading, now I don't hear them at all.

sudo lshw -c network - result

   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:05:00.0
   logical name: enp5s0
   version: 15
   serial: 98:ee:cb:d2:77:a1
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.051.02-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:19 ioport:3000(size=256) memory:a0504000-a0504fff memory:a0500000-a0503fff

sudo lspci -k - result

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
    Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    Kernel driver in use: r8168
    Kernel modules: r8169, r8168

What I have tried. I have configured dnsmasq to be used with and without NetworkManager to no avail. I have tried not using dnsmasq. I have turned on and off IPv6. I have tried different ethernet cables and on other devices as well. They work just fine. My switch also works fine on other devices too. I have tried installing new drivers. so I went from 8168 to 8168-dkms. I tried installing the new kernel and then updating both of those drivers again. I turned off powersaving on them through modprobe. I turned on and off my pihole dns server as well.

I am not dual-booting Windows either also have no intentions of switching distros or going back to Windows either, just to be clear.

I am still pretty new to Arch and Linux as a whole but I feel like I am missing something super small or its just my router that sucks since its a Google Home Mesh Router and has almost no features. I am getting a new server and I want to virtualize pfsense through there and I hope that may fix it. All in all any help is appreciated.


Board footer

Powered by FluxBB