You are not logged in.

#1 2023-11-08 22:49:34

dIQi
Member
Registered: 2023-11-04
Posts: 67

7800 XT extremely low FPS on fresh install

I have just freshly installed Arch using archlinux-2023.11.01-x86_64.iso

I see here that the 7800 XT performs well with the UNIGINE Superposition Benchmark.  However when I try on the same settings it I’m getting ~5fps

To rule out hardware / hardware config issues I installed Windows To Go on a flash drive.  This gives me benchmark results in a similar range to those in the Phoronix article.  My hardware seems good

inxi -Faz

System:
  Kernel: 6.5.9-arch2-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm parameters: initrd=\intel-ucode.img
    initrd=\initramfs-linux.img
    root=PARTUUID=df9f8cd4-f4c2-4f06-ab33-3fe184a63d56 rw rootfstype=ext4
  Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Arch Linux
Machine:
  Type: Mini-pc System: Intel Client Systems product: NUC13RNGi7 v: M58740-303
    serial: <superuser required> Chassis: Intel Corporation type: 35 v: 2.0
    serial: <superuser required>
  Mobo: Intel model: NUC13SBBi7 v: M89885-303 serial: <superuser required>
    UEFI: Intel v: SBRPL579.0058.2023.0817.1457 date: 08/17/2023
CPU:
  Info: model: 13th Gen Intel Core i7-13700K bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
    microcode: 0x11A
  Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled
    cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB
    L2: 24 MiB desc: 8x2 MiB, 2x4 MiB L3: 30 MiB desc: 1x30 MiB
  Speed (MHz): avg: 1003 high: 1439 min/max: 800/5300:5400:4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 1334 4: 801
    5: 800 6: 800 7: 1124 8: 800 9: 1346 10: 799 11: 1030 12: 800 13: 802
    14: 800 15: 1370 16: 800 17: 1394 18: 800 19: 1439 20: 1187 21: 1347
    22: 1318 23: 800 24: 800 bogomips: 164088
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] driver: amdgpu v: kernel
    arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm) built: 2022+ pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: DP-1 empty: DP-2,HDMI-A-1,HDMI-A-2
    bus-ID: 03:00.0 chip-ID: 1002:747e class-ID: 0300
  Display: x11 server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-size: <missing: xdpyinfo>
  Monitor-1: DP-1 mapped: DisplayPort-0 model: LG (GoldStar) ULTRAWIDE
    serial: <filter> built: 2023 res: 5120x1440 hz: 85 dpi: 108 gamma: 1.2
    size: 1200x340mm (47.24x13.39") diag: 1244mm (49") modes: max: 5120x1440
    min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (gfx1101 LLVM
    16.0.6 DRM 3.54 6.5.9-arch2-1) device-ID: 1002:747e memory: 15.62 GiB
    unified: no
  API: Vulkan v: 1.3.269 layers: N/A device: 0 type: discrete-gpu name: AMD
    Radeon RX 7800 XT (RADV GFX1101) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:747e surfaces: xcb,xlib
Audio:
  Device-1: Intel Alder Lake-S HD Audio vendor: Realtek driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:7ad0 class-ID: 0401
  Device-2: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-3: Generic USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:5
    chip-ID: 0bda:4c60 class-ID: 0300
  API: ALSA v: k6.5.9-arch2-1 status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Alder Lake-S PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-2: Aquantia AQC113C NBase-T/IEEE 802.3bz Ethernet [AQtion]
    vendor: Intel driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 2
    port: N/A bus-ID: 05:00.0 chip-ID: 1d6a:14c0 class-ID: 0200 temp: 68.0 C
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Intel Ethernet I226-V driver: igc v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 06:00.0 chip-ID: 8086:125c
    class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
Bluetooth:
  Device-1: N/A driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-14:6 chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 2.84 TiB used: 18.91 GiB (0.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: solidgm model: SSDPFKKW010X7
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 001C temp: 50.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: WDC WDS200T2B0A-00SM50
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 40WD scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MK1032GSX
    size: 93.16 GiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 0209 scheme: GPT
Partition:
  ID-1: / raw-size: 24.07 GiB size: 23.52 GiB (97.73%) used: 13.3 GiB (56.5%)
    fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 63.3 MiB (12.4%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 68.59 GiB size: 66.96 GiB (97.63%)
    used: 5.55 GiB (8.3%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 47.0 C mem: 58.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Processes: 458 Uptime: 1h 2m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.96 GiB used: 4.7 GiB (15.2%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 793
  pm: pacman pkgs: 781 libs: 274 tools: gnome-software,yay pm: flatpak
  pkgs: 12 Shell: Bash v: 5.2.15 running-in: kgx inxi: 3.3.31

pacman -Qs linux-firmware

local/linux-firmware 20231030.2b304bfe-1
    Firmware files for Linux
local/linux-firmware-whence 20231030.2b304bfe-1
    Firmware files for Linux - contains the WHENCE license file which documents the vendor license details

pacman -Qs vulkan

local/lib32-vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader
local/vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver
local/vulkan-tools 1.3.269-1 (vulkan-devel)
    Vulkan Utilities and Tools

pacman -Qs mesa

local/glu 9.0.3-1
    Mesa OpenGL utility library
local/lib32-mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification (32-bit)
local/lib32-mesa-utils 9.0.0-1
    Essential Mesa utilities (32-bit)
local/mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification
local/mesa-utils 9.0.0-3
    Essential Mesa utilities
local/vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver

vulkaninfo --summary

Vulkan Instance Version: 1.3.269

Instance Extensions: count = 23
-------------------------------
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_EXT_surface_maintenance1            : extension revision 1
VK_EXT_swapchain_colorspace            : extension revision 4
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_portability_enumeration         : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6
VK_LUNARG_direct_driver_loading        : extension revision 1

Instance Layers:
----------------

Devices:
========
GPU0:
	apiVersion         = 1.3.255
	driverVersion      = 23.2.1
	vendorID           = 0x1002
	deviceID           = 0x747e
	deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
	deviceName         = AMD Radeon RX 7800 XT (RADV GFX1101)
	driverID           = DRIVER_ID_MESA_RADV
	driverName         = radv
	driverInfo         = Mesa 23.2.1-arch1.2
	conformanceVersion = 1.3.0.0
	deviceUUID         = 00000000-0300-0000-0000-000000000000
	driverUUID         = 414d442d-4d45-5341-2d44-525600000000

pacman -Qs unigine-superposition

local/unigine-superposition 1.1-6
    Interactive 3D benchmark: walk through a lab of a lone professor

  freesync is off on the monitor
  VT-d is off
  Same results with X11 / Wayland

cat  /sys/class/drm/card1/device/pp_dpm_mclk

0: 96Mhz *
1: 456Mhz 
2: 772Mhz 
3: 1218Mhz 

pp_dpm_mclk is stuck at 96Mhz / 465MHz depending on refresh rate.  This makes no difference to FPS

This is the GPU, I believe it only has a single BIOS : https://www.sapphiretech.com/en/consume … -16g-gddr6

AMD have temporarily removed OD for this card from kernel 6.5:  https://gitlab.freedesktop.org/drm/amd/ … te_2079945

I've read the section at the bottom of AMDGPU about MCLK being locked at 96Mhz.

cvt12 5120 1440 144 -b

# 5120x1440 @ 144.000 Hz Reduced Blank (CVT) field rate 144.000 Hz; hsync: 222.192 kHz; pclk: 1155.40 MHz
Modeline "5120x1440_144.00_rb2"  1155.40  5120 5128 5160 5200  1440 1529 1537 1543 +hsync -vsync
xrandr --newmode "MCLK-fix" 1155.40  5120 5128 5160 5200  1440 1529 1537 1543 +hsync -vsync

xrandr --addmode DisplayPort-0 "MCLK-fix"

Then I choose 144Mhz, as opposed to 143.98 that the system boots with, and I get this terrible mess

FluxBB bbcode test

I also tried this with 85MHz and while I didn't get the same result I've not seen any increase in FPS and pp_dpm_mclk is still stuck

Thanks in advance for any suggestions

Offline

#2 2023-11-08 23:28:10

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Just tried cvt12 at 120MHz, which is one of the rates available when freesync is turned on in the monitor settings, and I got a very slightly different mess appear on screen

Offline

#3 2023-11-08 23:42:53

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Just noticed a new kernel release

uname -r
6.6.1-arch1-1

Nothing's changed

Offline

#4 2023-11-09 00:59:05

kgtuning
Member
From: New Hampshire
Registered: 2015-09-30
Posts: 44

Re: 7800 XT extremely low FPS on fresh install

Edit: disregard

Last edited by kgtuning (2023-11-09 01:02:16)

Offline

#5 2023-11-09 09:01:35

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,181

Re: 7800 XT extremely low FPS on fresh install

Intel/Asus NUC systems tend to be heavily engineered to work well with intel hardware.

please enable the intel graphics as primary so the system will function as intel/Asus  designed it to do.

Once that's done post full lspci -k (run as user) and journal (run with root-rights) outputs.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2023-11-09 14:07:11

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

Next to that, what if you add

amdgpu.runpm=0 amdgpu.bapm=0 amdgpu.aspm=0 pcie_aspm=off

to the kernel paramters?
(+"amdgpu.dpm=0", but that'll likely prevent the system from booting?)

Offline

#7 2023-11-09 22:04:59

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

lspci -k

00:00.0 Host bridge: Intel Corporation Device a703 (rev 01)
	Subsystem: Intel Corporation Device 3033
00:01.0 PCI bridge: Intel Corporation Device a70d (rev 01)
	Subsystem: Intel Corporation Device 3033
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation Raptor Lake-S GT1 [UHD Graphics 770] (rev 04)
	Subsystem: Intel Corporation Raptor Lake-S GT1 [UHD Graphics 770]
	Kernel driver in use: i915
	Kernel modules: i915
00:06.0 PCI bridge: Intel Corporation Raptor Lake PCIe 4.0 Graphics Port (rev 01)
	Kernel driver in use: pcieport
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 01)
	Subsystem: Intel Corporation GNA Scoring Accelerator module
00:0a.0 Signal processing controller: Intel Corporation Raptor Lake Crashlog and Telemetry (rev 01)
	Kernel driver in use: intel_vsec
	Kernel modules: intel_vsec
00:14.0 USB controller: Intel Corporation Alder Lake-S PCH USB 3.2 Gen 2x2 XHCI Controller (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH USB 3.2 Gen 2x2 XHCI Controller
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 RAM memory: Intel Corporation Alder Lake-S PCH Shared SRAM (rev 11)
00:14.3 Network controller: Intel Corporation Alder Lake-S PCH CNVi WiFi (rev 11)
	Subsystem: Rivet Networks Alder Lake-S PCH CNVi WiFi
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
00:15.0 Serial bus controller: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller #0 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:15.2 Serial bus controller: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller #2 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation Alder Lake-S PCH HECI Controller #1 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH HECI Controller
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation Alder Lake-S PCH SATA Controller [AHCI Mode] (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH SATA Controller [AHCI Mode]
	Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation Alder Lake-S PCH PCI Express Root Port #1 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH PCI Express Root Port
	Kernel driver in use: pcieport
00:1c.6 PCI bridge: Intel Corporation Device 7abe (rev 11)
	Subsystem: Intel Corporation Device 3033
	Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation Alder Lake-S PCH PCI Express Root Port #9 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH PCI Express Root Port
	Kernel driver in use: pcieport
00:1e.0 Communication controller: Intel Corporation Alder Lake-S PCH Serial IO UART #0 (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH Serial IO UART
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:1e.3 Serial bus controller: Intel Corporation Alder Lake-S PCH Serial IO SPI Controller #1 (rev 11)
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:1f.0 ISA bridge: Intel Corporation Z690 Chipset LPC/eSPI Controller (rev 11)
	Subsystem: Intel Corporation Z690 Chipset LPC/eSPI Controller
00:1f.3 Multimedia audio controller: Intel Corporation Alder Lake-S HD Audio Controller (rev 11)
	Subsystem: Realtek Semiconductor Co., Ltd. Alder Lake-S HD Audio Controller
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl
00:1f.4 SMBus: Intel Corporation Alder Lake-S PCH SMBus Controller (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH SMBus Controller
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
00:1f.5 Serial bus controller: Intel Corporation Alder Lake-S PCH SPI Controller (rev 11)
	Subsystem: Intel Corporation Alder Lake-S PCH SPI Controller
	Kernel driver in use: intel-spi
	Kernel modules: spi_intel_pci
01:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Upstream Port of PCI Express Switch (rev 11)
	Kernel driver in use: pcieport
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Downstream Port of PCI Express Switch (rev 11)
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Downstream Port of PCI Express Switch
	Kernel driver in use: pcieport
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 32 [Radeon RX 7700 XT / 7800 XT] (rev c8)
	Subsystem: Sapphire Technology Limited Device 475d
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 HDMI/DP Audio
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 HDMI/DP Audio
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
04:00.0 Non-Volatile memory controller: Solidigm P44 Pro NVMe SSD
	Subsystem: Solidigm P44 Pro NVMe SSD
	Kernel driver in use: nvme
	Kernel modules: nvme
05:00.0 Ethernet controller: Aquantia Corp. AQC113C NBase-T/IEEE 802.3bz Ethernet Controller [AQtion] (rev 03)
	Subsystem: Intel Corporation AQC113C NBase-T/IEEE 802.3bz Ethernet Controller [AQtion]
	Kernel driver in use: atlantic
	Kernel modules: atlantic
06:00.0 Ethernet controller: Intel Corporation Ethernet Controller I226-V (rev 04)
	Subsystem: Intel Corporation Ethernet Controller I226-V
	Kernel driver in use: igc
	Kernel modules: igc
07:00.0 PCI bridge: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020] (rev 02)
	Subsystem: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020]
	Kernel driver in use: pcieport
08:00.0 PCI bridge: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020] (rev 02)
	Subsystem: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020]
	Kernel driver in use: pcieport
08:01.0 PCI bridge: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020] (rev 02)
	Subsystem: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020]
	Kernel driver in use: pcieport
08:02.0 PCI bridge: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020] (rev 02)
	Subsystem: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020]
	Kernel driver in use: pcieport
08:03.0 PCI bridge: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020] (rev 02)
	Subsystem: Intel Corporation Thunderbolt 4 Bridge [Maple Ridge 4C 2020]
	Kernel driver in use: pcieport
09:00.0 USB controller: Intel Corporation Thunderbolt 4 NHI [Maple Ridge 4C 2020]
	Subsystem: Intel Corporation Thunderbolt 4 NHI [Maple Ridge 4C 2020]
	Kernel driver in use: thunderbolt
	Kernel modules: thunderbolt
3d:00.0 USB controller: Intel Corporation Thunderbolt 4 USB Controller [Maple Ridge 4C 2020]
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci

sudo journalctl | curl -F 'file=@-' 0x0.st  :  http://0x0.st/Ht0C.txt

Offline

#8 2023-11-09 22:21:55

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

"-b" to isolate the running boot.

Nov 09 21:53:05 archlinux kernel: i915 0000:00:02.0: [drm] Cannot find any crtc or sizes
Nov 09 21:53:05 archlinux kernel: i915 0000:00:02.0: [drm] Cannot find any crtc or sizes
Nov 09 21:54:14 archlinux /usr/lib/gdm-x-session[1395]: (WW) AMDGPU(0): Output DisplayPort-2: Strange aspect ratio (1198/337), consider adding a quirk
Nov 09 21:54:14 archlinux /usr/lib/gdm-x-session[1395]: (WW) AMDGPU(0): Output DisplayPort-2: Strange aspect ratio (1198/337), consider adding a quirk
Nov 09 21:54:14 archlinux /usr/lib/gdm-x-session[1395]: (II) AMDGPU(0): Printing probed modes for output DisplayPort-2
Nov 09 21:54:14 archlinux /usr/lib/gdm-x-session[1395]: (II) AMDGPU(0): Modeline "5120x1440"x144.0  1173.00  5120 5168 5200 5280  1440 1443 1453 1543 +hsync -vsync (222.2 kHz eP)

No outputs attached to the intel chip, you're running on xf86-video-amdgpu instead of eg. reverse-prime and an LG ultrawide that the driver complains about.
Do you have some other output (FullHD TV or so)?
Did the problem exist w/o xf86-video-amdgpu?

Offline

#9 2023-11-09 22:56:52

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Yes, I thought that was odd but I'm the one asking for help so...

Just booted with amdgpu.runpm=0 amdgpu.bapm=0 amdgpu.aspm=0 pcie_aspm=off amdgpu.dpm=0 and it hung, as predicted

sudo journalctl -b -1 | curl -F 'file=@-' 0x0.st  :  http://0x0.st/HtGK.txt

Booted again without amdgpu.dpm=0, no effect on FPS

sudo journalctl -b -1 | curl -F 'file=@-' 0x0.st  :  http://0x0.st/HtGP.txt

I will remove the added kernel parameters

I will also remove xf86-video-amdgpu and reboot with a spare 1080p monitor I have

Do I need something connected to the iGPU as well as the dGPU?

Offline

#10 2023-11-09 23:23:43

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Booted with, after the other monitor, what seems like the smallest screen in the world

http://0x0.st/HtGT.txt

No effect on FPS

Offline

#11 2023-11-10 08:09:00

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

Do I need something connected to the iGPU as well as the dGPU?

"possibly", see the caveat in https://wiki.archlinux.org/title/PRIME#Reverse_PRIME (though that's for reverse prime which you've not been running at any time, but god knows what the cause of that is)

Offline

#12 2023-11-10 12:44:26

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Bit confused.  Isn't Reverse PRIME for laptops?

Will the iGPU have to be plugged into a monitor?  I can plug it into the same monitor or I have an HDMI dummy plug I could use.  With the current BIOS settings if I plug it into my monitor I think the monitor will be iGPU powered and the AMD card will be second.  Although I do have PBP on this screen so I might be able use both together

Offline

#13 2023-11-10 13:53:44

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

Reverse prime is for when you've outputs attached to the non-rendering device.
As mentioned, it does't /really/ fit your situation, but only because you had the IGP completely disabled and were running on the GPU in the other case.
You've not tried to run the server on the IGP (and attach the monitor there) and DRI_PRIME invoke the GPU only, have you?

Edit: for the reverse prime situation you'd need two outputs (one on the GPU, causing the reverse prime, one on the IGP to mitigate that weird bug - though I guess it's just a prime-sync related issue)

Last edited by seth (2023-11-10 13:54:40)

Offline

#14 2023-11-10 23:39:35

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Now I have HDMI from the iGPU and DP from the dGPU.  The iGPUS is set to default in the BIOS.  Both outputs are connected to the same monitor.

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Raptor Lake-S GT1 [UHD Graphics 770] (rev 04)
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 32 [Radeon RX 7700 XT / 7800 XT] (rev c8)

glxinfo -B

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel (0x8086)
    Device: Mesa Intel(R) Graphics (RPL-S) (0xa780)
    Version: 23.2.1
    Accelerated: yes
    Video memory: 31640MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.6
    Max compat profile version: 4.6
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (RPL-S)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-arch1.2
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-arch1.2
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-arch1.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

DRI_PRIME=1 glxinfo -B

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: AMD (0x1002)
    Device: AMD Radeon RX 7800 XT (gfx1101, LLVM 16.0.6, DRM 3.54, 6.6.1-arch1-1) (0x747e)
    Version: 23.2.1
    Accelerated: yes
    Video memory: 16384MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.6
    Max compat profile version: 4.6
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 16112 MB, largest block: 16112 MB
    VBO free aux. memory - total: 15768 MB, largest block: 15768 MB
    Texture free memory - total: 16112 MB, largest block: 16112 MB
    Texture free aux. memory - total: 15768 MB, largest block: 15768 MB
    Renderbuffer free memory - total: 16112 MB, largest block: 16112 MB
    Renderbuffer free aux. memory - total: 15768 MB, largest block: 15768 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 16384 MB
    Total available memory: 32204 MB
    Currently available dedicated video memory: 16112 MB
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon RX 7800 XT (gfx1101, LLVM 16.0.6, DRM 3.54, 6.6.1-arch1-1)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-arch1.2
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-arch1.2
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-arch1.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Using PBP I have set each output to one half each, splitting the display in two.  I have also set the display to 2560x1440 so that it functions as a standard 1440p screen, with large black bards on each side.  Both of these produce the same results.  Below I'm using Game >  Custom > Fullscreen Disabled > 720p because it's quick to load and allows me to view nvtop.

$ unigine-superposition
FluxBB iGPU FluxBB iGPU
FPS fluctuates widely and extremely quickly between these approximate values, only by screenshotting am I able to actually read a number

$ DRI_PRIME=1 unigine-superposition
FluxBB dGPU
FPS is pretty steady at this.

The iGPU is arguably better than my 16GB AMD

With the dGPU running the benchmark I get the same stuck at 96Mhz etc etc

The PRIME link says I should install xf86-video-amdgpu.  I've just uninstalled that

sudo pacman -S xf86-video-amdgpu xf86-video-intel

Rebooting.....

Offline

#15 2023-11-11 01:50:00

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Well that didn't work.  Whoever invented chroot - thank you

Offline

#16 2023-11-11 13:27:16

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

You could probably also have booted the multi-user.target (2nd link below), xf86-video-intel in particular is a really bad idea, but maybe (though I'm not holding my breath) xf86-video-amdgpu helps to power up the AMD GPU.

The problem is however that you're stuck in the low performance mode andfrom your other thread can't even manually get out of that.
That's be the amdgpu kernel module.

For a re-cap: have you tried not-gnome (eg. openbox)?
Have you tried to boost the GPU w/ a different testcase? Eg. https://archlinux.org/packages/extra/x86_64/vkmark/ ?

Offline

#17 2023-11-11 19:56:52

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

I managed to get to cli but it hung when I did pacman -Rnsu so I went for chroot.  I do wonder if screen / tmux might have worked but I don't plan on finding out

vkmark - same results

Will try xf86-video-amdgpu again but it was installed before

I'm going to try SDDM and KDE Plasma

Offline

#18 2023-11-11 19:59:55

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

Please try a non-compositing WM and X11, for plasma, shift+alt+F12 toggles the compositor.

Offline

#19 2023-11-11 21:13:30

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

xf86-video-amdgpu is installed

Tried Openbox and KDE with SDDM

Same results

Offline

#20 2023-11-11 21:40:20

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

grumpf.

Sanity check: you didn't forget to attach the dedicated power supply )6/8-pin connectors) and made sure that the GPU is seated in the PEG slot your board manual suggests?

Offline

#21 2023-11-11 22:11:46

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

The GPU works fine under a "Windows To Go" usb so I presume it's plugged in ok

Offline

#22 2023-11-11 22:20:39

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

In the next few days I plan to put the GPU in my old machine and see if I can get anything different out of it to see if it's a BIOS / hardware issue.  However I built my old machine in February 2016 and I think it could have PCIe v3 so I'm not sure if this will be a good test or not

Offline

#23 2023-11-12 00:15:32

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Obviously any other idea are very welcome

Offline

#24 2023-11-12 14:40:59

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: 7800 XT extremely low FPS on fresh install

The GPU works fine under a "Windows To Go" usb

So we can expect it to be not the HW.

Have you tested the behavior w/ some live distro? (grml, knoppix - maybe some webgl testcase, since it's probalby down to getting the GPU to clock up)

Offline

#25 2023-11-12 21:19:36

dIQi
Member
Registered: 2023-11-04
Posts: 67

Re: 7800 XT extremely low FPS on fresh install

Not the hardware unless there's something specific to this NUC.  I thought Intel's HW was pretty well supported under Linux.  Maybe I was wrong.  Officially Intel don't support Linux on this model but that's true of most hardware I've run Linux on

I've tried other distros on usb:

ubuntu-23.10.1-desktop-amd64.iso because it's closest to the setup that was used in the Phoronix article.  I also used this as a persistent usb in order to install the closed source drivers

ubuntu-22.04.3-desktop-amd64.iso as a persistent usb because that's the distro the closed source drivers are meant for

Garuda-dr460nized-gaming-linux-zen-230501.iso because I thought a gaming distro might have ironed out GPU issues

Nobara-38-GNOME-2023-08-29.iso because it ships with an older kernel - which I've since realised might have been a waste of time

Only Windows works sad

I'll try your suggestions

Last edited by dIQi (2023-11-12 21:21:59)

Offline

Board footer

Powered by FluxBB