You are not logged in.

#1 2023-11-10 22:55:35

Xenfo
Member
From: Montreal, QC
Registered: 2021-11-06
Posts: 33
Website

[SOLVED] Network speeds have had a huge drop

A couple weeks ago my download speeds were consistently about ~15-20mb/s and now they're always fluctuating to as low as ~800kb/s. I'm using NetworkManager with iwd backend.

Journal: http://0x0.st/HtRA.txt

Consecutive runs of wget.

❯ wget https://sabnzbd.org/tests/internetspeed/50MB.bin
--2023-11-10 17:52:03--  https://sabnzbd.org/tests/internetspeed/50MB.bin
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving sabnzbd.org (sabnzbd.org)... 104.26.2.117, 172.67.69.176, 104.26.3.117, ...
Connecting to sabnzbd.org (sabnzbd.org)|104.26.2.117|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50111000 (48M) [application/octet-stream]
Saving to: ‘50MB.bin.7’

50MB.bin.7                         100%[===============================================================>]  47.79M  15.7MB/s    in 3.0s    

2023-11-10 17:52:08 (15.7 MB/s) - ‘50MB.bin.7’ saved [50111000/50111000]


~ took 4s 
❯ wget https://sabnzbd.org/tests/internetspeed/50MB.bin
--2023-11-10 17:52:11--  https://sabnzbd.org/tests/internetspeed/50MB.bin
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving sabnzbd.org (sabnzbd.org)... 172.67.69.176, 104.26.3.117, 104.26.2.117, ...
Connecting to sabnzbd.org (sabnzbd.org)|172.67.69.176|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50111000 (48M) [application/octet-stream]
Saving to: ‘50MB.bin.8’

50MB.bin.8                         100%[===============================================================>]  47.79M  6.37MB/s    in 7.0s    

2023-11-10 17:52:19 (6.79 MB/s) - ‘50MB.bin.8’ saved [50111000/50111000]


~ took 7s 
❯ wget https://sabnzbd.org/tests/internetspeed/50MB.bin
--2023-11-10 17:52:20--  https://sabnzbd.org/tests/internetspeed/50MB.bin
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving sabnzbd.org (sabnzbd.org)... 172.67.69.176, 104.26.3.117, 104.26.2.117, ...
Connecting to sabnzbd.org (sabnzbd.org)|172.67.69.176|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50111000 (48M) [application/octet-stream]
Saving to: ‘50MB.bin.9’

50MB.bin.9                         100%[===============================================================>]  47.79M  1.81MB/s    in 25s     

2023-11-10 17:52:45 (1.95 MB/s) - ‘50MB.bin.9’ saved [50111000/50111000]


~ took 25s 
❯ wget https://sabnzbd.org/tests/internetspeed/50MB.bin
--2023-11-10 17:52:48--  https://sabnzbd.org/tests/internetspeed/50MB.bin
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving sabnzbd.org (sabnzbd.org)... 104.26.2.117, 104.26.3.117, 172.67.69.176, ...
Connecting to sabnzbd.org (sabnzbd.org)|104.26.2.117|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50111000 (48M) [application/octet-stream]
Saving to: ‘50MB.bin.10’

50MB.bin.10                        100%[===============================================================>]  47.79M  1.93MB/s    in 27s     

2023-11-10 17:53:16 (1.74 MB/s) - ‘50MB.bin.10’ saved [50111000/50111000]


~ took 27s 
❯ wget https://sabnzbd.org/tests/internetspeed/50MB.bin
--2023-11-10 17:53:38--  https://sabnzbd.org/tests/internetspeed/50MB.bin
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving sabnzbd.org (sabnzbd.org)... 104.26.2.117, 172.67.69.176, 104.26.3.117, ...
Connecting to sabnzbd.org (sabnzbd.org)|104.26.2.117|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50111000 (48M) [application/octet-stream]
Saving to: ‘50MB.bin.11’

50MB.bin.11                        100%[===============================================================>]  47.79M   953KB/s    in 45s     

2023-11-10 17:54:24 (1.05 MB/s) - ‘50MB.bin.11’ saved [50111000/50111000]


~ took 45s

Last edited by Xenfo (2023-11-19 23:41:32)

Offline

#2 2023-11-11 08:54:33

seth
Member
Registered: 2012-09-03
Posts: 45,087

Re: [SOLVED] Network speeds have had a huge drop

wget -O /dev/null https://sabnzbd.org/tests/internetspeed/50MB.bin

to rule out the local storage.
Did you test the LTS kernel?
enp5s0 still works at full speed?
Otherwise, can you test the LAN performance w/ eg. iperf3 (that's gonna require two LAN hosts running it)

Offline

#3 2023-11-19 23:41:09

Xenfo
Member
From: Montreal, QC
Registered: 2021-11-06
Posts: 33
Website

Re: [SOLVED] Network speeds have had a huge drop

Not sure what happened but it's stable now even without changing anything, so I'll mark as resolved.

Offline

#4 2023-11-25 09:44:28

seth
Member
Registered: 2012-09-03
Posts: 45,087

Re: [SOLVED] Network speeds have had a huge drop

Between you and the internet is your ISP -  and they all suck.
So if/when the issue re-emerges you want to test the LAN throughput to ensure it's a problem with your system or LAN config and not simply your ISP.
You can also test the system in a different context or at least make sure that other devices in your LAN have decent performance.

Offline

Board footer

Powered by FluxBB