You are not logged in.

#1 2023-11-16 11:06:55

rahul90
Member
Registered: 2023-11-16
Posts: 7

[SOLVED]Wifi has very low speed when connected to university wifi

I am newbie  , I have installed arch 3 weeks back . My laptop has very low speed when connected to University's wifi . It was fine when I was on Fedora .  But my android device works fine so are my friends laptops . But when I connect to my mobile hotspot it works fine . I thought it was some problem with driver , I looked it up on arch wiki found some solutions tried them but they didn't work .
Sometimes it works fine , but sometime it won't work for several days.

 lspci -k 
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
	DeviceName: Sanji2 
	Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter
	Kernel driver in use: rtl8723be
	Kernel modules: rtl8723be

if I ping some it works , sometimes it shows 90% packet loss , some times that an error that dns is not resolved

dmsed
[ 5628.707780] wlo1: deauthenticating from 62:3a:1e:32:7a:e3 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 5630.404620] wlo1: authenticate with 72:3a:1e:32:7a:e3
[ 5630.404642] wlo1: 80 MHz not supported, disabling VHT
[ 5630.420052] wlo1: send auth to 72:3a:1e:32:7a:e3 (try 1/3)
[ 5630.426577] wlo1: authenticated
[ 5630.432620] wlo1: associate with 72:3a:1e:32:7a:e3 (try 1/3)
[ 5630.439864] wlo1: RX AssocResp from 72:3a:1e:32:7a:e3 (capab=0x1431 status=0 aid=4)
[ 5630.440115] wlo1: associated
[ 5630.476079] wlo1: Limiting TX power to 20 (20 - 0) dBm as advertised by 72:3a:1e:32:7a:e3
[ 5804.554138] wlo1: deauthenticating from 72:3a:1e:32:7a:e3 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 5806.370414] wlo1: authenticate with 62:3a:1e:32:7a:e3
[ 5806.370433] wlo1: 80 MHz not supported, disabling VHT
[ 5806.380660] wlo1: send auth to 62:3a:1e:32:7a:e3 (try 1/3)
[ 5806.384636] wlo1: authenticated
[ 5806.385558] wlo1: associate with 62:3a:1e:32:7a:e3 (try 1/3)
[ 5806.393104] wlo1: RX AssocResp from 62:3a:1e:32:7a:e3 (capab=0x1421 status=0 aid=1)
[ 5806.393316] wlo1: associated
[ 5806.595727] wlo1: Limiting TX power to 20 (20 - 0) dBm as advertised by 62:3a:1e:32:7a:e3
[ 5858.164656] wlo1: deauthenticating from 62:3a:1e:32:7a:e3 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 5860.909065] wlo1: authenticate with 72:3a:1e:32:7a:e3
[ 5860.909123] wlo1: 80 MHz not supported, disabling VHT
[ 5860.924658] wlo1: send auth to 72:3a:1e:32:7a:e3 (try 1/3)
[ 5861.026908] wlo1: send auth to 72:3a:1e:32:7a:e3 (try 2/3)
[ 5861.130328] wlo1: send auth to 72:3a:1e:32:7a:e3 (try 3/3)
[ 5861.233416] wlo1: authentication with 72:3a:1e:32:7a:e3 timed out
[ 5861.416742] wlo1: authenticate with 72:3a:1e:32:80:20
[ 5861.416801] wlo1: 80 MHz not supported, disabling VHT
[ 5861.427249] wlo1: send auth to 72:3a:1e:32:80:20 (try 1/3)
[ 5861.437686] wlo1: authenticated
[ 5861.443449] wlo1: associate with 72:3a:1e:32:80:20 (try 1/3)
[ 5861.546777] wlo1: associate with 72:3a:1e:32:80:20 (try 2/3)
[ 5861.650300] wlo1: associate with 72:3a:1e:32:80:20 (try 3/3)
[ 5861.753586] wlo1: association with 72:3a:1e:32:80:20 timed out
[ 5863.298168] wlo1: authenticate with 72:3a:1e:32:7a:e3
[ 5863.298227] wlo1: 80 MHz not supported, disabling VHT
[ 5863.314978] wlo1: send auth to 72:3a:1e:32:7a:e3 (try 1/3)
[ 5863.317726] wlo1: authenticated
[ 5863.320216] wlo1: associate with 72:3a:1e:32:7a:e3 (try 1/3)
[ 5863.337940] wlo1: RX AssocResp from 72:3a:1e:32:7a:e3 (capab=0x1431 status=0 aid=3)
[ 5863.338112] wlo1: associated
[ 5863.427309] wlo1: Limiting TX power to 20 (20 - 0) dBm as advertised by 72:3a:1e:32:7a:e3
 find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f
bluetooth.service                        | bluetooth.target.wants
dbus-org.bluez.service                   | system
dbus-org.freedesktop.nm-dispatcher.service | system
dbus-org.freedesktop.timesync1.service   | system
display-manager.service                  | system
gcr-ssh-agent.socket                     | sockets.target.wants
getty@tty1.service                       | getty.target.wants
NetworkManager.service                   | multi-user.target.wants
NetworkManager-wait-online.service       | network-online.target.wants
p11-kit-server.socket                    | sockets.target.wants
pipewire-pulse.socket                    | sockets.target.wants
pipewire-session-manager.service         | user
pipewire.socket                          | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
systemd-timesyncd.service                | sysinit.target.wants
wireless-regdom.service                  | multi-user.target.wants
wireplumber.service                      | pipewire.service.wants
 sudo journalctl -b | curl -F 'file=@-' 0x0.st

http://0x0.st/HvJe.txt

Last edited by rahul90 (2023-11-28 17:40:39)

Offline

#2 2023-11-16 15:35:14

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [SOLVED]Wifi has very low speed when connected to university wifi

Random lines from the demesg won't help - there're three volontary disconnects followed by reconnects ~2s later
The last one tries and fails a different BSSID first.
Please post the output of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#3 2023-11-17 06:53:25

rahul90
Member
Registered: 2023-11-16
Posts: 7

Re: [SOLVED]Wifi has very low speed when connected to university wifi

seth wrote:

Random lines from the demesg won't help - there're three volontary disconnects followed by reconnects ~2s later
The last one tries and fails a different BSSID first.
Please post the output of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

updated the post.

Offline

#4 2023-11-17 07:57:39

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [SOLVED]Wifi has very low speed when connected to university wifi

There're no obvious errors, are you connecting to your phone on 2.4GHz as well?
What if you disable/rfkill bluetooth? (It's operating the in the 2.4GHz band as well, maybe there's interference)

Offline

#5 2023-11-17 08:44:17

rahul90
Member
Registered: 2023-11-16
Posts: 7

Re: [SOLVED]Wifi has very low speed when connected to university wifi

seth wrote:

There're no obvious errors, are you connecting to your phone on 2.4GHz as well?

My laptop can only connect to 2.4GHz , so yeah I am connecting to phone on 2.4GHz.

seth wrote:

What if you disable/rfkill bluetooth? (It's operating the in the 2.4GHz band as well, maybe there's interference)

no it still the same. Wifi works for time then it doesn't , 30 minutes ago it was working fine now it works 5 seconds and then doesn't work 30seconds .

Last edited by rahul90 (2023-11-17 08:44:50)

Offline

#6 2023-11-17 14:18:42

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [SOLVED]Wifi has very low speed when connected to university wifi

Does the journal you posted cover this behavior?

Nov 17 12:05:40 op NetworkManager[407]: <info>  [1700202940.2885] device (wlo1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "NITAP-Outsourcing"
…
Nov 17 12:05:40 op NetworkManager[407]: <info>  [1700202940.3250] policy: set 'NITAP-Outsourcing' (wlo1) as default for IPv4 routing and DNS
…
Nov 17 12:05:40 op NetworkManager[407]: <info>  [1700202940.6025] manager: NetworkManager state is now CONNECTED_SITE
…
Nov 17 12:05:41 op NetworkManager[407]: <info>  [1700202941.1872] manager: NetworkManager state is now CONNECTED_GLOBAL
Nov 17 12:05:42 op systemd[1]: NetworkManager-dispatcher.service: Deactivated successfully.
Nov 17 12:05:59 op NetworkManager[407]: <info>  [1700202959.8182] agent-manager: agent[41015e80fbd082a0,:1.31/org.freedesktop.nm-applet/1000]: agent registered
…
Nov 17 12:07:37 op systemd-timesyncd[373]: Timed out waiting for reply from 95.216.192.15:123 (0.arch.pool.ntp.org).
…
Nov 17 12:10:50 op NetworkManager[407]: <info>  [1700203250.6146] manager: NetworkManager state is now CONNECTED_SITE
Nov 17 12:10:50 op dbus-daemon[384]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.5' (uid=0 pid=407 comm="/usr/bin/NetworkManager --no-daemon")
Nov 17 12:11:00 op systemd[1]: NetworkManager-dispatcher.service: Deactivated successfully.
Nov 17 12:12:58 op NetworkManager[407]: <info>  [1700203378.1171] manager: NetworkManager state is now CONNECTED_GLOBAL
…
Nov 17 12:14:15 op NetworkManager[407]: <info>  [1700203455.3270] manager: (usb0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/5)
Nov 17 12:14:15 op NetworkManager[407]: <info>  [1700203455.3583] device (usb0): interface index 4 renamed iface from 'usb0' to 'enp0s20f0u2'

In a nutshell
----------------
12:05:40: NM connects to "NITAP-Outsourcing"
12:05:41: NM can ping ping.archlinux.org
12:07:37: you (from here on) fail to get an aswer from the timeserver
12:10:50: NM can no longer ping archlinux.org, but the local connection isn't (considered) lost
12:12:58: NM can ping ping.archlinux.org again
12:14:15: you plug some ethernet dongle

There're no driver or wpa errors, no disconnects - nothing.
1. How's the signal quality?
2. disable https://wiki.archlinux.org/title/Networ … domization
3. when the wifi "doesn't work", can you still "ping _gateway"?

Offline

#7 2023-11-17 15:09:45

rahul90
Member
Registered: 2023-11-16
Posts: 7

Re: [SOLVED]Wifi has very low speed when connected to university wifi

seth wrote:

1. How's the signal quality?

it is good , in network manager its shows 84%.

I am not at the uni right now ? will definitely try ?

seth wrote:

3. when the wifi "doesn't work", can you still "ping _gateway"?

Sometimes I can ping but there is 100% packet loss , sometimes it says it can't resolve dns .

And Should have said a long time back thank you for helping !!! .

Offline

#8 2023-11-17 15:14:44

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [SOLVED]Wifi has very low speed when connected to university wifi

The point is to ping the "_gateway", not a domain (DNS fails) or some WAN IP (might be a firewall etc. issue, but not between you and the AP)

Offline

#9 2023-11-20 04:24:25

rahul90
Member
Registered: 2023-11-16
Posts: 7

Re: [SOLVED]Wifi has very low speed when connected to university wifi

I can't ping the _gateway , whenever I can ping wifi returns

ping _gateway                                               
PING _gateway (172.180.0.1) 56(84) bytes of data.
64 bytes from _gateway (172.180.0.1): icmp_seq=52 ttl=255 time=5.32 ms
64 bytes from _gateway (172.180.0.1): icmp_seq=53 ttl=255 time=2.61 ms
^C
--- _gateway ping statistics ---
53 packets transmitted, 2 received, 96.2264% packet loss, time 52672ms
rtt min/avg/max/mdev = 2.608/3.964/5.320/1.356 ms

Offline

#10 2023-11-25 12:32:28

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [SOLVED]Wifi has very low speed when connected to university wifi

Sorry for the delay.

You can ping the gateway, but with an extreme packet loss.

Usually I'd tell you to reboot the router (certainly of the overall signal is good) but that's not an option and also there're too many "my uni wifi sucks" threads now.
I somewhat suspect that the TX power limit gets botched and you're super weak transmission signal gets frequently overyelled by your classmates.

Have you tried the behavior on hte LTS kernel?

Offline

#11 2023-11-27 17:43:27

rahul90
Member
Registered: 2023-11-16
Posts: 7

Re: [SOLVED]Wifi has very low speed when connected to university wifi

I don't know why or how it is working without any problem for past 2 days .
Thank you for helping .

Last edited by rahul90 (2023-11-27 17:43:54)

Offline

Board footer

Powered by FluxBB