You are not logged in.

#1 2024-02-12 12:37:59

Freakzz
Member
Registered: 2020-12-01
Posts: 58

Inconsistent cursor themes on GTK apps

So I recently switched to hyprland (from awesomewm, didnt uninstall neither awesome nor xorg) and I have been experiencing inconsistent cursor themes on apps that use GTK themes.
I've used LXAppearance to firstly, set the cursor theme, then went on all(or most) appropriate files to make the relevant changes so that the new cursor would apply anywhere. As of now, the cursor theme I've set works on all apps that don't use GTK themes (e.g. alacritty), however on those that do(firefox, galculator, eww...), the cursor theme switches to the default ('Adwaita') one. I've made changes on files such as

 ~/.icons/default/index.theme 

 /usr/share/icons/default/index.theme 

 ~/.config/gtk-3.0/settings.ini 

and yes, even in hyprland's config using the "env" variables.

The cursor theme continues to have inconsistencies, even after rebooting.


Suffering from crippling rice addiction.

Offline

#2 2024-04-05 15:56:23

kicka
Member
From: Sicily / Italy
Registered: 2012-10-18
Posts: 25

Re: Inconsistent cursor themes on GTK apps

Hi, sorry for the delay, i just see your post.
I had a similar problem coming from Plasma 6 to Hyprland.
In these example I will set "Breeze_Light" as the cursor theme and "30" as the cursor size, substitute them with your desired values.

$HOME/.config/hypr/hyprland.conf:

env = XCURSOR_THEME,Breeze_Light
env = XCURSOR_SIZE,30
env = HYPRCURSOR_THEME,Breeze_Light
env = HYPRCURSOR_SIZE,30

$HOME/.Xresources:

Xcursor.theme: Breeze_Light
Xcursor.size: 30

$HOME/.Xdefaults:

Xcursor.theme: Breeze_Light
Xcursor.size: 30

$HOME/.gtkrc-2.0:

gtk-cursor-theme-name="Breeze_Light"
gtk-cursor-theme-size=30

$HOME/.icons/default/index.theme:

[Icon Theme]
Inherits=Breeze_Light

$HOME/.config/gtk-3.0/settings.ini:

gtk-cursor-theme-name=Breeze_Light
gtk-cursor-theme-size=30

$HOME/.config/gtk-4.0/settings.ini:

gtk-cursor-theme-name=Breeze_Light
gtk-cursor-theme-size=30

$HOME/.config/xsettingsd/xsettingsd.conf:

Gtk/CursorThemeName "Breeze_Light"
Gtk/CursorThemeSize 45

Note that in last file i didn't put "30" as in the other files, but the result of (30 * 1.5) where 1.5 it's my current screen scaling value.

For QT applications use qt5ct and qt6ct .
In my case, having Plasma 6 installed side by side with Hyprland,  I use qt5ct-kde and qt6ct-kde instead.

Launch them with:

env QT_QPA_PLATFORMTHEME=qt5ct qt5ct
env QT_QPA_PLATFORMTHEME=qt6ct qt6ct

and set the cursor theme name and size from there.

After all of that, reboot.
Every GTK3, GTK4, QT5, QT6 or Electron application that I have tried so far have the same cursor size and theme after i setted all these files.
Hope that this could help.

Last edited by kicka (2024-04-10 05:01:44)

Offline

#3 2024-04-05 17:01:09

seth
Member
Registered: 2012-09-03
Posts: 51,206

Offline

Board footer

Powered by FluxBB