You are not logged in.

#1 2024-05-15 02:15:50

syn606
Member
Registered: 2024-05-15
Posts: 3

[SOLVED] Wifi card is not being detected after update

I use TP-Link Archer T2U PLUS which uses the driver rtl8821au, i downloaded that driver from AUR and everything was working fine but 2 day ago i update my system andi stopped detecting that usb wifi adapter.
when i run nmcli it shows

wlan1: disconnected
        "TP-Link Archer T2U PLUS"
        wifi (rtl88XXau), 3E:50:48:18:E9:18, hw, mtu 2312

Last edited by syn606 (2024-05-30 15:11:11)

Offline

#2 2024-05-15 02:37:35

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,703

Re: [SOLVED] Wifi card is not being detected after update

Did that module build against the new kernel?

Offline

#3 2024-05-17 09:35:59

hippopanda
Member
Registered: 2024-05-17
Posts: 4

Re: [SOLVED] Wifi card is not being detected after update

Same issue here. After I updated my system yesterday, today my wifi card is undetected. The kernel module comes with the kernel itself.

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8852BE PCIe 802.11ax Wireless Network Controller
	DeviceName: Realtek
	Subsystem: Lenovo Device 4853
	Kernel modules: rtw89_8852be
$ sudo dmesg | grep rtw89
[    9.308258] rtw89_8852be 0000:03:00.0: loading /lib/firmware/rtw89/rtw8852b_fw-1.bin.zst failed with error -22
[    9.308262] rtw89_8852be 0000:03:00.0: Direct firmware load for rtw89/rtw8852b_fw-1.bin failed with error -22
[    9.308282] rtw89_8852be 0000:03:00.0: loading /lib/firmware/rtw89/rtw8852b_fw.bin.zst failed with error -22
[    9.308283] rtw89_8852be 0000:03:00.0: Direct firmware load for rtw89/rtw8852b_fw.bin failed with error -22
[    9.308285] rtw89_8852be 0000:03:00.0: failed to early request firmware: -22
[    9.308327] rtw89_8852be 0000:03:00.0: enabling device (0000 -> 0003)
[    9.309440] rtw89_8852be 0000:03:00.0: loading /lib/firmware/rtw89/rtw8852b_fw.bin.zst failed with error -22
[    9.309442] rtw89_8852be 0000:03:00.0: Direct firmware load for rtw89/rtw8852b_fw.bin failed with error -22
[    9.309481] rtw89_8852be 0000:03:00.0: failed to wait firmware completion
[    9.309482] rtw89_8852be 0000:03:00.0: failed to setup chip information
[    9.309868] rtw89_8852be: probe of 0000:03:00.0 failed with error -22
$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether e4:a8:df:d3:0a:06 brd ff:ff:ff:ff:ff:ff
$ pacman -Q linux
linux 6.8.9.arch1-2

EDIT: Downgrading the kernel to 6.8.7.arch1-2 did not help.

Last edited by hippopanda (2024-05-17 09:51:31)

Offline

#4 2024-05-17 13:16:00

seth
Member
Registered: 2012-09-03
Posts: 53,182

Re: [SOLVED] Wifi card is not being detected after update

Don't grep, also your situation (w/ an in-tree driver fro a different chip) is likely different from the OPs

Offline

#5 2024-05-17 13:24:33

hippopanda
Member
Registered: 2024-05-17
Posts: 4

Re: [SOLVED] Wifi card is not being detected after update

seth wrote:

Don't grep, also your situation (w/ an in-tree driver fro a different chip) is likely different from the OPs

Thanks. I will open a separate topic, then.

Offline

#6 2024-05-17 16:32:12

syn606
Member
Registered: 2024-05-15
Posts: 3

Re: [SOLVED] Wifi card is not being detected after update

But is there any solution of it ?

Offline

#7 2024-05-17 18:21:32

loqs
Member
Registered: 2014-03-06
Posts: 17,714

Re: [SOLVED] Wifi card is not being detected after update

syn606 wrote:

But is there any solution of it ?

Please post the full system journal from a boot with the issue.

Offline

#8 2024-05-17 19:07:21

seth
Member
Registered: 2012-09-03
Posts: 53,182

Re: [SOLVED] Wifi card is not being detected after update

Also

Scimmia wrote:

Did that module build against the new kernel?

dkms status

Offline

#9 2024-05-20 23:47:55

luiscrjunior
Member
Registered: 2020-10-24
Posts: 8

Re: [SOLVED] Wifi card is not being detected after update

Same thing here, with TP-Link Archer T2U PLUS. Stopped working after kernel upgrade.

SOLVED rebuilding the driver. Using this one.

$ lsusb
Bus 003 Device 002: ID 2357:0120 TP-Link Archer T2U PLUS [RTL8821AU]
$ sudo dkms status
rtl8821au/5.12.5.2, 6.9.1-arch1-1, x86_64: installed
$ ip addr
3: wlp0s20u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether f0:a7:31:b0:a7:dc brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.7/24 brd 192.168.0.255 scope global dynamic wlp0s20u1
       valid_lft 86068sec preferred_lft 86068sec
    inet6 2804:14d:4c52:820b:3fe4:fbdd:d7e8:86ce/64 scope global dynamic noprefixroute 
       valid_lft 2443112sec preferred_lft 455912sec
    inet6 fe80::6f89:aa66:f185:82a4/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Last edited by luiscrjunior (2024-05-21 00:12:04)

Offline

#10 2024-05-30 15:11:50

syn606
Member
Registered: 2024-05-15
Posts: 3

Re: [SOLVED] Wifi card is not being detected after update

i did the same and mine issue is fixed too thanks to everyone for replying

Offline

Board footer

Powered by FluxBB