You are not logged in.

#1 2024-05-17 19:42:08

drdoom
Member
Registered: 2024-03-08
Posts: 9

DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

I'm trying to run DaVinci Resolve I have a laptop with an NVIDIA 4070 dedicated and an AMD Radeon for integrated/for on-battery. 

I'm booted into fully dedicated mode so the NVIDA card is driving everything; this works for games and other apps no problem but for some reason DaVinci doesn't see it and only shows the AMD chip in GPU Configuration section

The attached screenshot shows that section and my NVIDIA drivers/utils installed

edit: i dont see attachments support but anyway take my word for it
the version I am trying to run is 18.6 stable
https://aur.archlinux.org/packages/davinci-resolve

Last edited by drdoom (2024-05-22 04:00:32)

Offline

#2 2024-05-18 20:11:32

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,205

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

DR creates a log file , please post the contents of that file.

attachments are not supported, but there are alternatives . https://wiki.archlinux.org/title/Genera … s_and_code


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2024-05-22 02:32:25

drdoom
Member
Registered: 2024-03-08
Posts: 9

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

okay sure, yep here it confirms only Detecting 1 GPUs:

0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,549 | Running DaVinci Resolve v18.6.6.0007 (Linux/Clang x86_64)
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,549 | BMD_BUILD_UUID ae8e413a-f0a7-4d57-9b6f-d2ea8b529ffa
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,549 | BMD_GIT_COMMIT 3f827ef0d730e66d9a676870f5237d1a0008c1ec
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,549 | Starting GPUDetect 1.2_5-a6
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 | Done in 123 ms.
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 | Detected System:
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - OS: Linux EndeavourOS
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - Model: ASUSTeK GA402XV
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - System ID: 5a7cfc5977714efe9a7df0631e5efc9c
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - CPU: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics, 16 threads, x86-64
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - RAM: 23.2 GiB used of 30.6 GiB
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - NVIDIA GPU Driver: 550.54, supports CUDA 12.4
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 | Detected 1 GPUs:
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - "AMD Radeon Graphics" (gpu:af87dd0c.3f2d22db) <- Main Display GPU
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |     Discrete, 142 MiB used of 512 MiB VRAM, PCI:101:0.0
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |     Matches: OpenCL, XOrg
0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 | Detected 1 monitors:
0x7caff201d000 | Main.GPUConfig       | INFO  | 2024-05-21 20:26:47,673 | Compute API set to automatic, defaulting to OpenCL.
0x7caff201d000 | Main.GPUConfig       | INFO  | 2024-05-21 20:26:47,673 | Selected compute API: OpenCL
0x7caff201d000 | Main.GPUConfig       | INFO  | 2024-05-21 20:26:47,673 | Automatic GPU Selection:
0x7caff201d000 | Main.GPUConfig       | INFO  | 2024-05-21 20:26:47,673 |   - "AMD Radeon Graphics" (gpu:af87dd0c.3f2d22db)
0x7caff201d000 | IO                   | INFO  | 2024-05-21 20:26:47,673 | RED InitializeSdk with library path at /opt/resolve/libs
0x7caff201d000 | IO                   | INFO  | 2024-05-21 20:26:47,700 | R3DAPI 8.4.0-53216 (20230817 Lx64S) R3DSDK 8.4.0-53216 (20230817 Lx64D C3B1) RED OPENCL 8.4.0-53119 (20230817) [/opt/resolve/libs/] init is successful
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,700 | 0 RED rocket cards available
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,700 | Decklink model name: '', version: ''
0x7caff201d000 | DVIP                 | INFO  | 2024-05-21 20:26:47,700 | DVIP release/18.6.6 build 4 (21300c06aa3bce41a9664e26f37d179b83ad2775). Release, version 18.6.6.
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,701 | Using DNxHR library v2.7.3.27r
0x7cae89a00680 | SyManager            | ERROR | 2024-05-21 20:26:47,797 | GetProjectLibraries() - Access token is empty
0x7cae8fe00680 | Fusion               | INFO  | 2024-05-21 20:26:47,886 | Fusion Build: 52756ec3_0004 (Mar 19 2024 08:39:53)
0x7cae78000680 | Fusion               | INFO  | 2024-05-21 20:26:47,888 | fusionsystem: = "/opt/resolve/libs/Fusion/libfusionsystem.so"
0x7cae78000680 | Fusion               | INFO  | 2024-05-21 20:26:47,891 | FusionLibs: = "/opt/resolve/libs/Fusion/"
0x7cae78000680 | Fusion               | INFO  | 2024-05-21 20:26:47,891 | UserData:   = "/home/derrick/.local/share/DaVinciResolve/Fusion"
0x7cae78000680 | Fusion               | INFO  | 2024-05-21 20:26:47,891 | Profiles:   = "UserData:Profiles/"
0x7cae6a000680 | DbCommon2            | INFO  | 2024-05-21 20:26:47,928 | Loading dblist file: /home/derrick/.local/share/DaVinciResolve/configs/.dblist
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,938 | NVDEC is using upto (988) MB
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,940 | NVDEC decodes VP9, chroma 4:2:0, bitdepth 8, upto 8192 x 8192
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,942 | NVDEC decodes VP9, chroma 4:2:0, bitdepth 10, upto 8192 x 8192
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,943 | NVDEC decodes AV1, chroma 4:2:0, bitdepth 8, upto 8192 x 8192
0x7cae8f400680 | IO                   | INFO  | 2024-05-21 20:26:47,944 | NVDEC decodes AV1, chroma 4:2:0, bitdepth 10, upto 8192 x 8192
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,948 | Finished loading Application style sheet
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,958 | Show splash screen
0x7caff201d000 | Main                 | INFO  | 2024-05-21 20:26:47,958 | Show splash screen message: Starting Up
0x7caff201d000 | UI.GLContext         | INFO  | 2024-05-21 20:26:48,164 | Creating shared OpenGL context for this thread (1 total).
0x7caff201d000 | UI.GLContext         | INFO  | 2024-05-21 20:26:48,168 | Initialized OpenGL 4.5 (requested 4.5) on device 'NVIDIA Corporation NVIDIA GeForce RTX 4060 Laptop GPU/PCIe/SSE2'
0x7cae55e00680 | LeManager            | INFO  | 2024-05-21 20:26:48,173 | 521, 29
0x7caff201d000 | BtCommon             | INFO  | 2024-05-21 20:26:48,173 | Memory config: reserved=5869M pinned=4000M log=0
0x7caff201d000 | BtCommon             | INFO  | 2024-05-21 20:26:48,174 | Using default pooled memory manager
0x7cae55400680 | BtCommon             | INFO  | 2024-05-21 20:26:48,174 | BtResourceManager Process Thread Started
0x7caff201d000 | IO                   | INFO  | 2024-05-21 20:26:48,176 | Setting codec capacity (0)
0x7caff201d000 | SyManager            | INFO  | 2024-05-21 20:26:48,177 | Total: 20, NumDtThreads: 8, NumComms: 0, NumSites: 1

0x7caff201d000 | SyManager            | INFO  | 2024-05-21 20:26:48,177 | Lookaheads -> playback = 20, record = 20, stop = 2

other apps are using the NVIDA fine; for example in Blender Prefs > System > CUDA tab it has "NVIDIA GeForce RTX 4060 Laptop GPU"  checked

Offline

#4 2024-05-22 03:09:02

drdoom
Member
Registered: 2024-03-08
Posts: 9

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

Oh i seem to be having this same issue

https://bbs.archlinux.org/viewtopic.php … 4#p2126194

edit: fixed it similarly by installing the same version of opencl-nvidia as the other nvidia drivers on this system

https://archive.archlinux.org/packages/o/opencl-nvidia/

edit2: well the next issue is there is no video playback; ie- you can't scrub a video timeline and video thumbnails are all just blank

so something is still wrong with my setup on dedicated NVIDIA

if I boot into hybrid mode on my laptop then Davinci works fine cause it will use the AMD chip (with painfully slow rendering times)

Last edited by drdoom (2024-05-22 04:01:59)

Offline

#5 2024-05-22 10:24:36

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,205

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

You could try to install cuda to see if DR uses that instead of opencl.

Unfortunately the output shows Endeavour OS.

0x7caff201d000 | GPUDetect            | INFO  | 2024-05-21 20:26:47,673 |   - OS: Linux EndeavourOS

Do you also have an archlinux install on this machine ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2024-05-22 22:16:42

drdoom
Member
Registered: 2024-03-08
Posts: 9

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

.... isnt Endeavor just a convenience installer for Arch ?

Offline

#7 2024-05-23 08:26:19

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,205

Re: DaVinci Resolve doesn't detect NVIDIA GPU (only AMD card)

Nope, it's  a different distro with their own repositories, mirrors, developers, support channels etc.

EndeavourOS homepage wrote:

EndeavourOS is an Arch-based distro


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB