You are not logged in.

#1 2026-09-25 08:39:55

PeterCu
Member
Registered: 2026-09-24
Posts: 1

[SOLVED] Update of openldap to version 2.7.1 broke slapd

Error Message in slapd.service:
Sep 24 15:49:18 emserver.eselchaos slapd[390]: mdb_db_open: database "dc=eselchaos" cannot be opened: MDB_INVALID: File is not an LMDB file (-30793). Administrator intervention needed!

Steps to repair the database:
Downgrade:
pacman -U /var/cache/pacman/pkg/openldap-2.6.13-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/libldap-2.6.13-1-x86_64.pkg.tar.zst

Backup Database:
slapcat -F /etc/openldap/slapd.d -l /tmp/slapd.ldif

Update openldap:
pacman -S openldap libldap

Restore database:
rm -v /var/lib/openldap/data.mdb
slapadd -F slapd.d -l /tmp/slapd.ldif
chown ldap:ldap /var/lib/openldap/data.mdb
systemctl  start slapd

Maybe this is useful for somebody.

Last edited by PeterCu (2026-09-27 08:25:33)

Offline

Board footer

Powered by FluxBB