You are not logged in.

#1 2007-08-24 20:02:49

gazj
Member
From: /home/gazj -> /uk/cambs
Registered: 2007-02-09
Posts: 679
Website

Apache won't start

For some reason apache won't start for me, i have uninstalled the whole of it, removed /etc/httpd ,reinstalled (pacman -Sy apache) still no luck, the output of apachectl -t seems fine, please see below.

[root@server /]# apachectl -t
httpd: apr_sockaddr_info_get() failed for server
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Syntax OK

Help me i'm so stuck

Thanks in advance

Offline

#2 2007-08-24 20:23:49

gazj
Member
From: /home/gazj -> /uk/cambs
Registered: 2007-02-09
Posts: 679
Website

Re: Apache won't start

Its ok, worked it out, you need to have your hostname that you have in /etc/rc.conf also in /etc/hosts

How long have i been using apache and i never knew that.

Offline

#3 2007-09-01 22:04:49

martincho
Member
Registered: 2007-09-01
Posts: 12

Re: Apache won't start

Hi

I have the same problem, could you please let me know where have to change it?

Here is the /etc/rc.conf:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="es_ES.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="America/Argentina/Buenos_Aires"
KEYMAP="la-latin1"
CONSOLEFONT="lat0-16"
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=()
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="localhost"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.1.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond)


# End of file

And this the /etc/hosts:

#
# /etc/hosts: static lookup table for host names
#

#<ip-address>    <hostname.domain.org>    <hostname>
127.0.0.1    localhost.localdomain    localhost

# End of file

Regards
Martin

Offline

#4 2007-09-02 07:03:43

gazj
Member
From: /home/gazj -> /uk/cambs
Registered: 2007-02-09
Posts: 679
Website

Re: Apache won't start

here are my files

/etc/rc.conf

HOSTNAME="server"

and /etc/hosts

#
# /etc/hosts: static lookup table for host names
#

#<ip-address>   <hostname.domain.org>   <hostname>

127.0.0.1               localhost.localdomain   localhost server

# End of file

All i did was add server (my hostname) on the end of the 127.0.0.1 localhost as another alias.

Hope this helps

Offline

#5 2007-09-02 07:20:13

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Apache won't start

martincho wrote:

DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond)

To me it looks like surfing to http://localhost should work because your rc.conf HOSTNAME setting is "localhost" and that hostname is already in your /etc/hosts file, so perhaps all that is missing is adding httpd to the end of your DAEMONS line to autostart apache. Watch the apache error_log file when using "/etc/rc.d/httpd restart" to see any errors, ie; use tail -f /var/log/httpd/error_log from another shell (as root).

Offline

#6 2007-09-05 22:24:53

shockware
Member
From: Romania
Registered: 2007-09-04
Posts: 6

Re: Apache won't start

Ok... here's my problem... httpd starts perfectly but... I can't get to http://localhost or to the apache server via my dns... my browser says Waiting for http://localhost... and does nothing... what can it be? I don't think there are any configuration problems... I also have webmin installed but I can't get to it either by typing in my browser localhost:10000 (10000 being the default port that webmin binds to... any help would be appreciated... thanx... smile

Offline

#7 2012-10-29 10:31:41

hisland
Member
Registered: 2012-10-29
Posts: 5

Re: Apache won't start

hi,

first run command:

hostname

then add the output to your /etc/hosts file:

#
# /etc/hosts: static lookup table for host names
#
#<ip-address>    <hostname.domain.org>    <hostname>
127.0.0.1    localhost.localdomain    localhost $output-here
# End of file

i resolve this problem by this method, wish it will help you!

Offline

#8 2012-10-29 13:07:42

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,272

Re: Apache won't start

Wow! This thread is five years old. What a necro bump.

Please don't do that, hisland. Closing.

BTW: Welcome to the forums nevertheless! smile


To know or not to know ...
... the questions remain forever.

Offline

Board footer

Powered by FluxBB