You are not logged in.

#1 2007-11-28 15:15:12

jacko
Member
Registered: 2007-11-23
Posts: 840

how to fix this annoying behavior???

Ok, firstly here is my setup. I have two HD's in the PC. One is a SATA 80g (ubuntu) and the other is a IDE ATA 20g (arch)HD. I boot which ever HD by pressing 'esc' when the computer loads, to get a menu from the bios. I then select which ever drive I want to use as the primary drive, this drive then boots. Works fine, I can boot into arch or ubuntu within seconds of restarting the machine.

But, as it seems this has its problems. First annoying behavior, I made a mistake in my menu.lst file so when I rebooted I had a kernel panic. At first I was surprised and didn't get the problem, so I booted into ubuntu. From there I mounted the IDE ATA (arch) device and went to the arch directory /boot/grub/menu.lst, rick clicked and viewed it with sudo gedit. Up pops the ubuntu menu.lst. HUH???? So after getting frustrated here I decided to try the arch fallback option on boot...

So I reboot the pc and 'esc' to select primary drive this time choosing the arch linux HD. It boots as normal and I get the option for fallback, I select this option and the arch linux kernel loads and then the rest starts to happen and all of a sudden I see ubuntu pTTy or something like that. HUH??? ubuntu tty while I am trying to boot into arch??? wtf is going on...

The one thing that I think contributes to the whole mess is how arch sees my IDE ATA drive as /dev/sda. I thought sda was only for sata devices and if so then this is how I suspect the problem is happening. Whats the deal with arch seeing my IDE drive as sata drive????

Last edited by jacko (2007-11-28 15:21:04)

Offline

#2 2007-11-28 15:30:11

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: how to fix this annoying behavior???

I should add, I finally got fallback to boot once I disconnected the SATA 80g ubuntu drive. sad Was my only option.

There has to be a better way to set this up, anyone have any good ideas?

Offline

#3 2007-11-28 15:39:55

brebs
Member
Registered: 2007-04-03
Posts: 3,406

Re: how to fix this annoying behavior???

It sounds like you're telling Arch to use the Ubuntu drive.

Use e.g. root=/dev/sda1 (or sdb1) in the kernel line in menu.lst

IDE is sda because that's how the kernel is written - the IDE and SATA code was merged.

Last edited by brebs (2007-11-28 15:41:38)

Offline

#4 2007-11-28 15:55:10

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: how to fix this annoying behavior???

Yeah, but to the bios and ubuntu, the 80 gig drive is the first sata device. Well that would explain my problem, but what can I do about it? How can I change it so its still as easy to boot but still be efficient and fast. Solutions, I am willing to hear????

Offline

#5 2007-11-28 19:10:57

kishd
Member
Registered: 2006-06-14
Posts: 399

Re: how to fix this annoying behavior???

Check out persistent block device naming on the wiki. It should help.

http://wiki.archlinux.org/index.php/Per … ice_naming


---for there is nothing either good or bad, but only thinking makes it so....
Hamlet, W Shakespeare

Offline

#6 2007-11-29 01:27:23

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: how to fix this annoying behavior???

kishd wrote:

Check out persistent block device naming on the wiki. It should help.

http://wiki.archlinux.org/index.php/Per … ice_naming

perfect, thank you. I was wondering why ubuntu had a UUID to access the HD, now I know why.

Offline

Board footer

Powered by FluxBB