You are not logged in.

#1 2004-05-26 16:19:35

Win
Member
Registered: 2004-03-04
Posts: 155

KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Hi.

After upgrading to kdelibs-3.2.2-3 and kdemultimedia-3.2.2-2, there is a KCMInit error every time KDE loads.  This error did not occur prior to this with a fully up-to-date KDE environment.

Can anyone provide any help/assistance here?

Thanks.

Win

Offline

#2 2004-05-26 16:48:09

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

You were the only one to post to the correct forum.  The new package maintainer is working on the fix:

http://bbs.archlinux.org/viewtopic.php?t=4751

Offline

#3 2004-05-26 20:42:55

dipp
Member
From: Sweden
Registered: 2004-02-13
Posts: 15

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Yep I got it too, mine segfaults when starting kde or when I try to execute kcminit manually. I hope the package maintainer is working fast as this is a pretty damn annoying error!


"Teaching should be such that what is offered is perceived as a valuable gift and not as a hard duty." -- Albert Einstein

Offline

#4 2004-05-26 22:02:50

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Check out your pacman cache (/var/cache/pacman/pkg), you may have the older versions there.  You can go back to the previous packages until the new ones are fixed.

Offline

#5 2004-05-27 10:04:51

dipp
Member
From: Sweden
Registered: 2004-02-13
Posts: 15

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

colnago wrote:

Check out your pacman cache (/var/cache/pacman/pkg), you may have the older versions there.  You can go back to the previous packages until the new ones are fixed.

Yeah I did that, I recentley cleaned it with pacman -Sc though so no luck there hmm


"Teaching should be such that what is offered is perceived as a valuable gift and not as a hard duty." -- Albert Einstein

Offline

#6 2004-05-28 02:19:32

Stinky
Member
From: The Colony, TX
Registered: 2004-05-28
Posts: 187

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Going back to the previous version work...For anybody else that is interested.

Offline

#7 2004-05-28 19:38:22

lomix
Member
From: Germany
Registered: 2004-05-26
Posts: 13

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Hi,
you can find the older version on "unofficial" server. I had to change kdelibs and kdemultimedia, now everthing is working fine.
For example: ftp://ftp.tu-chemnitz.de/pub/linux/suns … nofficial/

or any other server from your pacman.conf.
I`m using KDEMultimedia 3.2.2-1 and kdelibs-3.2.2-2.
Greetings


WS : Asus P4PE-X, P4 2.4 GHz HT, GF2 MX400
Slackware 10.0 :Kernel 2.8.1 / Xorg 6.8.1 / KDE 3.3
Arch-Linux Wombat 0.7: still in Heaven after HDD-Crash

Offline

#8 2004-05-28 20:46:06

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 231

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

After upgrading kde, artsd crashs everytime when I'm starting kde... Now I'm recompiling artsd with gcc 3.4 (I think that diffrent versions off gcc that artsd was compilled is problem). If artsd would work ok, artsd will need to recompile.


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#9 2004-05-28 21:06:47

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 231

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

After recompilling arts, everything is ok.


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#10 2004-05-29 00:46:12

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Thank you for the verification on recompiling arts, cmf mentioned that this should work on another thread, but I did not get around to trying it.

Offline

#11 2004-05-31 02:58:12

dekernel
Member
From: Vassar, MI USA
Registered: 2004-03-22
Posts: 117

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

I just finished building and installing arts-1.2.2-1, and I am still getting the seg fault. The build seemed to run through.

Offline

#12 2004-06-01 14:40:49

dipp
Member
From: Sweden
Registered: 2004-02-13
Posts: 15

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Hmm I am wondering when cmf will be uploading the new builds. I hope he really does it soon so that we can get rid of this very anoying error.


"Teaching should be such that what is offered is perceived as a valuable gift and not as a hard duty." -- Albert Einstein

Offline

#13 2004-06-06 09:15:23

rc
Member
Registered: 2004-03-06
Posts: 8

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

Hi,
had the same problem with  kdelibs-3.2.2-3 and kdemultimedia-3.2.2-2.
So i had to downgrade to  kdelibs-3.2.2-2 and kdemultimedia-3.2.2-1.
Now  kdelibs-3.2.2-4 and kdemultimedia-3.2.2-3 are out. I`m updating to those as i write this.
I`ll let you know if they solve that problem.

greetings,

rc

Offline

#14 2004-06-06 09:31:30

rc
Member
Registered: 2004-03-06
Posts: 8

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

So, installed the new packages and everything seems to work fine.
No kcminit error and arts is working well too.

greetings,
rc

Offline

#15 2004-06-09 12:58:54

dipp
Member
From: Sweden
Registered: 2004-02-13
Posts: 15

Re: KCMInit Error After Recent Upgrade: kdelibs-3.2.2-3

I installed the reverted packages and now everything seems to be working ok.


"Teaching should be such that what is offered is perceived as a valuable gift and not as a hard duty." -- Albert Einstein

Offline

Board footer

Powered by FluxBB