You are not logged in.

#1 2008-10-11 12:58:27

From: Poland, Kraków
Registered: 2008-02-01
Posts: 67

Cups - Unable to bind socket for address

At first I must say, than CUPS is the bigger shit I have ever seen on Linux. I have configured many daemons like: Apache, Lighttpd, MySQL or dnsmasq. Everything always just work, but not CUPS. I have configured it for 15-20 times. I always need about 5-10 hours to run it, and I've never known why it started work - probably it is randomly like Windows wink

Now, CUPS works fine on server, and I can print from laptop. But I've reinstalled Arch on PC. I've copied /etc/cups/ from laptop to PC, and now I can't start CUPS:

/etc/rc.d/cups start
:: Starting CUPS Daemon                         [BUSY]
cupsd: Child exited on signal 15!


I [11/Oct/2008:14:45:22 +0200] Listening to (IPv4)
I [11/Oct/2008:14:45:22 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [11/Oct/2008:14:45:22 +0200] Using default TempDir of /var/spool/cups/tmp...
I [11/Oct/2008:14:45:22 +0200] Configured for up to 100 clients.
I [11/Oct/2008:14:45:22 +0200] Allowing up to 100 client connections per host.
I [11/Oct/2008:14:45:22 +0200] Using policy "default" as the default!
I [11/Oct/2008:14:45:22 +0200] Full reload is required.
I [11/Oct/2008:14:45:22 +0200] Loaded MIME database from '/etc/cups': 35 types, 39 filters...
D [11/Oct/2008:14:45:22 +0200] Loading printer Domowa...
D [11/Oct/2008:14:45:22 +0200] Loading printer tmp...
D [11/Oct/2008:14:45:22 +0200] Discarding unused printer-stopped event...
E [11/Oct/2008:14:45:22 +0200] Filter "foomatic-rip" for printer "tmp" not available: No such file or directory
D [11/Oct/2008:14:45:22 +0200] Scanning /var/spool/cups for jobs...
I [11/Oct/2008:14:45:22 +0200] Full reload complete.
I [11/Oct/2008:14:45:22 +0200] Cleaning out old temporary files in "/var/spool/cups/tmp"...
E [11/Oct/2008:14:45:22 +0200] Unable to bind socket for address - Cannot assign requested address.
X [11/Oct/2008:14:45:22 +0200] No Listen or Port lines were found to allow access via localhost!


LogLevel debug
SystemGroup sys root
Listen localhost:631

DefaultAuthType Basic

I haven't any idea what it is: It think it is in USA.

socklist | grep 631 - clear

Only deference between pc and laptop it's kernel - on pc I use 2.6.24

English is not my first language, so please forgive me for my mistakes.


#2 2008-10-20 23:18:09

Registered: 2006-02-01
Posts: 1

Re: Cups - Unable to bind socket for address

I had the same problem.  I solved it doing 2 things.  (1) I replaced my /etc/cups/cups.conf with /etc/cups/cups.conf.default and (2) I added an acl option in the fstab.  Do a search on the forum for acl and you should see it.



Board footer

Powered by FluxBB