You are not logged in.

#1 2009-01-07 18:18:44

000krf
Member
Registered: 2008-10-30
Posts: 23

[SOLVED] Transparent URxvt position in Openbox

I've followed the "Urxvt in the background" topic in the ArchWiki Openbox entry. I am unable to get the terminal to appear anywhere but the upper right corner. I have tried various changes to the postion settings in the application section of the rc.xml file with no effect. It also doesn't seem to be on the bottom layer, as other windows can be moved below it. It also doesn't have focus.

My current application section is rc.xml

<application name="urxvt">
      <decor>no</decor>
      <focus>yes</focus>
      <position>
        <x>-5</x>
           <y>0</y>
          </position>
          <layer>below</layer>
          <desktop>all</desktop>
   </application>

Last edited by 000krf (2009-01-08 22:39:19)

Offline

#2 2009-01-07 19:11:15

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,629
Website

Re: [SOLVED] Transparent URxvt position in Openbox

Try using the application class as opposed to the name.

Offline

#3 2009-01-07 20:26:46

000krf
Member
Registered: 2008-10-30
Posts: 23

Re: [SOLVED] Transparent URxvt position in Openbox

That didn't work either. Here is what I have found, after further experimenting...
Here is my .Xdefaults file

URxvt*transparent:true
URxvt*scrollBar: false
#URxvt*borderLess: true
URxvt*foreground: White

And here is my current rc.xml file

<application name="urxvt">
      <decor>no</decor>
      <focus>yes</focus>
      <position>
          <x>-5</x>
          <y>5</y>
          </position>
          <layer>below</layer>
          <desktop>1</desktop>
 </application>

As shown above, my terminal appears as transparent, on the desktop, and in the upper right-hand corner, but with a black border. If I uncomment the "URxvt*borderLess: true" line the terminal appears in the upper left-hand corner and borderless. It is as though this line causes the position section in the rc.xml file to be ingnored.:(

Offline

#4 2009-01-07 22:38:18

pointone
Wiki Admin
From: Waterloo, ON
Registered: 2008-02-21
Posts: 379

Re: [SOLVED] Transparent URxvt position in Openbox

Oooh... Interesting! I had URxvt.borderless (commented out) in my .Xdefaults. I just tried changing it to URxvt.borderLess and now experience similar behaviour to what you describe: the window is created in the top left of my screen and I am unable to even select it. I needed to xkill the stubborn thing.

I run xmonad, though, so this isn't an Openbox-specifc problem.

Shouldn't <decor>no</decor> take care of that pesky border, though? Not too familiar with Openbox... only tried it for a few days before stumbling into the beauty that is xmonad.

What happen?


M*cr*s*ft: Who needs quality when you have marketing?

Offline

#5 2009-01-08 00:25:20

000krf
Member
Registered: 2008-10-30
Posts: 23

Re: [SOLVED] Transparent URxvt position in Openbox

I'm not sure how, but it is definitely linked to the URxvt*borderLess line in the .Xdefaults file.

Offline

#6 2009-01-08 22:38:52

000krf
Member
Registered: 2008-10-30
Posts: 23

Re: [SOLVED] Transparent URxvt position in Openbox

[SOLVED]

All I had to do was uncheck the box "Windows retain a border when undecorated" in the Appearance tab of the Openbox Configuration Manager.

Here is my final .Xdefaults file:

URxvt*transparent:true
URxvt*scrollBar: false
URxvt*foreground: White  #For a black or dark background

And the application section in the rc.xml file:

<application name="urxvt">
      <decor>no</decor>
      <focus>yes</focus>
      <position>
        <x>-5</x>
        <y>5</y>
      </position>
      <layer>below</layer>
      <desktop>all</desktop>
    </application>

This places my terminal in the upper right corner of my desktops.
Thanks to those who responded.

Offline

#7 2010-09-09 23:31:26

zandgreen
Member
Registered: 2010-08-12
Posts: 16

Re: [SOLVED] Transparent URxvt position in Openbox

@000krf: thanks a lot, man. I've been struggling all day on that.

Offline

#8 2010-09-19 22:17:13

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,158

Re: [SOLVED] Transparent URxvt position in Openbox

zandgreen, do not necro bump an old thread.

Read the forum etiquettes on the wiki.

Closing...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB