You are not logged in.

#1 2009-01-22 10:00:47

kaola_linux
Member
From: Bacolod City/Philippines
Registered: 2008-09-23
Posts: 513

Unable to start nm-applet as normal user[SOLVED]

Hi, I've installed networkmanager 0.7 once again...I had problems starting the nm-applet as normal user..I'm already a member of the "network" group..Any ideas?

Thanks in advance

Last edited by kaola_linux (2009-01-23 02:47:54)


Netbook (Acer Aspire One 110 || 160gb SATA HD || 1.5gb ram): archlinux i686 / KDEmod 4.3
Registered Linux User # 481212 / Machine Registration # 390468
"In a world without walls and fences, who needs windows and gates?"

Offline

#2 2009-01-22 10:25:03

u_no_hu
Member
Registered: 2008-06-15
Posts: 453

Re: Unable to start nm-applet as normal user[SOLVED]

I have an idea...why not state exactly what problems you have while starting it?


Don't be a HELP VAMPIRE. Please search before you ask.

Subscribe to The Arch Daily News.

Offline

#3 2009-01-22 10:29:09

Allan
Supreme Leader
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,599
Website

Re: Unable to start nm-applet as normal user[SOLVED]

Run "nm-applet" from the command line and post the output.

Offline

#4 2009-01-22 10:36:27

madhatter
Member
From: Freudenstadt, Germany
Registered: 2004-09-01
Posts: 59

Re: Unable to start nm-applet as normal user[SOLVED]

networkmanager changed it behaviour with 0.7, it doesn't matter if you're in the network group and instead it uses ConsoleKit (what the hell is that anyway?), so you have to start a ConsoleKit-Session first with ck-launch-session.
For me this caused a lot of troubles, so as an alternative way you can change the dbus settings to the old behaviour:

/etc/dbus-1/system.d/NetworkManager.conf:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_interface="org.freedesktop.NetworkManager"/>

        <allow own="org.freedesktop.NetworkManager.PPP"/>
                <allow send_destination="org.freedesktop.NetworkManager.PPP"/>
                <allow send_interface="org.freedesktop.NetworkManager.PPP"/>
        </policy>
    <!-- My hack -->
        <policy group="network">
                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_interface="org.freedesktop.NetworkManager"/>
        </policy>
        <!-- End of my hack -->
        <policy at_console="true">
                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_interface="org.freedesktop.NetworkManager"/>
        </policy>
        <policy context="default">
                <deny own="org.freedesktop.NetworkManager"/>
                <deny send_destination="org.freedesktop.NetworkManager"/>
                <deny send_interface="org.freedesktop.NetworkManager"/>

                <deny own="org.freedesktop.NetworkManager.PPP"/>
                <deny send_destination="org.freedesktop.NetworkManager.PPP"/>
                <deny send_interface="org.freedesktop.NetworkManager.PPP"/>
        </policy>

        <limit name="max_replies_per_connection">512</limit>
</busconfig>

and /etc/dbus-1/system.d/nm-applet.conf:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
    <policy user="root">
        <allow own="org.freedesktop.NetworkManagerUserSettings"/>

        <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
        <allow send_interface="org.freedesktop.NetworkManagerSettings"/>

        <!-- Only root can get secrets -->
        <allow send_interface="org.freedesktop.NetworkManagerSettings.Secrets"/>
    </policy>
    <!-- My hack -->
    <policy group="network">
        <allow own="org.freedesktop.NetworkManagerUserSettings"/>
        <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
        <allow send_interface="org.freedesktop.NetworkManagerUserSettings"/>

        <deny send_interface="org.freedesktop.NetworkManagerSetting.Secrets"/>
    </policy>
       <!-- end of my hack -->
    <policy at_console="true">
        <allow own="org.freedesktop.NetworkManagerUserSettings"/>

        <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
        <allow send_interface="org.freedesktop.NetworkManagerSettings"/>

        <!-- Only root can get secrets -->
        <deny send_interface="org.freedesktop.NetworkManagerSettings.Secrets"/>
    </policy>
    <policy context="default">
        <deny own="org.freedesktop.NetworkManagerUserSettings"/>

        <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
        <allow send_interface="org.freedesktop.NetworkManagerSettings"/>
        <!-- Only root can get secrets -->
        <deny send_interface="org.freedesktop.NetworkManagerSettings.Secrets"/>
    </policy>

    <limit name="max_replies_per_connection">512</limit>
</busconfig>

As you can see, it adds a policy for group="network" which is the same as at_console="true"

Offline

#5 2009-01-23 02:33:44

kaola_linux
Member
From: Bacolod City/Philippines
Registered: 2008-09-23
Posts: 513

Re: Unable to start nm-applet as normal user[SOLVED]

Here is the output:

[koala@myhost ~]$ nm-applet

** (nm-applet:2622): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service.
  Message: 'Connection ":1.24" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file'

Following what madhatter said, I can now use nm-applet as normal user...:)
Many thanks!!!:D

Last edited by kaola_linux (2009-01-23 02:47:23)


Netbook (Acer Aspire One 110 || 160gb SATA HD || 1.5gb ram): archlinux i686 / KDEmod 4.3
Registered Linux User # 481212 / Machine Registration # 390468
"In a world without walls and fences, who needs windows and gates?"

Offline

#6 2009-02-12 05:45:35

valeuf
Member
Registered: 2009-02-11
Posts: 8

Re: Unable to start nm-applet as normal user[SOLVED]

Works fine for me smile Thanks

Offline

#7 2009-02-19 00:19:51

tandycorp
Member
Registered: 2007-07-01
Posts: 65

Re: Unable to start nm-applet as normal user[SOLVED]

thanks from me too! I hope linux will not become bloated for security purposes.. well we will still be able to create alternative hacks, in case that happens wink

Last edited by tandycorp (2009-02-19 00:20:57)

Offline

#8 2009-04-26 17:34:38

coroa
Member
Registered: 2009-04-26
Posts: 3

Re: Unable to start nm-applet as normal user[SOLVED]

i add my thanks, but have to caution as well, that there is a typo in your hack to nm-applet.conf. The previous to last line should read:
        <deny send_interface="org.freedesktop.NetworkManagerSettings.Secrets"/>

The "s" in Settings is missing.

But i expect it to be non-critical as dbus probably reverts to the default context when nothing is specified on behalf of NetworkManagerSettings, which means the secrets are denied anyway.

Offline

#9 2010-02-09 17:03:59

havresylt
Member
Registered: 2010-01-11
Posts: 13

Re: Unable to start nm-applet as normal user[SOLVED]

It seems there has been some change in the syntax for the dbus files. Now, this

<allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
<allow send_interface="org.freedesktop.NetworkManagerUserSettings"/>

has to be replaced by

<allow send_destination="org.freedesktop.NetworkManagerUserSettings"
       send_interface="org.freedesktop.NetworkManagerUserSettings"/>

Also, for me the edits in NetworkManager.conf weren't enough. I basically copied the entire contents of the "at_console" section:

<policy group="network">
        <allow send_destination="org.freedesktop.NetworkManager"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.DBus.Introspectable"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.DBus.Properties"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.AccessPoint"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Connection.Active"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device.Cdma"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device.Wired"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device.Gsm"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device.Serial"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device.Wireless"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.Device"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.DHCP4Config"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.IP4Config"/>

    <allow send_destination="org.freedesktop.NetworkManager"
           send_interface="org.freedesktop.NetworkManager.VPN.Connection"/>
</policy>

Perhaps all of this wasn't necessary.

Offline

#10 2010-10-03 17:56:29

Loafers
Member
Registered: 2009-11-01
Posts: 92

Re: Unable to start nm-applet as normal user[SOLVED]

The little hack doesn't work for me.

I get the following error:

** (nm-applet:1976): WARNING **: get_all_cb: couldn't retriever system settings properties: (2) The name org.freedesktop.NetworkManagerSystemSettings was no provided by any .service files.

** (nm-applet:1976): WARNING **: fetch_connections_done: error fetching system connections: (2) The name org.freedesktop.NetworkManagerSystemSettings was no provided by any .service files.

Any suggestions?

I normally use WICD to manage all my wireless connections, but it causes my computer to fatally crash with my usb wireless adapter which I can't solve.

Offline

Board footer

Powered by FluxBB