You are not logged in.

#1 2009-04-01 17:32:29

Registered: 2008-12-22
Posts: 101

unable to debug php using apache + xdebug + vim

I am tryibg setup php debugging using vim + DBGp client plugin + Xdebug.  I set up things according this article … ation.html.  I have PHP 5.2.9 at Apache/2.2.11 . Every time I try to start debugging (in vim pressing F5 and than reload page with appended ?XDEBUG_SESSION_START=1) i got error message in vim:

Connection closed, stop debugging (<type 'exceptions.AttributeError'>, AttributeError("DbgProtocol instance has no attribute 'stop'",), <traceback object at 0x89df11c>)

There is no message in system logs.

According forums this can be result of many things
- loaded as regular extension, not zend extension (not my case, if it is loaded as regular extension it has warning message in phpinfo, tested at my machine)
- not reloading within 5sec after pressing F5 (but I tried many times as fast as possible)
- not accessible port - I setup xdebug tu use port 9000 in php.ini, but maybe I need to allow it in in some other place too (maybe /etc/hosts.allow ?)

Edit: I found newer version of vim plugin (, now the error message is simple "Connection Timeout"

If anybody have any idea where to search I would be very thankfull. I know I can use Xdebud with other IDEs, but I am very used to vim and also I use now pretty old notebook so IDEs like Eclipse are too heavy for me.

Xdebug part of php.ini:

xdebug.remote_enabled = 1
xdebug.remote_port = 9000
xdebug.remote_host = localhost

Xdebug part of phpinfo:

xdebug support    enabled
Version     2.0.3

Supported protocols    Revision
DBGp - Common DeBuGger Protocol     $Revision: $
GDB - GNU Debugger protocol     $Revision: 1.87 $
PHP3 - PHP 3 Debugger protocol     $Revision: 1.22 $

Directive    Local Value    Master Value
xdebug.auto_trace    Off    Off
xdebug.collect_includes    On    On
xdebug.collect_params    0    0
xdebug.collect_return    Off    Off
xdebug.collect_vars    Off    Off
xdebug.default_enable    On    On
xdebug.dump.COOKIE    no value    no value
xdebug.dump.ENV    no value    no value
xdebug.dump.FILES    no value    no value
xdebug.dump.GET    no value    no value
xdebug.dump.POST    no value    no value
xdebug.dump.REQUEST    no value    no value
xdebug.dump.SERVER    no value    no value
xdebug.dump.SESSION    no value    no value
xdebug.dump_globals    On    On
xdebug.dump_once    On    On
xdebug.dump_undefined    Off    Off
xdebug.extended_info    On    On
xdebug.idekey    root    no value
xdebug.max_nesting_level    100    100
xdebug.profiler_aggregate    Off    Off
xdebug.profiler_append    Off    Off
xdebug.profiler_enable    Off    Off
xdebug.profiler_enable_trigger    Off    Off
xdebug.profiler_output_dir    /tmp    /tmp
xdebug.profiler_output_name    cachegrind.out.%p    cachegrind.out.%p
xdebug.remote_autostart    Off    Off
xdebug.remote_enable    Off    Off
xdebug.remote_handler    dbgp    dbgp
xdebug.remote_host    localhost    localhost
xdebug.remote_log    no value    no value
xdebug.remote_mode    req    req
xdebug.remote_port    9000    9000
xdebug.show_exception_trace    Off    Off
xdebug.show_local_vars    Off    Off
xdebug.show_mem_delta    Off    Off
xdebug.trace_format    0    0
xdebug.trace_options    0    0
xdebug.trace_output_dir    /tmp    /tmp
xdebug.trace_output_name    trace.%c    trace.%c
xdebug.var_display_max_children    128    128
xdebug.var_display_max_data    512    512
xdebug.var_display_max_depth    3    3

Last edited by stabele (2009-04-01 18:08:24)


#2 2009-05-11 18:15:53

From: Eindhoven
Registered: 2008-11-21
Posts: 26

Re: unable to debug php using apache + xdebug + vim

Are you sure that 9000 is open when you refresh the page? Check that with `netstat --inet -l` within the 10 seconds that vim is listening for a signal.


Board footer

Powered by FluxBB