You are not logged in.

#1 2009-04-06 19:28:51

wrc1944
Member
From: Gainesville, Florida
Registered: 2007-10-07
Posts: 117

[SOLVED] Gnome problems still here, nautilus, and no regular session

After updating today I now I can't open a normal gnome session- only a failsafe session. the ~/.xsession errors show:

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: ssh-agent not found!
/etc/gdm/Xsession: Setup done, will execute: gnome-session
gnome-session[10497]: WARNING: Could not connect to ConsoleKit: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
gnome-session[10497]: CRITICAL: dbus_g_connection_get_connection: assertion `gconnection' failed
process 10497: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 3298.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
gnome-session[10497]: ******************* START ********************************
gnome-session[10497]: Frame 0: /usr/lib/gnome-session/gnome-session [0x418ab7]
gnome-session[10497]: Frame 1: /usr/lib/gnome-session/gnome-session [0x418c06]
gnome-session[10497]: Frame 2: /lib/libc.so.6 [0x7ff6b78ab150]
gnome-session[10497]: Frame 3: /lib/libc.so.6(gsignal+0x35) [0x7ff6b78ab0c5]
gnome-session[10497]: Frame 4: /lib/libc.so.6(abort+0x183) [0x7ff6b78ac5e3]
gnome-session[10497]: Frame 5: /usr/lib/libdbus-1.so.3 [0x7ff6ba383675]
gnome-session[10497]: Frame 6: /usr/lib/libdbus-1.so.3 [0x7ff6ba37f4ed]
gnome-session[10497]: Frame 7: /usr/lib/libdbus-1.so.3(dbus_connection_send_with_reply_and_block+0x12f) [0x7ff6ba3693bf]
gnome-session[10497]: Frame 8: /usr/lib/gnome-session/gnome-session [0x411cbc]
gnome-session[10497]: Frame 9: /usr/lib/gnome-session/gnome-session [0x411dc0]
gnome-session[10497]: Frame 10: /usr/lib/gnome-session/gnome-session [0x419d90]
gnome-session[10497]: Frame 11: /usr/lib/gnome-session/gnome-session [0x41a26f]
gnome-session[10497]: Frame 12: /lib/libc.so.6(__libc_start_main+0xe6) [0x7ff6b7897546]
gnome-session[10497]: Frame 13: /usr/lib/gnome-session/gnome-session [0x40ad59]
gnome-session[10497]: ******************* END ****************

This happened before and after I added the line

"AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop"

to /usr/share/applications, and changed X-GNOME-AutoRestart=true to =false as a workaround to the nautilus respawning problem here http://bbs.archlinux.org/viewtopic.php?id=69219 .
BTW, it stopped the respawing, but Nautilus now will not launch either from menus or command line.  I get this at command line:

[wrc@myhost ~]$ nautilus

(nautilus:10655): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.HalVolumeMonitor is not supported

(nautilus:10655): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.GPhoto2VolumeMonitor is not supported

** (nautilus:10655): WARNING **: Cannot connect to DBus Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

process 10655: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 3298.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
[wrc@myhost ~]$

Last edited by wrc1944 (2009-04-07 14:29:37)

Offline

#2 2009-04-06 22:21:05

JGC
Developer
Registered: 2003-12-03
Posts: 1,663

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

Put dbus in DAEMONS in /etc/rc.conf. You might want to add hal also.

Offline

#3 2009-04-06 23:22:28

wrc1944
Member
From: Gainesville, Florida
Registered: 2007-10-07
Posts: 117

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

Thanks much, JGC,
I did add dbus to rc.conf right before i checked back here, and it did allow me to boot to a regular gnome session.  However, Nautilus still would not launch. I read up on hal, and relaized hal would detect and launch dbus, so I removed dbus and added hal to the Daemons list.

It seemed to work fine on reboot, but when i got to the GDM screen, when I tried to type in user and password, each keystroke repeated 3 times, making it impossible to login.  I've rebooted into my Gentoo partition, and edited rc.conf back to dbus only, and will reboot and see if the key repeat problem gores away. Back soon. smile

Offline

#4 2009-04-06 23:36:05

wrc1944
Member
From: Gainesville, Florida
Registered: 2007-10-07
Posts: 117

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

OK- removing the hal daemon and putting in the dbus deamon got rid of the 3 for 1 key repeat problem in gdm and allowed me to start a gnome (or any other) session, but Nautilus still refuses to start while in gnome.  The "Starting File Manager" panel window appears, and tries, but about 10-15 seconds later gives up. roll

Guess I'll use Thunar or another file manager while in gnome, unless there is a fix. I was using GDM instead of KDM as I'm running markc's kde-svn packages on Arch, and figured at any time KDM might run into problems.

What in hal could cause a keystroke repeat problem in GDM and prevent logging in?  Maybe I'll try starting Nautilus while in kde or xfce4, and/or switch to KDM and see what happens.

Trying to start Nautilus in command line still gives me this

 [wrc@myhost ~]$ nautilus

(nautilus:3103): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.HalVolumeMonitor is not supported

(nautilus:3103): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.GPhoto2VolumeMonitor is not supported

** (nautilus:3103): WARNING **: Failed to initialize hal : (null)

process 3103: Attempt to remove filter function 0x7f87a127ead0 user data 0x222f970, but no such filter has been added
  D-Bus not built with -rdynamic so unable to print a backtrace
[wrc@myhost ~]$

Last edited by wrc1944 (2009-04-06 23:38:38)

Offline

#5 2009-04-06 23:48:01

CaptainShanks
Member
Registered: 2008-10-25
Posts: 57

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

JGC wrote:

Put dbus in DAEMONS in /etc/rc.conf. You might want to add hal also.

I thought HAL automatically called DBUS...?

Offline

#6 2009-04-06 23:52:15

wrc1944
Member
From: Gainesville, Florida
Registered: 2007-10-07
Posts: 117

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

Yes, hal calls dbus, but adding it to daemons causes gdm to have a key repeat problem, which disallows a login with user/password, as normal typing doesn't work. But apparently, not having hal running causes Natilus not to be able to launch. Seems like a classic catch 22 situation.

Offline

#7 2009-04-07 06:03:00

wrc1944
Member
From: Gainesville, Florida
Registered: 2007-10-07
Posts: 117

Re: [SOLVED] Gnome problems still here, nautilus, and no regular session

OK- I think I've SOLVED all my Nautilus problems, which included the endless respawning "Starting Filemanager windows" on the panel, the hal daemon related GDM 3 for 1 key repeat prevents login problem, and the Nautilus refusing to launch problem!
After reviewing the Gentoo Hal documetation, and realizing I had the xf86-input-evdev driver installed on Arch, I had forgotten that in order to get the mouse/keyboard to function I had to previously add a line in xorg.conf that was now conflicting with hal/dbus and the new xorg server version.

I just commented out this line in xorg.conf, like this

Section "ServerFlags"
 # Option "AllowEmptyInput" "false"
 Option "DontZap"   "false"
 EndSection

and added the hal daemon (which calls dbus) to my /etc/rc.conf, which allows evdev/hal/dbus to do it's thing.

Along with the edits to the /usr/share/applications/nautilus.desktop file (which is strangely named "File Manager" in Thunar, one of three files of the same name).  The edits made are:
X-GNOME-AutoRestart=false    # changed from =true
AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop    # added this line

Now, I can boot from GDM into a normal gnome session, and Nautilus launches normally, without endlessly repawning itself in the panel.

The fix itself was quite simple, but tracing the cause down and understanding it was not! big_smile

Last edited by wrc1944 (2009-04-07 06:27:21)

Offline

Board footer

Powered by FluxBB