You are not logged in.

#1 2009-04-14 19:39:08

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

The killswitch, and how NetworkManager thinks it's always on.

Since I updated my system about a day ago, NetworkManager seems unable to configure my wireless card for some unknown reason. Only thing that got updated that I can imagine affects NetworkManager would be HAL. Looking through the logs, I spotted this in /var/log/daemon.log

Multivac NetworkManager: <info>  Wireless now disabled by radio killswitch
Multivac NetworkManager: <info>  (ath0): supplicant manager state:  down -> idle
....
Multivac NetworkManager: <info>  (eth0): device state change: 1 -> 2
Multivac NetworkManager: <info>  (eth0): bringing up device.
Multivac NetworkManager: <info>  (eth0): preparing device.
Multivac NetworkManager: <info>  (eth0): deactivating device (reason: 2).
Multivac NetworkManager: <info>  (eth0): carrier now ON (device state 2)
Multivac NetworkManager: <info>  (eth0): device state change: 2 -> 3
Multivac NetworkManager: <info>  (eth0): carrier now OFF (device state 3)
Multivac NetworkManager: <info>  (eth0): device state change: 3 -> 2
Multivac NetworkManager: <info>  (eth0): deactivating device (reason: 40).
Multivac NetworkManager: <info>  (ath0): device state change: 1 -> 2
Multivac NetworkManager: <info>  (ath0): bringing up device.
Multivac NetworkManager: <info>  (ath0): preparing device.
Multivac NetworkManager: <info>  (ath0): deactivating device (reason: 2).

So yeah, seems NetworkManager thinks the killswitch is on. This is on a Acer Aspire One, which doesn't have a "real" killswitch, so to speak. To enable it, I'm using this in rc.local

/usr/bin/setkeycodes e055 159
/usr/bin/setkeycodes e056 158

However, I can flick the killswitch how many times I want, it doesn't make a difference to NetworkManager, it still thinks it's enabled. I can still connect with the wireless card manually through iwconfig or through wicd, so why this is specific to NetworkManager is quite the mystery. Still, I'd like to fix it if I'm able to.

Oh, and I've tried using both ath5k and madwifi-hal (from AUR), and that makes zero difference.

Anybody have any ideas or similar issues?

Last edited by Zom (2009-04-14 19:40:29)

Offline

#2 2009-04-14 21:43:58

hellblazer
Member
From: Cascais - Portugal
Registered: 2009-04-14
Posts: 3

Re: The killswitch, and how NetworkManager thinks it's always on.

I am having exactly the same problem in the stock kernel since updating the system today, in my acer aspire one. I'm using the kernel compiled from the kernel-one aur package build and network manager works fine.

Any ideas?

Small progress: by disabling the kill switch module (rfkill) in rc.conf i was able to use network manager in the stock kernel again, but this is no solution, i would like to actually use the switch...

Last edited by hellblazer (2009-04-14 21:58:34)

Offline

#3 2009-04-15 18:18:57

azolotko
Member
Registered: 2008-04-25
Posts: 5

Re: The killswitch, and how NetworkManager thinks it's always on.

I have this problem too. hellblazer, thank you for workaround.

Offline

#4 2009-04-15 18:33:08

luciferin
Member
Registered: 2007-05-10
Posts: 144

Re: The killswitch, and how NetworkManager thinks it's always on.

It's definately an upstream bug.  I'm not sure if it's specifically with HAL or with the 2.6.29 Kernel, but I believe it's the.  I've had the issue with Fedora on my AAO.

Offline

#5 2009-04-15 19:12:04

hellblazer
Member
From: Cascais - Portugal
Registered: 2009-04-14
Posts: 3

Re: The killswitch, and how NetworkManager thinks it's always on.

Must be the new HAL, i have a 3G USB Modem and yesterday, after updating the system, i had no wireless connection and had to use usb_modswitch to use my modem, witch i haven't had to use in years, since HAL did all the work. Archlinux is always full of surprises in the updates.

Last edited by hellblazer (2009-04-15 19:13:03)

Offline

#6 2010-05-20 13:18:01

humilleitor
Member
Registered: 2010-02-22
Posts: 46

Re: The killswitch, and how NetworkManager thinks it's always on.

I've had the same problem, wich happens somewhat randomly.

To start with, I only experience it after some crashes of the system.
The previous time, I solved it uninstalling and reinstalling networkmanager. I didn't need to unload rfkill, or blacklist it. And it has been working ok with the rfkill module loaded.
After the last crash I had, again it stopped working, as usual. But this time, instead or reinstalling networkmanager, I solved it unloading rfkill module.

The whole bug seems to be quite capricious. I don't manage to find a sure way of fixing it. These are the different alternatives that seem to work for me in different upcomings of the issue:
- Deleting the /var/lib/NetworkManager/NetworkManager.state file.
- Unload rfkill module.
- Reinstalling the networkmanager package.
- Changing my BIOS settings for the killswitch.

I'm bewildered (and disgusted) with this issue.

Last edited by humilleitor (2010-05-20 13:22:11)

Offline

Board footer

Powered by FluxBB