You are not logged in.

#1 2004-10-04 22:52:14

billbar
Member
Registered: 2004-02-14
Posts: 100

new evolution-2.0 installation

Install looked great.  Love the way Arch works, but...

execution fails
Here's the dialog from a terminal:
[root@billb /]# /opt/gnome/bin/evolution-2.0
/opt/gnome/bin/evolution-2.0: error while loading shared libraries: libgal-2.2.so.1: cannot open shared object file: No such file or directory

anybody have a fix for this?

Bill Barnes

Offline

#2 2004-10-05 06:26:03

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

I have found out that to satisfy the dependency for libgal-2.2.so.1, one has to install gal (and libgnomeui) packages.

I am researching further.

Regards,
Oleg

Offline

#3 2004-10-05 06:42:06

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

I think to satisfy the dependencies we have to make sure all the required packages from the Required list on http://archlinux.org/packages.php?id=874 are installed automatically/or if lacking - manually  sad

God bless you all with the good Arch Linux!

Best regards,
Oleg

Offline

#4 2004-10-05 06:45:45

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

As I have found out  - just the gtkhtml package was lacking.

To summarize:

For Evolution to be able to start one has to install manually gal and gtkhtml packages (and some little amount of others that pacman suggests as you do it).

Offline

#5 2004-10-05 07:48:51

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

Since some calendar component failed to start - I have found out that package libsoup is also needed. hmm

Offline

#6 2004-10-05 12:11:44

supa
Forum Fellow
From: United States
Registered: 2003-05-19
Posts: 24
Website

Re: new evolution-2.0 installation

Can you guys summerize how you installed evolution?  It seems to pull gal automatically for me...

# pacman -Rd gal
removing gal... done.
# pacman -S evolution
:: evolution-2.0.1-1: is up to date.  Upgrade anyway? [Y/n] Y

Targets: gal-2.2.2-1 evolution-2.0.1-1

Total Package Size:   11.4 MB

Proceed with upgrade? [Y/n]

checking package integrity... done.
loading package data... done.
checking for file conflicts... done.
installing gal... done.
upgrading evolution... done.
#

Offline

#7 2004-10-05 13:00:14

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

Still frustrating:

Ev. 2.0.1 imported my mail settings and mail, but missed all the contacts and calendar data.

I thought it happened due to missing libsoup package (that the callendar module did not start and the calendar data were not imported).

I installed libsoup. Deleted the ~/.evolution folder. But the application did not import data again. And I wonder why?

Also I was unable to create new calendar

How can I import data from my old evolution folder the quickest?

I have lost a lot of time and I regret that I have hurried with this upgrade

Offline

#8 2004-10-05 13:08:23

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

After I searched for answer for some time. I contacted guys at irc.gnome.org #evolution and got an aswer from there:
force migration FAQ (was: Re: [Evolution] Evolution 2.0.0) at http://lists.ximian.com/archives/public … 39343.html

also somehow I still don't have my calendar data imported from the old evo smile hmm also the guy who wrote the above faq says it does so for him.

Offline

#9 2004-10-05 13:25:34

loveslave
Member
Registered: 2004-03-27
Posts: 15

Re: new evolution-2.0 installation

Dear Supa,

as you have requested

In my case I use 0.7 current (updating the packages that are relevant for me to have the newest version):
I had to manually install (because pacman -Sy evolution did not suggest it in my case)
gal
gtkhtml
and libsoup

after since I did not have the libsoup installed - my calendar component did not configure properly. And I had to delete my ~/.evolution directory and reimport the data, since my contacs info was also missing.

Now the only disadavntage that I see - is that Calendar data was not imported. [/b]

Offline

#10 2004-10-18 13:11:30

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Re: new evolution-2.0 installation

version 2.0.2 keep re-popping mail that I have already popped each time I open it.  Is anyone else having this problem?  I'm downgrading back to 2.0.1 in the meantime.

Offline

Board footer

Powered by FluxBB