You are not logged in.

#1 2009-05-25 02:55:45

Trent
Member
From: Baltimore, MD (US)
Registered: 2009-04-16
Posts: 990

Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

So, I originally clicked "Post New Topic" to ask for help, but I figured it out in the process of describing my problem.  smile  I post it anyway in hopes that it will help others.

So, I'm trying to get wicd to connect to a WPA/WPA2 wireless network.  I can connect from the command line perfectly fine:

# ifconfig wlan0 up
# iwconfig wlan0 essid "my_network"
# wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf
# dhcpcd wlan0

works like a charm.  In /etc/wpa_supplicant.conf I have only the following four lines:

network={
    ssid="my_network"
    psk="Secret Passphrase"
}

However, wicd stuck at "Validating Authentication".  I checked the file in /var/lib/wicd/configurations/ corresponding to the connection (just figuring that out was an expedition in itself), and the psk= value is wrong.  These are the steps I used to configure it:

Start wicd-client.  Select the encrypted network.  Click "Advanced Settings".  Check "Use Encryption" and select "WPA 1/2 (Passphrase)" in the pull-down menu.  Type the secret passphrase in the textbox (in plain text).

The pre-shared key should have been a specific hex string (starting with f1).  However, in the /var/lib/wicd/configurations/... file it was a completely different string (starting with 09).  The same thing happened when I entered the correct hex string under "WPA 1/2 (Preshared Key)".  My accidental fix was to type in the plaintext passphrase under the (Preshared Key) option, and it works now.

This looks to me like a bug in wicd, but I didn't want to file a bug report until I got some feedback.  Does anybody else have this experience?  Did I just choose the wrong authentication method to start with?

Offline

#2 2009-05-25 04:39:41

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,477

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

I suffered several issues with wicd, and am using network-manager. I remember something somehow pre-enrypting the password, before saving it.

A good start for you could propably be
http://wicd.sourceforge.net/


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#3 2009-05-25 06:36:51

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

Wicd stuck at authentication for me too, but your method does not work for me.
Doing it at the command line with dhcp showed that

dhcpcd: version 5.0.2 starting
dhcpcd: wlan0: waiting for carrier
dhcpcd: timed out

Network manager does not work, either. Network manager on my Ubuntu does not work, either sad

Offline

#4 2009-06-03 00:03:14

drandre
Member
Registered: 2009-04-16
Posts: 35

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

I struggled with this problem for a while.  It took a lot of learning.

When you enter a passphrase, WPA is meant to create a key by hashing that passphrase.  The passphrase is stored in your wpa_supplicant.conf file quoted - psk="like this".

An alternative and apparently more secure setup is to directly enter a random hex key instead of a passphrase.  In this case WPA doesn't hash the key you provide but uses it directly.  A hex key is stored in your wpa_supplicant.conf file unquoted - psk=ca670...

wicd gives you a number of different options for setting the psk value.  I ended up playing around till I found the one that wrote the conf file correctly.  Ironically the correct method for specifying the hex key directly is "WPA 1/2 (passphrase)" - not pre-shared key as I would have expected.  If you enter your key using the pre-shared key option it will actually be treated as a passphrase and hashed before being written to the conf file.

Now I don't know enough about wireless to be sure whether this is a bug or just a misunderstanding on my part.  If somebody can confirm?

Offline

#5 2009-06-03 09:47:11

R00KIE
Forum Fellow
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

I'm using wicd too and it works fine here but my wpa_supplicant.conf is empty, everything is set through wicd.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#6 2009-06-14 19:27:34

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,359
Website

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

This might be off-topic (read IS EXTREMELY off-topic) but congratulations on your 1337th post Moo-Crumpus! I know this was like your 1335th or something but your 1337th was in a topic that is now closed so I thought I had to congratulate you here.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#7 2012-07-28 01:32:16

rajvarma
Member
Registered: 2012-07-28
Posts: 1
Website

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

How to specify the wpa-key to the wicd-cli? I don't see anything in the help. THank you.

Offline

#8 2012-07-28 01:41:07

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,133
Website

Re: Solution: Wicd fails on WPA 1/2 (Passphrase) authentication

rajvarma - please don't necrobump

https://wiki.archlinux.org/index.php/Fo … Bumping.27

It's under preferences IIRC...


Closing.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB