You are not logged in.

#1 2009-06-16 14:53:55

greenfish
Member
From: eating fish in /dev/null
Registered: 2008-08-30
Posts: 226

[cups] "no printers found" over network

Hello! I'm trying to find my printer at my server (usb printer) using my client but i'm always getting
the same message from the web interface "no printers found".

cups-server-no-printers.png

Printer: Samsung ML-1630 Series (Samsung ML-1630 Series)
Client ip: 192.168.1.100
Server ip: 192.168.1.104

Printer hooked up to client (dmesg)
Works: yes

usb 2-1: new high speed USB device using ehci_hcd and address 4
usb 2-1: configuration #1 chosen from 1 choice
usblp1: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04E8 pid 0x328B
usbcore: registered new interface driver usblp

Detected Printers:

Samsung ML-1630 Series (Samsung ML-1630 Series USB #2)

Printer hooked up to server (dmesg)
Works: unknown (not detected by cups over the network)

usb 2-1: new high speed USB device using ehci_hcd and address 4
usb 2-1: configuration #1 chosen from 1 choice
usblp1: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04E8 pid 0x328B
usbcore: registered new interface driver usblp

cupsd.conf (client)

#
# "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $"
#
#   Sample configuration file for the Common UNIX Printing System (CUPS)
#   scheduler.  See "man cupsd.conf" for a complete description of this
#   file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel debug

# Administrator user group...
SystemGroup sys root


# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock
ServerName 192.168.1.104

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL
BrowseAllow all

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Encryption Required
  Order allow,deny
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
</Location>

# Set the default printer/job policies...
<Policy default>
  # Job-related operations must be done by the owner or an administrator...
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $".
#

cupsd.conf (server)

#
# "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $"
#
#   Sample configuration file for the Common UNIX Printing System (CUPS)
#   scheduler.  See "man cupsd.conf" for a complete description of this
#   file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel debug

# Administrator user group...
SystemGroup sys root lp


# Only listen for connections from the local machine.
port 631
Listen /var/run/cups/cups.sock
Listen 192.168.1.104:631

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL
BrowseAllow all


DefaultEncryption Never

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
  Allow all
</Location>

# Restrict access to the admin pages...
<Location /admin>
  #Encryption Required
  Order allow,deny
  Allow all
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
  Allow all
</Location>

<Location />
  Order allow,deny
  Allow localhost
  Allow all
</Location>




<Location

# Set the default printer/job policies...
<Policy default>
  # Job-related operations must be done by the owner or an administrator...
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $".
#

CUPS on the client logs:

http://pastebin.com/m57ac4766 (error_log)

CUPS on the server logs:

http://pastebin.com/ma23b916 (error_log)

In my opinion it should be working but it's not, i've read the linux printer database/various linux forums/#cups on freenode (idled for 2 days no response)/gentoo wiki/forums and the old tool "google" but most of the "hacks" I tried didn't work.

Anyone have any ideas?

Thank You


ARCH64 archSKYNET server AMD  Phenom(tm) II X2 550 HDD 6TB Ram 8GB
Hobbies: Running, Pistol Marksmanship, Classic Music

Offline

#2 2009-06-17 06:40:43

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [cups] "no printers found" over network

I never got it to work on the network of my univeristy either.

Have you tried to add it manually? I.e. http://localhost:631/admin?op=add-printer and specify the address.

Is it a samba printer or something else? If so you could use smbclient to find the printer.

Cheers,
Rasmus


Arch x64 on Thinkpad X200s/W530

Offline

#3 2009-06-17 09:22:02

greenfish
Member
From: eating fish in /dev/null
Registered: 2008-08-30
Posts: 226

Re: [cups] "no printers found" over network

Pank wrote:

I never got it to work on the network of my univeristy either.

Have you tried to add it manually? I.e. http://localhost:631/admin?op=add-printer and specify the address.

Is it a samba printer or something else? If so you could use smbclient to find the printer.

Cheers,
Rasmus

Hello Rasmus thanks for responding! Yeah i've tried to add it manually but doing so either: A. CUPS claims it's the wrong firmware (which is incorrect) B. Red status on the printer, won't print, I belive it's still not finding my printer, since the USB option never turns up in the process.

SAMBA? No it's on my server which is running archlinux (no X)

I could hook up my printer to my laptop with a long USB cable but that kinda defeats the purpose and the problem would remain unsolved.

Thanks

EDIT: this is the output from my server:

lpinfo -v
network socket
network beh
network http
network ipp
network lpd
direct scsi
network smb

CUPS doesn't support USB printer over network? Nah that can't be the case most printers today is USB not parallell.

Last edited by greenfish (2009-06-17 17:42:52)


ARCH64 archSKYNET server AMD  Phenom(tm) II X2 550 HDD 6TB Ram 8GB
Hobbies: Running, Pistol Marksmanship, Classic Music

Offline

#4 2009-06-18 09:11:54

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,212
Website

Re: [cups] "no printers found" over network

I don't see anywhere in your server conf that the printer is published. IIRC, you need to have it published on your server in order for your clients to find the printer automatically.

Zl.

Offline

#5 2009-06-18 09:30:05

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [cups] "no printers found" over network

greenfish wrote:

Hello Rasmus thanks for responding! Yeah i've tried to add it manually but doing so either: A. CUPS claims it's the wrong firmware (which is incorrect) B. Red status on the printer, won't print, I belive it's still not finding my printer, since the USB option never turns up in the process.

I don't know anything about servers, but in Zenwalk I recently had a strange error doing network printing using cups. I think that the cups-api used by Zenwalk at least had a bug since it inserted an extra blank line in the end of printers.conf. This caused cups not being able to connect to the university-printers. So please check that there is not an extra blank line in /etc/cups/printers.conf. For more info on this potential bug please see this thread.

I tried to add a test printer with cups web ui in Arch and I also got an extra blank line. It might cause some kind of problem for you. Again, my experience is with samba-printers. It might be totally different from your case. The error messaged, caused by the extra blank line, was something like: not able to contact cifs host or similar.

Cheers,
Rasmus


Arch x64 on Thinkpad X200s/W530

Offline

#6 2009-06-18 12:44:39

broch
Banned
From: L.A. California
Registered: 2006-11-13
Posts: 975

Re: [cups] "no printers found" over network

I never used this printer however I did use USB printers over network. Assuming that this is standard setup:
1) does not matter for network protocol how printer is connected locally (to the server)
2) need printer drivers on client
3) personally I was always setting up lpd because it is more flexible (works with network attached printers and with networked printers attached to unix/windows server)
4) in the case of firewall, open ports for printer

some win printers will not work over network by design. I would check if your printer really can be shared over net.

Offline

#7 2009-06-18 15:30:08

greenfish
Member
From: eating fish in /dev/null
Registered: 2008-08-30
Posts: 226

Re: [cups] "no printers found" over network

Pank wrote:
greenfish wrote:

Hello Rasmus thanks for responding! Yeah i've tried to add it manually but doing so either: A. CUPS claims it's the wrong firmware (which is incorrect) B. Red status on the printer, won't print, I belive it's still not finding my printer, since the USB option never turns up in the process.

I don't know anything about servers, but in Zenwalk I recently had a strange error doing network printing using cups. I think that the cups-api used by Zenwalk at least had a bug since it inserted an extra blank line in the end of printers.conf. This caused cups not being able to connect to the university-printers. So please check that there is not an extra blank line in /etc/cups/printers.conf. For more info on this potential bug please see this thread.

I tried to add a test printer with cups web ui in Arch and I also got an extra blank line. It might cause some kind of problem for you. Again, my experience is with samba-printers. It might be totally different from your case. The error messaged, caused by the extra blank line, was something like: not able to contact cifs host or similar.

Cheers,
Rasmus

Rasmus thanks once more for your insight, I did verify my config and there doesn't seem to be any blank line.


@zenlord

Hmm where do you see that in my config? Because the webinterface marks the printer as "published"

@broch

Yeah but a few google links indicates it is indeed working on windows and macosx but not much else to go after.


Guys this is one of the few rare instances where I'm gonna have to give up, this is already taking too much time from my vacation, I just want to print over my server that's it. As of now i've disabled my printer and removed CUPS from the server. My laptop will be the host for my printer (inconvience) but at least i can print.

Should I find a solution to my problem, i'll update this thread.

Thanks though for your help guys, much appreciated!!!!

cool


ARCH64 archSKYNET server AMD  Phenom(tm) II X2 550 HDD 6TB Ram 8GB
Hobbies: Running, Pistol Marksmanship, Classic Music

Offline

#8 2009-06-18 17:20:25

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,212
Website

Re: [cups] "no printers found" over network

Hmmm - I didn't see 'published' anywhere in your confs. On my server (debian lenny) I have a /etc/cups/printers.conf where the default printer is marked 'Shared Yes'

My Arch linux laptop immediately got the shared network-printer, but I must admit that every printer is listed twice on my laptop, so maybe there's a bug.

Zl.

Offline

Board footer

Powered by FluxBB