You are not logged in.

#1 2009-08-08 07:51:32

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Missing eth0 after installation

Hi all,

just now I installed archlinux using a usb flash on a laptop Ideapad U350,
every thing seems good except eth0 is missing.
the output of "ifconfig -a" is lo wlan0 and wmaster0,
and the output of "lspci" shows the ethernet controller as

08:00.0 Ethernet controller: Broadcom Corporation Device 1692 (rev 01)

I also tried to reboot the system using the usb installation media,
but finding the same output.

I googled the forum, found this thread, http://bbs.archlinux.org/viewtopic.php?id=51856, complained about a same problem, but I am not using an eee pc.


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#2 2009-08-08 08:30:55

djszapi
Member
From: Cambridge, United Kingdom
Registered: 2009-06-14
Posts: 1,439
Website

Offline

#3 2009-08-08 09:07:46

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

thank you djszapi, I did follow the wiki instruction when I was install it.
The system has been installed successfully, but could not found eth0, that is the problem.


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#4 2009-08-08 09:13:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,341
Website

Re: Missing eth0 after installation

What do you have in your network section in your /etc/rc.conf?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2009-08-08 09:45:32

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

jasonwryan wrote:

What do you have in your network section in your /etc/rc.conf?

MOUDLES=(tg3 snd-cmipci ath5k ath_pci ath_hal wlan)

HOSTNAME="enlightenment"
eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#6 2009-08-08 09:48:07

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,341
Website

Re: Missing eth0 after installation

Try:

#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(eth0)
eth0="dhcp"

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#7 2009-08-08 09:55:56

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

I tried it before, but this way does not work, as system could not found eth0

eth0: read_interface: No such device

also the output of "ifconfig -a" does not contains  eth0.

Last edited by fallening (2009-08-08 09:57:38)


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#8 2009-08-08 14:23:49

majiq
Member
Registered: 2009-03-06
Posts: 259

Re: Missing eth0 after installation

Do you know what your wired NIC card is? As in make and model? Because it could (very outlandish idea) be one of the apparently like two percent that don't work with the default e100 module.

You could try rmmod'ing the e100 module and the reloading it, also the eepro100 module (if that's still around and different :-/).

Also, this thread looks kinda promising ~> http://bbs.archlinux.org/viewtopic.php?id=34292 (also brings up the point of does lshwd list your card; if not, it's probably an internal issue).

Edit: Actually, that one had an eth0, but still, some diagnostics in there you might try.

Last edited by majiq (2009-08-08 14:24:22)

Offline

#9 2009-08-09 09:42:20

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

thank you majiq, I checked that thread but did not get my wired card work.

At last I even recompiled the kernel to make the driver tg3 build in, however I get one more interface named "sit0", but it still not for wired cable.

ifconfig -a
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:22:FB:72:6C:B4  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr 00-22-FB-72-6C-B4-00-00-00-00-00-00-00-00-00-00  
          [NO FLAGS]  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#10 2009-08-10 00:00:18

endpoint
Member
Registered: 2009-08-09
Posts: 1

Re: Missing eth0 after installation

Not sure if this will help but I'm having a similar problem after pacman -Syu.  I was getting a error about module dependencies during boot up.  modprobe -l produced an error saying that it was looking for modules.dep in a folder that no longer existed and was replaced by a newer kernel folder.  To make a long story short, I set up arch with a boot partition that mounts at boot up and then unmounts afterward.  What I found was that the new kernel was written to /boot on the root partition, which was being mounted over by my boot partition.  So I was running the old kernel looking for the old modules.dep on a file system that had a new folder for modules.dep.

I haven't resolved the problem because we were having thunderstorms a little earlier, but I think that was my problem.  I plan to back up everything on my boot partition and copy over everything from /boot on my root partition to the boot partition.  Clear as mud I'm sure, but maybe it'll help you.  Take all of this with a grain of salt, or maybe the whole shaker.  I've only been playing with Arch for a weekend so far.

Reading your last post, this probably won't help you but maybe it will help somebody who made my mistake.  If you have a separate boot partition, I think you need to mount it before upgrading the system.

Last edited by endpoint (2009-08-10 00:21:59)

Offline

#11 2009-08-10 00:57:45

tlvb
Member
From: Sweden
Registered: 2008-10-06
Posts: 297
Website

Re: Missing eth0 after installation

jasonwryan wrote:

Try:

#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(eth0)
eth0="dhcp"

Shouldn't it be the other way around? I.e:

eth0="dhcp"
INTERFACES=(eth0)

(At least that is what I have (commented out, I don't start network at boot) in my /etc/rc.conf)

That may be the reason for the "no such device" error.

Last edited by tlvb (2009-08-10 00:58:47)


I need a sorted list of all random numbers, so that I can retrieve a suitable one later with a binary search instead of having to iterate through the generation process every time.

Offline

#12 2009-08-10 02:30:57

sand_man
Member
From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: Missing eth0 after installation

I think tlvb is right.

eth0="dhcp"  # Defines the interface
INTERFACES=(eth0) # Tells the system to use it


neutral

Offline

#13 2009-08-10 11:27:21

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

hello sand_man and tlvb, I change eth0="dhcp", and then by using "sudo /etc/rc.d/network restart", I got

dhcpcd: eth0 : interface not found or invalid
dhcpcd: timed out

I think this problem is most likely caused by the kernel driver, but I don't know how to solve it.


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#14 2009-08-10 11:33:44

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

endpoint wrote:

Not sure if this will help but I'm having a similar problem after pacman -Syu.  I was getting a error about module dependencies during boot up.  modprobe -l produced an error saying that it was looking for modules.dep in a folder that no longer existed and was replaced by a newer kernel folder.  To make a long story short, I set up arch with a boot partition that mounts at boot up and then unmounts afterward.  What I found was that the new kernel was written to /boot on the root partition, which was being mounted over by my boot partition.  So I was running the old kernel looking for the old modules.dep on a file system that had a new folder for modules.dep.

I haven't resolved the problem because we were having thunderstorms a little earlier, but I think that was my problem.  I plan to back up everything on my boot partition and copy over everything from /boot on my root partition to the boot partition.  Clear as mud I'm sure, but maybe it'll help you.  Take all of this with a grain of salt, or maybe the whole shaker.  I've only been playing with Arch for a weekend so far.

Reading your last post, this probably won't help you but maybe it will help somebody who made my mistake.  If you have a separate boot partition, I think you need to mount it before upgrading the system.

thank you for your attention, endpoint. I did use a seperated boot partation, but I think this kind of eth0 missing is not caused by the upgrade of the kernel as it appears after a fresh installation.

Last edited by fallening (2009-08-10 11:34:49)


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#15 2009-08-10 12:11:52

sand_man
Member
From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: Missing eth0 after installation

To avoid any more confusion can you please post your entire /etc/rc.conf file?


neutral

Offline

#16 2009-08-11 02:51:12

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

sorry sand_man, that is my fault.
I am now using offical kernel26 2.6.30.4-1, and my /etc/rc.conf is

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="local"
USEDIRECTISA="no"
TIMEZONE="Asia/Shanghai"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(tg3 intel_agp i915)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="enlightenment"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !network !netfs @crond @alsa @hal @dbus @cups @laptop-mode !entranced)

Last edited by fallening (2009-08-11 02:51:35)


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#17 2009-08-11 03:49:27

majiq
Member
Registered: 2009-03-06
Posts: 259

Re: Missing eth0 after installation

I'm not a pro with modules and hardware and the kernel or anything...but don't you need the e100 module in your module list? And also, maybe the mii module? I don't know how that affects the detection in other ways, but if you want the ethernet to work, you need the modules loaded, right? Or is the AUTOLOAD automagically supposed to take care of that?

Offline

#18 2009-08-11 12:42:31

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

hi majiq, I checked the lspci out put and found

08:00.0 Ethernet controller: Broadcom Corporation Device 1692 (rev 01)

for my wired card, also I googled and found this page(http://cateee.net/lkddb/web-lkddb/TIGON3.html), so I thought I should use module tg3. However, even after I have executed

modprobe  mii e100

, eth0 is still out of detection.


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#19 2009-08-15 03:26:31

fallening
Member
From: PRC
Registered: 2007-11-26
Posts: 25

Re: Missing eth0 after installation

my problem is moudle tg3 does not work for me, but according to the wiki and http://cateee.net/lkddb/web-lkddb/TIGON3.html , it is supposed to be the one, with dmesg

tg3.c:v3.98 (February 25, 2009)
tg3: 0000:08:00.0: PCI INT A -> GSI 17 (level low) -> IRQ 17
tg3: 0000:08:00:0: setting latency timer to 64 
tg3: 0000:08:00:0: PME# disabled
tg3 mdio bus: probed
eth%d: NO PHY devices
tg3: Problem fetching invariants of chip, aborting.
tg3: 0000:08:00.0: PCI INT A disabled

maybe I should use a 32-bit release instead of the current 64-bit one?

Last edited by fallening (2009-08-15 03:56:59)


載瞻星辰
載歌幽人
流水今日
明月前身

Offline

#20 2009-08-15 03:55:31

von_Wanderlust
Member
Registered: 2008-11-03
Posts: 67

Re: Missing eth0 after installation

It might be the network driver modules clashing as they load, I recently had this occur with my machine (also using tg3, but I think that is just coincidental). I couldn't find the card in lspci at all at one point so assumed it was the card that had gone funny. I got it working again by placing the tg3 module near the beginning of the MODULES array in rc.conf, with the module for the wireless card at the end of the array.

Thread is here: http://bbs.archlinux.org/viewtopic.php?id=76819

If it this is what is happening, and the above doesn't help, note B's commments in my thread that udev might be needed.

Offline

Board footer

Powered by FluxBB