You are not logged in.

#1 2009-08-28 10:02:50

LonelyStar
Member
Registered: 2007-12-09
Posts: 123

wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

HI,

Normaly my wireless works fine (I have a FritzBOX wlan router). But sometimes, when connection, I get this:

dhcpcd: wlan0: reject NAK

The wlan still works for other computers ...

What could cause this problem?
I use the iwl3945 kernel driver for intel wlan card.

Thanks!
Nathan

Offline

#2 2009-08-28 12:01:01

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,028

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

ive seen this too, this happened with a linksys wrt54g, there was no way to bring up the interface. forcing a static ip works. i always thought it was the router's fault.

rt73usb here.

Offline

#3 2009-09-05 22:05:18

Dr.U
Member
From: Ettlingen, Germany
Registered: 2005-03-03
Posts: 68

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

No, it's not the router. I have the same problem occurring sporadically, but my wired PCs can get to the router and work fine. I have an MSI notebook and have rt2x00pci, rt2x00lib and rt61pci all in my MODULES line of the rc.conf file.

I don't remember when the problem started occurring, but it must have been at least several months ago.

-- Dr. U

------------------------------------------------------------------------------------------------------------------
A child of five would understand this. Send someone to fetch a child of five. (Groucho Marx)

Offline

#4 2009-09-06 10:41:24

xduugu
Member
Registered: 2008-10-16
Posts: 292

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

I also noticed this recently and therefore commented out the following part of /etc/dhcpcd.conf a month or two ago.

# A ServerID is required by RFC2131.
# Some broken DHCP servers do not send one and dhcpcd can work without it.
# Some broken DHCP servers NAK incorrectly and do not include a ServerID
# either so the default is to require a ServerID.
require dhcp_server_identifier

Last edited by xduugu (2009-09-06 10:42:33)

Offline

#5 2009-09-06 20:47:14

Dr.U
Member
From: Ettlingen, Germany
Registered: 2005-03-03
Posts: 68

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

Thanks for the suggestion. I'll give it a try. Since the problem only occurs sporadically, I won't know for a while whether the suggestion solves the problem or not ... hmm

But thanks for the reply! wink

-- Dr.U

Offline

#6 2009-10-02 13:00:46

Scattenlaeufer
Member
Registered: 2009-04-05
Posts: 17

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

I had the same problem and commenting the given line in /eth/dhcpcd.conf solved it, so i will see, if any other problems occur.

Offline

#7 2009-10-02 13:05:14

LonelyStar
Member
Registered: 2007-12-09
Posts: 123

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

I have commented the line out for a while now and no problem so far, so seems good ...

Offline

#8 2009-10-02 13:05:25

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

Worked for me too smile


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#9 2009-11-01 21:24:40

bcdarwin
Member
Registered: 2009-08-18
Posts: 3

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

This week I noticed this problem when connecting through a gateway machine which has not been modified in months.  However, at another location I wasn't having this problem.  Thus, I suspect last week's kernel upgrades are responsible (for pointing out a flaw in a BSD's dhcpd configuration?).  Commenting the 'require dhcp_server_identifier' solved it.

Offline

#10 2009-11-23 15:20:06

vitoreiji
Member
Registered: 2009-09-04
Posts: 67

Re: wireless sometimes not working: "dhcpcd: wlan0 reject NAK"

Works for me too. Thanks xduugu!

Offline

Board footer

Powered by FluxBB