You are not logged in.

#26 2009-12-25 11:50:14

veranyon
Member
From: Odintsovo/Russian Federation
Registered: 2009-07-08
Posts: 105
Website

Re: phpmyadmin update [SOLVED]

ajb wrote:

Steps i've made:

rm -r /srv/httpd/phpMyAdmin
cp /etc/webapps/phpmyadmin/apache.example.conf /etc/httpd/conf/extra/phpmyadmin.conf
echo "\nInclude conf/extra/phpmyadmin.conf" >> /etc/httpd/conf/httpd.conf

and finally comment out "deny from all" in /etc/webapps/phpmyadmin (with "#" in front of line).
I've also changed alias to capital letters, as they were. (WARNING new standard address is http://localhost/phpmyadmin/ )
At the end /etc/rc.d/httpd restart
and everything have gone great

EDIT:
Yes... also i've added /usr/share/webapps and /etc/webapps to my open_basedir in /etc/php/php.ini

apachectl configtest
Syntax error on line 476 of /etc/httpd/conf/httpd.conf:
Invalid command '\\nInclude', perhaps misspelled or defined by a module not included in the server configuration

I'm confused.
Why phpmyadmin not working out of the box under Arch?

yaourt -S phpmyadmin
locate -i phpmyadmin | grep -v /home/iron/1/Docs
/var/lib/pacman/sync/community/phpmyadmin-3.2.4-1
/var/lib/pacman/sync/community/phpmyadmin-3.2.4-1/depends
/var/lib/pacman/sync/community/phpmyadmin-3.2.4-1/desc

hmm

And where's phpmyadmin itself? not source three 000)

Last edited by veranyon (2009-12-25 12:22:05)


ArchLinux x86_64 /AMD Phenom x4 9550/4 GB RAM/ASUS M3N78-EM/GeForce 9800 GT/DELL 2408 VFP
[img]http://img17.imageshack.us/img17/3443/111bzf.gif[/img]

Offline

#27 2010-02-13 17:58:29

veranyon
Member
From: Odintsovo/Russian Federation
Registered: 2009-07-08
Posts: 105
Website

Re: phpmyadmin update [SOLVED]

how to solve it
can't solve that problem

I did all that was writed on the http://wiki.archlinux.org/index.php/PhpMyAdmin page and have error 403 anyway

in '/etc/httpd/conf/extra/httpd-phpmyadmin.conf' change:

Alias /phpmyadmin/ "/usr/share/webapps/phpMyAdmin/"

to

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"

My /etc/httpd/conf/extra/httpd-phpmyadmin.conf file was already without that slash. A new installation of arch.

        Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"
        <Directory "/usr/share/webapps/phpMyAdmin">
                AllowOverride All
                Options FollowSymlinks
                Order allow,deny
                Allow from all
        </Directory>

"[Sat Feb 13 21:34:57 2010] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /usr/share/webapps/phpMyAdmin/"

People!!!...

Last edited by veranyon (2010-02-13 18:41:34)


ArchLinux x86_64 /AMD Phenom x4 9550/4 GB RAM/ASUS M3N78-EM/GeForce 9800 GT/DELL 2408 VFP
[img]http://img17.imageshack.us/img17/3443/111bzf.gif[/img]

Offline

#28 2010-02-14 10:48:33

kermana
Member
Registered: 2009-04-13
Posts: 60

Re: phpmyadmin update [SOLVED]

I'm not sure if I understand correctly, but what I have in my working box is a little different from you.

First, all I have in /etc/httpd/conf/httpd.conf about phpmyadmin is this:

#phpmyadmin
Include conf/extra/httpd-phpmyadmin.conf

The above sources /etc/httpd/conf/extra/httpd-phpmyadmin.conf which looks like:

        Alias /phpmyadmin/ "/usr/share/webapps/phpMyAdmin/"
        <Directory "/usr/share/webapps/phpMyAdmin">
                AllowOverride All
                Options FollowSymlinks
                Order allow,deny
                Allow from all
        </Directory>

Also make sure open_basedire in your php.ini looks something like this:

open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/:/etc/webapps

This is pretty much all I did while installing I guess. See if this helps you. It might be something as silly as a missing slash or something smile

Last edited by kermana (2010-02-14 10:53:24)

Offline

#29 2010-09-06 22:40:47

arastoo.s
Member
Registered: 2010-04-28
Posts: 18

Re: phpmyadmin update [SOLVED]

hi
i install lamp , and conf it then i install phpmyadmin and conf but when i want login in to this i cant ?!
i see this error and i dont know who can i do ? any one can help and steerage me please ?

#2006 Cannot log in to the MySQL server Arch linux

Last edited by arastoo.s (2010-09-07 00:09:32)

Offline

#30 2010-09-06 22:45:42

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,668
Website

Offline

#31 2010-09-06 23:44:22

arastoo.s
Member
Registered: 2010-04-28
Posts: 18

Re: phpmyadmin update [SOLVED]

Offline

#32 2010-09-07 02:56:44

yvonney
Member
Registered: 2008-06-11
Posts: 671

Re: phpmyadmin update [SOLVED]

[mysql: i think you need to see the mysql wiki page etc. as the password setting is quite a detail]

for me there was a whole bunch of details to take care of to have apache, mysql, php, phpmyadmin working. I did get things going. I'm still planning to get better at running them WHEN I actually need a server that can be accessed from outsite.

Right now I'm happily running xxamp 1.7.3a available in AUR. If you don't need your server to be accessed from outside your lan maybe use xxamp as it's all in one folder and can easily be deleted, copied etc.

That said learning the bare apps is way cool and I'm more into that yet for web development xxamp is great.

Last edited by yvonney (2010-09-07 03:15:29)

Offline

#33 2011-08-22 12:24:16

mouni
Member
Registered: 2011-07-03
Posts: 31

Re: phpmyadmin update [SOLVED]

Thank you very much.
I Just add that Arch Wiki is amazing. ( https://wiki.archlinux.org/index.php/PhpMyAdmin ) I follow all instructions and the of .htaccess i only write comment the rule: #deny from all


"See, you not only have to be a good coder to create a system like Linux, you have to be a sneaky bastard too." - Linus Torvalds

Offline

#34 2011-08-22 12:45:13

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,130

Re: phpmyadmin update [SOLVED]

mouni, please do not necrobump threads. Read this :: https://wiki.archlinux.org/index.php/Fo … Bumping.27

Closing...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB