You are not logged in.

#1 2004-11-30 22:03:08

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

How do I allow access of my mysql server to !localhost?

I just did an nmap of an arch box running mysql, but port 3306 isn't open. mysql is certainly running and local processes have no problem accessing it.

There are no entries in rc.allow or rc.deny, and I'm not running iptables.

Offline

#2 2004-12-01 00:54:43

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: How do I allow access of my mysql server to !localhost?

/etc/my.conf
# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#

skip-networking


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2004-12-01 01:37:51

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Re: How do I allow access of my mysql server to !localhost?

thanks!

Offline

Board footer

Powered by FluxBB