You are not logged in.

#1 2010-01-09 01:25:58

Can0n
Member
Registered: 2010-01-09
Posts: 7

[SOLVED] Wireless connect with username and password

I just recently installed Arch on my computer but have used *buntu for a couple of years so I'm not completely lost in the Linux-world.
Anyway, my college have a wireless setup that requires you to log in with your username and password. I used wicd in *buntu but the reason I installed Arch is because I want to know how to do stuff manually, and not only automagically.
So, the problem I have is that I don't know how to connect to it using wpa_supplicant and netcfg. I've googled about it but haven't seen any good examples, or how-to's.

I've a profile for my home network but I only have a WPA key here so that was easy with the wireless guide, so I know some basics about wpa_supplicant anyway.

This is what "iwlist wlan0 scan" give me:

Address: 0A:06:01:8D:A7:24
Channel:6                 
Frequency:2.437 GHz (Channel 6)
Quality=39/70  Signal level=-71 dBm  
Encryption key:on                    
ESSID:"LangaraSecure"                
Bit Rates:2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s; 11 Mb/s
              12 Mb/s; 18 Mb/s; 24 Mb/s                
Bit Rates:36 Mb/s; 48 Mb/s; 54 Mb/s                
Mode:Master                                        
Extra:tsf=efeeef1c5fdea26f                         
Extra: Last beacon: 3183ms ago                     
IE: Unknown: 000D4C616E67617261536563757265        
IE: Unknown: 0108040B0C1296182430                  
IE: Unknown: 030106                                
IE: Unknown: 2A0100                                
IE: Unknown: 320348606C                            
IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1606001B00000000000000000000000000000000000000        
IE: IEEE 802.11i/WPA2 Version 1                                      
    Group Cipher : TKIP                                              
    Pairwise Ciphers (1) : CCMP                                      
    Authentication Suites (1) : 802.1x                               
IE: WPA Version 1                                                    
    Group Cipher : TKIP                                              
    Pairwise Ciphers (1) : TKIP                                       
    Authentication Suites (1) : 802.1x                               
IE: Unknown: DD180050F2020101030003A4000027A4000042435E0062322F00    
IE: Unknown: DD1D000CE600049B0000000106000CE60690D10404010000000504008C0000

Hope this is enough, if it's not just tell me what more you need =)

Last edited by Can0n (2010-01-11 19:56:56)

Offline

#2 2010-01-09 03:01:54

Trent
Member
From: Baltimore, MD (US)
Registered: 2009-04-16
Posts: 988

Re: [SOLVED] Wireless connect with username and password

To be honest, I don't really understand most of the output of iwlist scan.  But do you know what authentication scheme your college uses?  What settings do you use in Wicd?

Offline

#3 2010-01-11 17:25:07

Can0n
Member
Registered: 2010-01-09
Posts: 7

Re: [SOLVED] Wireless connect with username and password

Sorry for the delay, haven't been on campus on the weekend ;P
So, I installed WICD to see what encryption it use, and in WICD it says "PEAP with TKIP/MSCHAPV2", without a "CA cert".

Anyone know how to connect to that kind of encryption with netcfg?

Offline

#4 2010-01-11 17:30:52

tavianator
Member
From: Waterloo, ON, Canada
Registered: 2007-08-21
Posts: 858
Website

Re: [SOLVED] Wireless connect with username and password

This works for me here at UW:

Manually in /etc/wpa_supplicant.conf:

network={
        ssid="<network>"
        key_mgmt=WPA-EAP
        identity="<username>"
        password="<password>"
}

Using netcfg (which I recommend strongly): do the above and set WPA_CONF to /etc/wpa_supplicant.conf (or whatever you want).

Using netcfg from testing (which you'll have to upgrade to eventually):

CONFIGSECTION='ssid="<network>"
               key_mgmt=WPA-EAP
               identity="<username>"
               password="<password>"'

Offline

#5 2010-01-11 19:56:25

Can0n
Member
Registered: 2010-01-09
Posts: 7

Re: [SOLVED] Wireless connect with username and password

tavianator wrote:

This works for me here at UW:

Manually in /etc/wpa_supplicant.conf:

network={
        ssid="<network>"
        key_mgmt=WPA-EAP
        identity="<username>"
        password="<password>"
}

Using netcfg (which I recommend strongly): do the above and set WPA_CONF to /etc/wpa_supplicant.conf (or whatever you want).

Using netcfg from testing (which you'll have to upgrade to eventually):

CONFIGSECTION='ssid="<network>"
               key_mgmt=WPA-EAP
               identity="<username>"
               password="<password>"'

That did it smile
I added an own profile in /etc/network.d that I just connect to now. Excited too see if it works back home as well, got some strange error yesterday when I use WEP.

Thanks !

Offline

#6 2010-02-09 16:08:47

Can0n
Member
Registered: 2010-01-09
Posts: 7

Re: [SOLVED] Wireless connect with username and password

Okey, so I got another problem now.
I'm not sure if it's netcfg or the network at school but I loose my connection very often, and when I try to reconnect I get " - Authentication/association failed" every time.

wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

eapol_version=1
ap_scan=1
fast_reauth=1

network={
        ssid="LangaraSecure"
        key_mgmt=WPA-EAP
        identity="myusername"
        password="mypassword"
}

Network profile

CONNECTION="wireless"
DESCRIPTION="Langara Secure"
INTERFACE="wlan0"
SCAN="no"
SECURITY="wpa-config"
ESSID="LangaraSecure"
IP="dhcp"
TIMEOUT="30"
WPA_CONF="/etc/wpa_supplicant.conf"

Offline

#7 2010-02-10 03:19:42

tavianator
Member
From: Waterloo, ON, Canada
Registered: 2007-08-21
Posts: 858
Website

Re: [SOLVED] Wireless connect with username and password

Probably just a weak signal or weak antenna in your computer.  I have two laptops here at UW; one of them can connect to the wireless from my dorm, the other usually can't.  But they both work when I'm on campus.

Offline

#8 2010-04-13 17:05:04

danieleboyo
Member
Registered: 2010-04-13
Posts: 1

Re: [SOLVED] Wireless connect with username and password

I think that issue is not solved, as I too experience trouble with my wpa_supplicant configuration on campus in my netcfg profile.  The issue is that I can connect once, but if I disconnect and try to reconnect,  I will get authentication/association failed (as mentioned 2 posts before mine).  It is only after a seemingly arbitrary amount of time that it can connect again.

  It was working fine with wpa_supplicant v 0.6.9-2, but then starting acting up only after this.  Is there some caching going on that would cause the authentication to fail every subsequent time?  Any insight would be most appreciated!

Offline

Board footer

Powered by FluxBB