You are not logged in.

#1 2010-01-25 10:16:19

Registered: 2009-10-01
Posts: 97

CNet CWP-854 (Ralink RT2561T) wifi connection dropping

I've been having a lot of trouble with my wireless connection dropping or not working at all. My setup:

Wifi card: CNet CWP-854 (Ralink RT2561T)
Router: FRITZ!Box Fon WLAN, Firmware version 08.04.26

I don't mind sharing my wifi so I'm running WEP security.

Packages I've got installed:

rt2x00-rt61-fw 1.2-4
wpa_supplicant 0.6.9-2
wireless_tools 29-3
netcfggui 0.5-1
netcfg 2.2.1-1

What's odd is that it'll sometimes connect and keep the connection for a while, and then it'll drop out unexpectedly and sometimes I can reconnect straightaway with "sudo /etc/rc.d/net-profiles restart"
while other times it'll take an hour of restarts before it connects again, I just get "- DHCP IP lease attempt failed."

I tried some Live CD's to test it out further.

gNewSense booted but there I get

phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware

from dmesg (blob?) and no wifi.

Ubuntu (kernel 2.6.24-19) detected it fine and has been running for some hours now without the connection dropping. The Ubuntu hardware tester calls it:

Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
RaLink RT2561/RT61 rev B 802.11g

"lspci | grep Network"
gives the same result on Ubuntu and Arch:

04:05.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

Here are the lsmod results from both:

ubuntu@ubuntu:~$ lsmod|grep rt
rt61pci                25472  0 
rt2x00pci              11264  1 rt61pci
rt2x00lib              22528  2 rt61pci,rt2x00pci
rfkill                  8592  1 rt2x00lib
input_polldev           5896  1 rt2x00lib
crc_itu_t               3072  1 rt2x00lib
mac80211              165652  3 rt61pci,rt2x00pci,rt2x00lib
eeprom_93cx6            3200  1 rt61pci

arch:~$ lsmod|grep rt
rt61pci                18712  0
rt2x00pci               4973  1 rt61pci
rt2x00lib              25533  2 rt61pci,rt2x00pci
led_class               2577  1 rt2x00lib
mac80211              165605  2 rt2x00pci,rt2x00lib
cfg80211              122783  2 rt2x00lib,mac80211
eeprom_93cx6            1320  1 rt61pci
crc_itu_t               1273  2 rt61pci,firewire_core
rtc_cmos                8904  0
rtc_core               14631  1 rtc_cmos
rtc_lib                 1810  1 rtc_core

I'm using network-profiles on Arch, and my /etc/rc.conf contains

gateway="default gw"
DAEMONS=(... !network !netfs @net-profiles ...)

where /etc/network.d/home has my ESSID, WEP key etc.

Can anyone give me a hint as to why my connection keeps dropping? I'm close to buying a new network card just to try it out, but seeing as Ubuntu managed it fine I'm not sure what to do...


#2 2010-02-10 18:38:08

Registered: 2009-10-01
Posts: 97

Re: CNet CWP-854 (Ralink RT2561T) wifi connection dropping

Gave up on this and bought a D-Link G-520 instead; works great with ath_pci (blacklisting ath5k in rc.conf) and net-profiles, no problems at all so far :-)


Board footer

Powered by FluxBB