You are not logged in.

#1 2005-07-14 17:27:42

ezar
Member
Registered: 2005-06-05
Posts: 10

Problem when hibernate using cko (dibble compilation)

I installed kernel cko from comunity and hibernate-script from aur (compilate it) but...
I have a problem... somebody can help me?

I'm using KDE.
In console I write:
[cesar@cesar boot]$ sudo hibernate --kill --force
Some modules failed to unload: nvidia
hibernate: Suspend reported the following errors:
- Suspend was aborted (see dmesg).


why? Somebody use nvidia?

Offline

#2 2005-07-14 17:36:08

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: Problem when hibernate using cko (dibble compilation)

I use nvidia, haven't got it totally working, but to get back to your questions..

you will have to change a little in your hibernate.conf
it lies in /etc/hibernate/


if you look in your dmesg (at the end) you will find the problem(the problem is not nvidia, it is the compression)

I had to manually tell hibernate that I wanted to use comåpression (otherwise I got the same error as you)


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#3 2005-07-14 22:31:42

ezar
Member
Registered: 2005-06-05
Posts: 10

Re: Problem when hibernate using cko (dibble compilation)

Thank you for your answer!!!!! yikes

I add "ProcSetting compressor lzf"  in .conf
It crash system when shutdown.

Can you paste your .conf file?

Offline

#4 2005-07-15 15:06:23

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: Problem when hibernate using cko (dibble compilation)

my config are, unfortunatly, not able to suspend/hibernate at all..

I have similiar problems as you are right now...but I have always had problems with standby/hibernate, and Now I finally have some time to look into it, i'll let you know how it is going big_smile


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#5 2005-07-17 08:11:28

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

Re: Problem when hibernate using cko (dibble compilation)

try the userui scripts from UNSUPPORTED - they can help you find config errors

Offline

#6 2005-07-17 08:39:39

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: Problem when hibernate using cko (dibble compilation)

I have those installed, but don't kow how to use them?!


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#7 2005-07-17 08:57:23

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

Re: Problem when hibernate using cko (dibble compilation)

ummmm - if you do pacman -Ql userui you'll see the scripts listed - trying running them iwith --help

Offline

#8 2005-07-17 10:01:49

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: Problem when hibernate using cko (dibble compilation)

ok, now I have tried around a bit, and I have gotten my script to once again suspending, now the problem is resuming sad

it hangs when info says: "Copying original kernel back"

any ideas?

Update: gotten it to resume when I havent entered X...so it is probaly an nvidia problem...


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#9 2005-07-17 11:22:10

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Problem when hibernate using cko (dibble compilation)

CyberTron wrote:

ok, now I have tried around a bit, and I have gotten my script to once again suspending, now the problem is resuming sad

it hangs when info says: "Copying original kernel back"

any ideas?

Update: gotten it to resume when I havent entered X...so it is probaly an nvidia problem...

im sure the dudes who wrote the hibernate script included a few hacks to work around nvidia.

theres one which is like a fake or secondary or demo X, and theres another option to swap out of X, try enabling them.

iphitus

Offline

#10 2005-07-17 13:14:53

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: Problem when hibernate using cko (dibble compilation)

tried that, doesn't change anything unfortunatly, still has the same error when resuming


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#11 2005-07-17 13:16:18

ezar
Member
Registered: 2005-06-05
Posts: 10

Re: Problem when hibernate using cko (dibble compilation)

cybertron > I have same problem... resume correctly when hibernate without X... whne hibernate in KDE, resume don't work!

### suspend2 (for Software Suspend 2)
UseSuspend2 yes
# Reboot no
#EnableEscape yes
# DefaultConsoleLevel 1
# ImageSizeLimit 200
## useful for initrd usage:
SuspendDevice swap:/dev/hdc6
# LoadSuspendModules suspend_swap suspend_lzf suspend_text
# UnloadSuspendModulesAfterResume yes
## Powerdown method - 3 for suspend-to-RAM, 4 for ACPI S4 sleep, 5 for poweroff
PowerdownMethod 5
## If you experience hangs on resume due to write caching, try this:
# AsyncIOLimit 128
## Any other /proc/software_suspend setting can be set like so:
#ProcSetting expected_lzf_compression 50
ProcSetting compressor lzf
ProcSetting disable_encryption 1
#ProcSetting disable_textmode_support 1
ProcSetting userui_program /usr/sbin/suspend2ui_text
## Or traditionally like this:
# Suspend2AllSettings 0 0 2056 65535 5
## Or even from the results of hibernate --save-settings with this:
# Suspend2AllSettingsFile /etc/hibernate/suspend-settings.conf
## For filewriter:
# FilewriterLocation /suspend_file 1000
# VerifyFilewriterResume2 yes

### sysfs_power_state
## To use /sys/power/state to suspend your machine (which may offer
## suspend-to-RAM, suspend-to-disk, standby, etc) comment out all the options
## above for Software Suspend 2, below for acpi_sleep, and uncomment this line.
## You may replace mem with any one of the states from "cat /sys/power/state"
#UseSysfsPowerState disk
#PowerdownMethod shutdown

### acpi_sleep
## To use ACPI to suspend your machine (via /proc/acpi/sleep), comment out
## all the options above for Software Suspend 2 and sysfs, and uncomment this
## line. The number refers to the ACPI sleep state - 3 is suspend-to-RAM and
## 4 is suspend-to-disk.
# UseACPISleep 4

##############################################################################
### Some global settings
##############################################################################

Verbosity 1
LogFile /var/log/hibernate.log
LogVerbosity 1
# AlwaysForce yes
# AlwaysKill yes
# HibernateVT 15
# Distribution debian (not required - autodetection should work)
# XDisplay :0

##############################################################################
### Scriptlets
###   Scriptlets provide support for doing all sorts of things before and after
###   suspending. The defaults settings here should work for most people, but
###   you may wish to edit these to taste. Consult "hibernate -h" for help on
###   the configuration settings.
##############################################################################

### bootsplash
## If you use bootsplash, also enabling SwitchToTextMode is recommended if
## you use X, otherwise you may end up with a garbled X display.
# Bootsplash on
# BootsplashConfig 
#/etc/bootsplash/default/config/bootsplash-1024x768.cfg

### clock
SaveClock restore-only

### devices
# IncompatibleDevices /dev/dsp /dev/video*

### diskcache
#DisableWriteCacheOn /dev/hda

### fbsplash (enable SwitchToTextMode if you use this)
# FBSplash on
# FBSplashTheme suspend2

### filesystems
#Unmount /mnt/windows
# UnmountFSTypes smbfs nfs
# UnmountGraceTime 1
# Mount /windows

### grub
# ChangeGrubMenu yes
# GrubMenuFile /boot/grub/menu.lst
# AlternateGrubMenuFile /boot/grub/menu-suspended.lst
# BackupGrubMenuFile /boot/grub/menu.lst.hibernate.bak

### hardware_tweaks
# IbmAcpi yes
# RadeonTool yes

### lilo
# EnsureLILOResumes yes

### lock (generally you only want one of the following options)
# LockConsoleAs root
# LockXScreenSaver yes
#LockKDE yes

### misclaunch
# OnSuspend 20 echo "Good night!"
# OnResume 20 echo "Good morning!"

### modules
#UnloadModules ipw2200 fan thermal ohci_hcd uhci_hcd ehci_hcd
#UnloadAllModules yes
UnloadBlacklistedModules yes
# LoadModules auto
# LoadModulesFromFile /etc/modules

### modules-gentoo
#GentooModulesAutoload yes

### network
#DownInterfaces eth0 eth1
#UpInterfaces auto

### programs
# IncompatiblePrograms xmms

### services
#RestartServices 
#StopServices ifplugd net.eth1 net.eth0 bluetooth
#StartServices ifplugd bluetooth

### vbetool
#EnableVbetool yes
# RestoreVbeStateFrom /var/lib/vbetool/vbestate
#VbetoolPost yes

### xhacks
#SwitchToTextMode yes
#UseDummyXServer yes

### xstatus
## This can be set to gnome, kde or x:
XStatus kde
#XSuspendText Preparing to suspend...
#XResumeText Resuming from suspend...
## When using XStatus x, and you have xosd installed:
#XosdSettings --font -misc-fixed-medium-r-semicondensed--*-120-*-*-c-*-*-* --colour=Green -shadow 1 --pos bottom --align center --offset 50

Offline

Board footer

Powered by FluxBB