You are not logged in.

#26 2005-07-15 12:11:23

jerrym
Member
From: Kannapolis, NC
Registered: 2005-07-08
Posts: 60

Re: .

ok, back at my machine at work where i downgraded qt to -7 and had no crashes. i upgraded it back to -8 and got the kwin crash in opera with the plastik theme. changed the theme to keramik and no crashes


He may look like an idiot and talk like an idiot but don't let that fool you. He really is an idiot.
- - - Groucho Marx

Registered Linux User #319935
Registered Linux Machine #204881

Offline

#27 2005-07-15 17:56:11

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

well i don't think its only plastik, (i never use either plastik/liptik/keramik) it happens when i use tiblit...anyway too lazy to workaround so im just using deerpark alpha 2 for the time being till a new package is out..

Offline

#28 2005-07-16 07:09:32

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: .

hey guys
qt-9 is the gcc4 rebuild it's for testing purposes not for production at the moment, we start building stuff with gcc4, i have a full kde rebuild with gcc4, but i will  not upload it, because next wednesday is tagging of 3.4.2 so expect new kde packages next weekend or so, depends on how much trouble is in the prepackages.
to the qt problem:
kde offers patches to qt branch that fixes problems, they were already inculded in -7(we do not apply the labeled unsafe patches).
My problem is i'm running 5 pc's with arch and kde and never had this kwin problem, i cannot reproduce it. I know otheres that also have no problems.
If you experience those crashes, try to rebuild qt without patches, but be prepared that some other problems may arise again.
Else please wait until the new kde release for gcc4 is in testing, perhaps it solves your trouble.
i hope you see my point, i cannot reproduce it so it's very hard for me to guess where the trouble comes from and i can't test what might help.
Thanks for your patience,
greetings
tpowa

Offline

#29 2005-07-16 10:42:57

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: .

ok uploaded kdelibs rebuild with gcc4. now qt and kde should work properly if you use testing, please those with problem check this one, i added 2 new patches from kdetree to qt perhaps your problems will be gone with it.
greetings
tpowa

Offline

#30 2005-07-16 12:14:06

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: .

hi
just grab qt,kdelibs, binutils,gcc,glibc
from testing and install it manually using pacman -U *.pkg.tar.gz
you can go back to older versions with pacman -S gcc qt binutils glibc kdelibs

Offline

#31 2005-07-16 12:14:37

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: .

btw i'm on irc atm you can join the session there smile

Offline

#32 2005-07-16 14:48:21

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

sorry tpowa, ive installed all the new packages and still have the same problem...no problem with qt-7 though..so right now im running the latest binutils,gcc,kdelibs,glibc but the old qt-7 package..

Offline

#33 2005-07-16 21:42:17

VLegacy
Member
From: Vienna, VA, USA
Registered: 2005-01-29
Posts: 40

Re: .

For me, at least, this problem is definitely linked to Opera.

pholie wrote:

... how can someone who doesn't even installed it have this problem too?

Despite the fact that it only happens with Opera for me, it makes sense that the problem is with kwin if people who don't use Opera have had this problem. I guess something in Opera is a trigger.

PS - I use Plastik.

Offline

#34 2005-07-17 02:31:07

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

on a side note, opera seems to load twice as fast in ubuntu (4s) compared to arch(8s)..   :x   is it possible that this is related to the qt packages/patches?...

anyway deleting ~/.opera doesnt make any difference to startup speed or stability..  sad

Offline

#35 2005-07-17 09:03:50

xirus
Member
Registered: 2002-12-01
Posts: 113

Re: .

I've also noticed that opera starts very slow recently

but I don't think opera is the cause for these crashes, as VLegacy said, opera is most likely a trigger of the actual problem

Offline

#36 2005-07-17 12:14:43

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

does anyone know how to get opera to be more verbose on execution when started from a terminal? maybe that way we can diagnose the problem..

Offline

#37 2005-07-17 16:53:17

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

i dont seem to get that warning.all clear for me..maybe if we tell opera not to look at all those fonts, then we might be able to speed it up a bit..any ideas?..

Offline

#38 2005-07-17 18:52:26

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: .

ganja_guru wrote:

does anyone know how to get opera to be more verbose on execution when started from a terminal? maybe that way we can diagnose the problem..

Run opera -help for available options. There are several for debugging different things.

Offline

#39 2005-07-18 00:27:16

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

yeah figured that out thanks to pholie..anyway cant see anything odd and removing unnecessary fonts dont alter speed in any way

Offline

#40 2005-07-21 09:08:08

VLegacy
Member
From: Vienna, VA, USA
Registered: 2005-01-29
Posts: 40

Re: .

Very cool.  smile Thanks, pholie, tpowa, and all of you who helped pin this down.

Offline

#41 2005-07-21 17:47:31

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: .

yup..new packages work brilliantly.....!

Offline

#42 2005-07-28 15:14:33

jerrym
Member
From: Kannapolis, NC
Registered: 2005-07-08
Posts: 60

Re: .

have upgraded everything from testing and no more crashes. using kde 3.4.2 and qt 3.3.4-12 and opera 8.01


He may look like an idiot and talk like an idiot but don't let that fool you. He really is an idiot.
- - - Groucho Marx

Registered Linux User #319935
Registered Linux Machine #204881

Offline

Board footer

Powered by FluxBB