You are not logged in.

#1 2011-12-12 12:47:55

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 376

BCM4313 Wireless LAN Controller Errors

Hi,

this is my wireless card:

Device:	0d:00.0
Class:	Network controller [0280]
Vendor:	Broadcom Corporation [14e4]
Device:	BCM4313 802.11b/g/n Wireless LAN Controller [4727]
SVendor:	Hewlett-Packard Company [103c]
SDevice:	Device [145c]
Rev:	01
Driver:	brcmsmac
Module:	brcmsmac
Module:	bcma

# uname -r
3.1.4-1-ARCH

this errors are shown every time:

Dec 11 21:27:43 localhost kernel: [   16.457367] ieee80211 phy0: brcms_ops_config: change monitor mode: false (implement)
Dec 11 21:27:43 localhost kernel: [   16.458589] ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
Dec 11 21:27:43 localhost kernel: [   16.459872] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Dec 11 21:27:46 localhost kernel: [   19.188219] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
Dec 11 21:27:46 localhost kernel: [   19.188231] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
Dec 11 21:27:46 localhost kernel: [   19.188250] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
Dec 11 21:27:55 localhost kernel: [   28.118211] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
Dec 11 21:30:35 localhost kernel: [  187.752733] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)

is this normal?

Offline

#2 2011-12-13 22:28:23

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 376

Re: BCM4313 Wireless LAN Controller Errors

same with 3.1.5-1-ARCH

Offline

#3 2011-12-14 20:46:12

nathan28
Member
Registered: 2011-05-18
Posts: 61

Re: BCM4313 Wireless LAN Controller Errors

This happens to me with the same card using the brcmsmac module. b43 and broadcom-wl do not print to the console, but I am unable to get the wireless up reliably with either. With brcmsmac I get consistent console spam regardless of the loglevel I set. I am not sure if this is indicative of any problem--brcmsmac prints

[ 9719.866424] brcmsmac: module is from the staging directory, the quality is unknown, you have been warned.

upon being loaded, so I've assumed these are a debugging "feature".


in the beginning was the switch operator

Offline

#4 2011-12-25 23:14:41

Shinmera
Member
Registered: 2011-12-25
Posts: 4

Re: BCM4313 Wireless LAN Controller Errors

I'm having the exact same issue.
Running 3.1.5-1-ARCH too.

My machine is an Asus EEE-Pc 1215N, for which the wiki reports that it should work out of the box, even though it doesn't for me.
The suggested fix in the wiki doesn't change anything, nor does installing broadcom-wl from AUR or manually compiling and installing the driver from the broadcom website.

Last edited by Shinmera (2011-12-25 23:15:38)

Offline

#5 2011-12-27 00:59:01

rjlaing
Member
From: Singapore
Registered: 2011-12-27
Posts: 1

Re: BCM4313 Wireless LAN Controller Errors

I have also been getting this problem on an Acer Aspire with a BCM4313 controller running a fresh build of 3.1.5-1-ARCH with bcma blacklisted.

Dec 27 08:32:54 localhost kernel: [   57.175175] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
Dec 27 08:32:54 localhost kernel: [   57.175317] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
Dec 27 08:32:54 localhost kernel: [   57.175445] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
Dec 27 08:33:00 localhost kernel: [   63.846490] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Dec 27 08:33:00 localhost kernel: [   63.846632] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: disassociated
Dec 27 08:33:00 localhost kernel: [   63.846755] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled false, count 0 (implement)
Dec 27 08:33:02 localhost kernel: [   64.917112] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
Dec 27 08:33:02 localhost kernel: [   64.917254] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
Dec 27 08:33:02 localhost kernel: [   64.917383] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
Dec 27 08:33:08 localhost kernel: [   71.834139] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Dec 27 08:33:08 localhost kernel: [   71.834280] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: disassociated
Dec 27 08:33:08 localhost kernel: [   71.834403] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled false, count 0 (implement)
Dec 27 08:33:33 localhost kernel: [   96.423150] ieee80211 phy0: brcms_ops_config: change monitor mode: false (implement)
Dec 27 08:33:33 localhost kernel: [   96.423250] ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
Dec 27 08:33:33 localhost kernel: [   96.425156] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Dec 27 08:34:10 localhost kernel: [  133.487863] ieee80211 phy0: brcms_ops_config: change monitor mode: false (implement)
Dec 27 08:34:10 localhost kernel: [  133.490522] ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
Dec 27 08:34:10 localhost kernel: [  133.492543] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Dec 27 08:34:13 localhost kernel: [  136.594685] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
Dec 27 08:34:13 localhost kernel: [  136.598192] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
Dec 27 08:34:13 localhost kernel: [  136.601692] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
Dec 27 08:34:26 localhost kernel: [  148.887718] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)

It seems to just cycle through different states and is the same whether I use netcfg, networkmanager, or wicd to invoke a wireless connection. Any suggestions? previous installs/versions of Arch didn't display this behaviour.

And for what it is worth...

07:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    Subsystem: Broadcom Corporation Device 0510
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 17
    Region 0: Memory at 92400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: brcmsmac
    Kernel modules: bcma, brcmsmac

Offline

#6 2011-12-27 13:38:58

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: BCM4313 Wireless LAN Controller Errors

I have a Asus 1215b with the same card and it works fine although the same messages appear. You should all know that the driver is not yet stable and is in the staging tree of the kernel, so i think the messages are normal, because they just say that some functionality is not yet implemented.


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#7 2012-01-02 09:42:40

Shinmera
Member
Registered: 2011-12-25
Posts: 4

Re: BCM4313 Wireless LAN Controller Errors

The issue seems to be resolved for me with the latest kernel update (3.1.6-1).
Is it fixed for anyone else too?

Edit: I seem to be able to connect to the W-LAN network of my phone, but not to the one at home.
The kernel warnings that appeared during boot-time before the kernel update are gone though.

Last edited by Shinmera (2012-01-02 10:21:14)

Offline

#8 2012-01-02 15:06:28

Liquen
Member
Registered: 2009-01-04
Posts: 40

Re: BCM4313 Wireless LAN Controller Errors

Updated to 3.1.6-1-ARCH, but I still get the boot warning messages.

Offline

#9 2012-01-07 03:17:00

kcirick
Member
Registered: 2010-06-21
Posts: 364

Re: BCM4313 Wireless LAN Controller Errors

I have the exact same warning (my kernel is up to date), but my wireless seems to be working. It is still annoying to get these messages.

Does anyone know the reason for these messages? Anyone have solution/how to get rid of these messages?

Offline

#10 2012-01-07 09:39:33

ViruSzZ
Member
From: The Streets
Registered: 2010-10-14
Posts: 202
Website

Re: BCM4313 Wireless LAN Controller Errors

Having the same wifi card and getting the same messages using my own compiled kernel.

Although the messages appear in my logs, the wifi is working fabulously.


Their Momma Made Em, Their Momma Gave em & now she can`t even SAVE`em | My WebLog

Offline

#11 2012-01-31 08:39:41

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 376

Re: BCM4313 Wireless LAN Controller Errors

ViruSzZ wrote:

Having the same wifi card and getting the same messages using my own compiled kernel.

Although the messages appear in my logs, the wifi is working fabulously.

It fails to be used with aireplay and aircrack in general and doesn't authenticate with all access points.. (no apparent reason shown)

Offline

#12 2012-01-31 18:27:00

ecd
Member
Registered: 2010-10-23
Posts: 2

Re: BCM4313 Wireless LAN Controller Errors

I've been getting the same annoying messages for quite some time. Although the wireless is working perfectly, it would be nice to get rid of these messages, which seem to be debug messages anyway.

Does anyone know of a way to suppress them?

ieee80211 phy0: brcms_ops_config: change monitor mode: false (implement)
ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)

Offline

#13 2012-01-31 21:59:14

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

For anyone still having this issue, please perform one or both of the following solutions:

1)  Add the following to your /etc/rc.local file:
     

dmesg -n 3

2)  and/or add this to your kernel line:
     

loglevel=3

so that it looks something like this:

kernel /vmlinuz-linux root=/dev/disk/by-uuid/UUID loglevel=3 ro

______________________________________________
For more info, see this forum thread:
https://bbs.archlinux.org/viewtopic.php?id=128609


I also go by 'clappy.'

Offline

#14 2012-02-01 18:24:56

ecd
Member
Registered: 2010-10-23
Posts: 2

Re: BCM4313 Wireless LAN Controller Errors

Thanks clappy, dmesg -n 3 did the trick...

Offline

#15 2012-02-01 18:26:31

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

ecd wrote:

Thanks clappy, dmesg -n 3 did the trick...

All credit goes to the posters at the link...  Thanks though!  Glad I could help.


I also go by 'clappy.'

Offline

#16 2012-03-27 23:20:48

linkmoises
Member
From: Panama
Registered: 2009-07-15
Posts: 3
Website

Re: BCM4313 Wireless LAN Controller Errors

Thanks clappy! I was tired of those messages

Offline

#17 2012-10-14 13:42:35

SuperBo
Member
Registered: 2012-02-20
Posts: 45

Re: BCM4313 Wireless LAN Controller Errors

thank you for good solution big_smile

Offline

#18 2013-02-16 18:15:14

demencia
Member
Registered: 2011-08-04
Posts: 9

Re: BCM4313 Wireless LAN Controller Errors

How can I fix this using systemd? (theres no /etc/rc.local file)

Offline

#19 2013-02-17 00:53:18

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

demencia wrote:

How can I fix this using systemd? (theres no /etc/rc.local file)

I wasn't aware that this issue was still circulating...

Try this:

Edit the grub config file:

sudo nano /etc/default/grub

...and change this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

...to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"

Then run the command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

I also go by 'clappy.'

Offline

#20 2013-02-17 19:11:37

demencia
Member
Registered: 2011-08-04
Posts: 9

Re: BCM4313 Wireless LAN Controller Errors

clappboard wrote:
demencia wrote:

How can I fix this using systemd? (theres no /etc/rc.local file)

I wasn't aware that this issue was still circulating...

Try this:

Edit the grub config file:

sudo nano /etc/default/grub

...and change this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

...to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"

Then run the command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Thank you very much clappy!

Offline

#21 2013-02-17 19:15:54

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

Glad I could help smile


I also go by 'clappy.'

Offline

#22 2013-04-16 07:35:46

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: BCM4313 Wireless LAN Controller Errors

How can I fix this in syslinux?

Offline

#23 2013-04-16 15:25:23

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

Carlinhos wrote:

How can I fix this in syslinux?

I'm not sure, exactly, I've always used GRUB, but if you look here Syslinux - ArchWiki and here Kernel parameters - Arch Wiki, you see that to add kernel parameters by default to syslinux, you need to edit the file at

/boot/syslinux/syslinux.cfg

and add them to the append line:

APPEND root=/dev/sda3 ro quiet splash

in your case to make it look like this:

APPEND root=/dev/sda3 ro quiet splash loglevel=3

then reboot the system.

Let me know if that works at all!

Last edited by clappboard (2013-04-16 18:44:46)


I also go by 'clappy.'

Offline

#24 2013-04-16 18:58:49

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: BCM4313 Wireless LAN Controller Errors

Thank you, that fixed it indeed, although my append line is a little shorter:

APPEND root=/dev/sda1 ro loglevel=3

Also, running

# syslinux-install_update -i -a -m

might be necessary, not really sure.

Offline

#25 2013-04-16 19:00:47

clappboard
Member
Registered: 2011-11-26
Posts: 39

Re: BCM4313 Wireless LAN Controller Errors

^ Good call.  It couldn't hurt, I don't think.


I also go by 'clappy.'

Offline

Board footer

Powered by FluxBB