You are not logged in.

#1 2011-12-18 18:43:26

f9e3defb
Member
Registered: 2011-11-26
Posts: 4

[SOLVED] Laptop staying very hot on Arch Linux

Hello!

I installed Arch Linux on my laptop (Core i7 Sandy Bridge), and I'm noticing that CPU is running much more hotter than Windows 7. On Windows 7, the same machine runs on 50°C, but in Arch Linux it runs on 65°C, and the fan stay blowing air permanently (while on Windows it stays really quiet).

I changed the CPU frequency governor to ondemand and accepted all the tips from powertop, but the temperature stays high. There is no process using 100% of the processor.

Is there anything that I could do?

Thanks!

Last edited by f9e3defb (2011-12-30 21:39:04)

Offline

#2 2011-12-18 18:51:03

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: [SOLVED] Laptop staying very hot on Arch Linux


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#3 2011-12-18 19:32:52

/dev/zero
Member
From: Melbourne, Australia
Registered: 2011-10-20
Posts: 1,176
Website

Re: [SOLVED] Laptop staying very hot on Arch Linux


Linux is NOT Windows | The Rootless Root
Toshiba Satellite i5-3230M 2.6GHz CPUs, 4Gb RAM, ArchLinux, wmii, nVidia GeForce GT 740M.

Offline

#4 2011-12-19 01:27:48

triumphguy
Member
From: Alabama, USA
Registered: 2010-12-26
Posts: 31

Re: [SOLVED] Laptop staying very hot on Arch Linux

I had a similar issue with my Intel i5 and the integrated Intel graphics.  The following article solved my problem.  It appears that they have had some hardware issues and therefore disabled some of the power reducing features.  You didn't say what kind of video processor you have but this might help.

http://www.phoronix.com/scan.php?page=a … ower&num=1

Offline

#5 2011-12-19 09:13:24

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 395

Re: [SOLVED] Laptop staying very hot on Arch Linux

/dev/zero wrote:

/dev/zero it's right

yes try this out https://bbs.archlinux.org/viewtopic.php?id=132077 it worked for me
Adapter: ISA adapter
Physical id 0:  +43.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +40.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +43.0°C  (high = +86.0°C, crit = +100.0°C)

Last edited by r0b0t (2011-12-19 09:13:50)

Offline

#6 2011-12-19 19:53:31

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Laptop staying very hot on Arch Linux

If you are using the integrated intel graphics try adding these to your grub line to enable some more advanced power saving settings for the intel graphics:

pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1

Also if you aren't using laptop-mode-tools I recommend you do, it can have a huge effect on battery life.

EDIT: I should have clicked that phoronix link since it says the same thing I just posted lol hmm

Last edited by bwat47 (2011-12-19 19:56:43)

Offline

#7 2011-12-20 14:04:58

arch-curio
Member
From: Beijing, China
Registered: 2011-12-20
Posts: 4

Re: [SOLVED] Laptop staying very hot on Arch Linux

bwat47 wrote:

If you are using the integrated intel graphics try adding these to your grub line to enable some more advanced power saving settings for the intel graphics:

pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1

Also if you aren't using laptop-mode-tools I recommend you do, it can have a huge effect on battery life.

EDIT: I should have clicked that phoronix link since it says the same thing I just posted lol hmm

Great!! It`s works for me.

but the phoronix link said:

Similar to how PCI Express Active-State Power Management (PCI-E ASPM) can be forced by adding "pcie_aspm=force" to your kernel's boot arguments, to bypass the cause of the major Linux kernel power regression due to the ASPM change in Linux 2.6.38, there's separately a number of arguments that can be passed to the open-source Intel Linux DRM kernel driver to reduce the power consumption on that front. These enable power-saving features of the Intel Linux graphics driver that aren't enabled by default at this time, commonly because for some hardware configurations they can cause stability problems or other issues.


so maybe "pcie_aspm=force" is not necessary. Anyway, great.....


Jump to Arch, and stay here......

Offline

#8 2011-12-20 14:26:33

arch-curio
Member
From: Beijing, China
Registered: 2011-12-20
Posts: 4

Re: [SOLVED] Laptop staying very hot on Arch Linux

Thanks to triumphguy and bwat47.

I resolve the problem like this(for Intel Core i3 integrated graphics):

First, add some options in /etc/modprobe.d/modprobe.conf:

options i915 modeset=1
options i915 i915_enable_rc6=1 
options i915 i915_enable_fbc=1 
options i915 lvds_downclock=1

And in /etc/mkinitcpio.conf:

MODULES="...i915"
FILES=".../etc/modprobe.d/modprobe.conf"

...means what you already have.


finally in console:

$sudo mkinitcpio -p linux

reboot, cool and noiseless....:lol::lol::lol::lol:


Jump to Arch, and stay here......

Offline

#9 2011-12-20 22:44:38

Viper_Scull
Member
From: London, UK
Registered: 2011-01-15
Posts: 153

Re: [SOLVED] Laptop staying very hot on Arch Linux

kernel 3.2 is gonna bring rc6 by default on Ivy bridge and also on Sandy Bridge if VTd is disabled.


Athlon II X4 620 + Gigabyte 785GPM-UD2H + 4GB DDR3 + SSD OCZ Vertex2 60GB

Archlinux x86_64 + Openbox

Offline

#10 2011-12-20 23:23:08

/dev/zero
Member
From: Melbourne, Australia
Registered: 2011-10-20
Posts: 1,176
Website

Re: [SOLVED] Laptop staying very hot on Arch Linux

arch-curio wrote:

Thanks to triumphguy and bwat47.

I resolve the problem like this(for Intel Core i3 integrated graphics):

First, add some options in /etc/modprobe.d/modprobe.conf:

options i915 modeset=1
options i915 i915_enable_rc6=1 
options i915 i915_enable_fbc=1 
options i915 lvds_downclock=1

And in /etc/mkinitcpio.conf:

MODULES="...i915"
FILES=".../etc/modprobe.d/modprobe.conf"

...means what you already have.


finally in console:

$sudo mkinitcpio -p linux

reboot, cool and noiseless....:lol::lol::lol::lol:

Please forgive me if I'm having a moment of stupidity here. It isn't quite clear to me why you've chosen to include the i915 module by altering mkinitcpio.conf. Would it not be sufficient to call it as one of the modules listed in /etc/rc.conf?


Linux is NOT Windows | The Rootless Root
Toshiba Satellite i5-3230M 2.6GHz CPUs, 4Gb RAM, ArchLinux, wmii, nVidia GeForce GT 740M.

Offline

#11 2011-12-21 02:50:03

arch-curio
Member
From: Beijing, China
Registered: 2011-12-20
Posts: 4

Re: [SOLVED] Laptop staying very hot on Arch Linux

/dev/zero wrote:
arch-curio wrote:

Thanks to triumphguy and bwat47.

I resolve the problem like this(for Intel Core i3 integrated graphics):

First, add some options in /etc/modprobe.d/modprobe.conf:

options i915 modeset=1
options i915 i915_enable_rc6=1 
options i915 i915_enable_fbc=1 
options i915 lvds_downclock=1

And in /etc/mkinitcpio.conf:

MODULES="...i915"
FILES=".../etc/modprobe.d/modprobe.conf"

...means what you already have.


finally in console:

$sudo mkinitcpio -p linux

reboot, cool and noiseless....:lol::lol::lol::lol:

Please forgive me if I'm having a moment of stupidity here. It isn't quite clear to me why you've chosen to include the i915 module by altering mkinitcpio.conf. Would it not be sufficient to call it as one of the modules listed in /etc/rc.conf?

I`m a linux newcomer, and just follow this Wiki: big_smile big_smile

https://wiki.archlinux.org/index.php/Intel

I guess that just like prepostion(/etc/mkinitcpio.conf) and postpostion(/etc/rc.conf), should have same effect.


Jump to Arch, and stay here......

Offline

#12 2011-12-21 02:56:59

arch-curio
Member
From: Beijing, China
Registered: 2011-12-20
Posts: 4

Re: [SOLVED] Laptop staying very hot on Arch Linux

with

$sudo get_module i915

I get

        initstate            : live
        refcnt               : 3
        uevent               : (null)
Parameters:
        enable_hangcheck     : Y
        fbpercrtc            : 0
        i915_enable_fbc      : 1
        i915_enable_rc6      : 1
        lvds_downclock       : 1
        lvds_use_ssc         : 1
        modeset              : 1
        panel_ignore_lid     : 0
        powersave            : 1
        reset                : Y
        semaphores           : 0
        vbt_sdvo_panel_type  : -1
Sections:
        .altinstr_replacement : 0xffffffffa0106025
        .altinstructions     : 0xffffffffa0118ab0
        .bss                 : 0xffffffffa01254b8
        .data                : 0xffffffffa0118e80
        .data..read_mostly   : 0xffffffffa0124ba0
        .devinit.text        : 0xffffffffa010593c
        .exit.text           : 0xffffffffa0105959
        .fixup               : 0xffffffffa0105f21
        .gnu.linkonce.this_module : 0xffffffffa0125260
        .init.text           : 0xffffffffa0130000
        .note.gnu.build-id   : 0xffffffffa0106040
        .parainstructions    : 0xffffffffa01185a0
        .rodata              : 0xffffffffa0106100
        .rodata.str1.1       : 0xffffffffa0113609
        .rodata.str1.8       : 0xffffffffa010eea0
        .smp_locks           : 0xffffffffa0116d58
        .strtab              : 0xffffffffa013b4c0
        .symtab              : 0xffffffffa01300c0
        .text                : 0xffffffffa007d000
        .text.unlikely       : 0xffffffffa0105972
        __bug_table          : 0xffffffffa01186dc
        __ex_table           : 0xffffffffa0118920
        __jump_table         : 0xffffffffa011b4e0
        __kcrctab_gpl        : 0xffffffffa01060c0
        __ksymtab_gpl        : 0xffffffffa0106070
        __ksymtab_strings    : 0xffffffffa0118548
        __mcount_loc         : 0xffffffffa0116f08
        __param              : 0xffffffffa0116d88
        __tracepoints_ptrs   : 0xffffffffa0118af0
        __tracepoints_strings : 0xffffffffa0118bb0
        __tracepoints        : 0xffffffffa0124ca0
        _ftrace_events       : 0xffffffffa0124bd0

Last edited by arch-curio (2011-12-21 02:58:50)


Jump to Arch, and stay here......

Offline

#13 2011-12-21 02:57:02

/dev/zero
Member
From: Melbourne, Australia
Registered: 2011-10-20
Posts: 1,176
Website

Re: [SOLVED] Laptop staying very hot on Arch Linux

arch-curio wrote:
/dev/null wrote:

Please forgive me if I'm having a moment of stupidity here. It isn't quite clear to me why you've chosen to include the i915 module by altering mkinitcpio.conf. Would it not be sufficient to call it as one of the modules listed in /etc/rc.conf?

I`m a linux newcomer, and just follow this Wiki: big_smile big_smile

https://wiki.archlinux.org/index.php/Intel

I guess that just like prepostion(/etc/mkinitcpio.conf) and postpostion(/etc/rc.conf), should have same effect.

Okay, I hadn't seen that wiki entry before. I'm only fairly new to Arch myself, so I was wondering if I misunderstood something :-)


Linux is NOT Windows | The Rootless Root
Toshiba Satellite i5-3230M 2.6GHz CPUs, 4Gb RAM, ArchLinux, wmii, nVidia GeForce GT 740M.

Offline

#14 2011-12-27 22:10:04

f9e3defb
Member
Registered: 2011-11-26
Posts: 4

Re: [SOLVED] Laptop staying very hot on Arch Linux

Thanks for all your help. With those suggested configurations, the CPU temperature went down from 65C to 54C, but the fan continues to be always on, making lots of noise. I did the procedures at https://wiki.archlinux.org/index.php/Fan_Speed_Control but it seems that my laptop don't have the ability to colect fan speed. Output of sensors:

acpitz-virtual-0
Adapter: Virtual device
temp1:        +54.0°C  (crit = +100.0°C)
temp2:        +54.0°C  (crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:        +58.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +59.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +55.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +59.0°C  (high = +86.0°C, crit = +100.0°C)

Offline

#15 2012-05-11 18:50:32

DarwinSurvivor
Member
Registered: 2009-08-05
Posts: 9

Re: [SOLVED] Laptop staying very hot on Arch Linux

@bwat47 THANK YOU. I was getting 5.5 - 6 hours on my 9-cell battery. Adding those grub options just bumped my expected time (by reading smapi) to 8.5 - 9 hours! I will *definitely* have to do a burn-down test to see how long it actually lasts.

50% more battery is ALWAYS a good thing to see!!!

Offline

Board footer

Powered by FluxBB