You are not logged in.

#51 2012-01-17 18:01:40

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] Pacman wont upgrade any packages

This worked for me smile

sudo pacman -Rdd pacman-color
sudo pacman -Rdd package-query
sudo pacman -Syu
sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf
sudo pacman-key --init
sudo pacman -Syu

I thinks its time for new arch linux 2012 iso smile


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#52 2012-01-17 18:03:07

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

Why a new iso? Any problems with the 2011.08.19 one?

Offline

#53 2012-01-17 19:36:05

Sotanaht
Member
Registered: 2012-01-14
Posts: 29

Re: [SOLVED] Pacman wont upgrade any packages

I'm having the "requires pacman<3.6" issue as well.  If I just wait a few days for everything to catch up to pacman, would that fix the problem?  I'd rather not mess around right now, I have enough troubles with my arch install as is.

Offline

#54 2012-01-17 19:44:50

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

You think that the apps you have installed will magically stop requiring pacman<3.6? I don't think so.
Many apps have updated versions that can use pacman 4, but you need to update pacman first. https://bbs.archlinux.org/viewtopic.php … 4#p1042014

You want to give as much details as possible and after reading your post I don't know what apps you have in mind so I can only give you generic help.

Offline

#55 2012-01-17 20:06:32

tolmun
Member
Registered: 2011-12-04
Posts: 8

Re: [SOLVED] Pacman wont upgrade any packages

Hi there,
when checking rc.conf, is same as before.
There is rc.conf.pacnew which is empty.
And all is working.

Did i miss something?

Offline

#56 2012-01-17 20:07:50

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,798
Website

Re: [SOLVED] Pacman wont upgrade any packages

tolmun wrote:

Hi there,
when checking rc.conf, is same as before.
There is rc.conf.pacnew which is empty.
And all is working.

Did i miss something?

The file that you want to merge your pacnew with is /etc/pacman.conf...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#57 2012-01-17 20:08:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

If you updated only pacman then I doubt rc.conf was touched, as it belongs to initscripts package ... In this case rc.conf.pacnew shouldn't be empty - it shouldn't be there at all.

Offline

#58 2012-01-17 20:12:41

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,798
Website

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

If you updated only pacman then I doubt rc.conf was touched, as it belongs to initscripts package ... In this case rc.conf.pacnew shouldn't be empty - it shouldn't be there at all.

Unless the poster did something like

vimdiff /etc/rc.conf{,.pacnew}

then an empty file called rc.conf.pacnew would be opened...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#59 2012-01-17 20:14:05

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

Good point.

I meant that rc.conf.pacnew will be created when the package that provides rc.conf is updated.

Offline

#60 2012-01-17 20:31:46

tolmun
Member
Registered: 2011-12-04
Posts: 8

Re: [SOLVED] Pacman wont upgrade any packages

Searching history i find my lapsus, when posting.

sudo mv /etc/pacman.conf ~/pacman.conf.backup
sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf 

This change something?

Offline

#61 2012-01-17 20:33:55

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

tolmun wrote:

Searching history i find my lapsus, when posting.

sudo mv /etc/pacman.conf ~/pacman.conf.backup
sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf 

This change something?

You should be able to answer this question yourself.

From pacman's perspective it's OK as you have some /etc/pacman.conf. If you're OK with old configs in your ~ - all is well.

Offline

#62 2012-01-18 04:06:35

geo909
Member
Registered: 2008-09-07
Posts: 275

Re: [SOLVED] Pacman wont upgrade any packages

TuxLyn wrote:

This worked for me smile

sudo pacman -Rdd pacman-color
sudo pacman -Rdd package-query
sudo pacman -Syu
sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf
sudo pacman-key --init
sudo pacman -Syu

Many thanks! That did the job for me, too.

EDIT: Then I cannot install programs with yaourt anymore, though..

yaourt -S Profile-sync-daemon
/usr/lib/yaourt/util.sh: line 165: package-query: command not found
/usr/lib/yaourt/util.sh: line 165: package-query: command not found
/usr/lib/yaourt/util.sh: line 165: package-query: command not found
error: target not found: Profile-sync-daemon
missing dependency for yaourt : package-query>=0.7

Last edited by geo909 (2012-01-18 04:10:13)

Offline

#63 2012-01-18 04:32:44

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,550

Re: [SOLVED] Pacman wont upgrade any packages

Reinstall package-query and yaourt, duh! Logic people, you can buy it in bulk at any corner drugstore. wink


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#64 2012-01-18 04:38:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

That's what happens if you copy-paste commands w/o a clue why you should be doing it.

Offline

#65 2012-01-18 04:48:04

geo909
Member
Registered: 2008-09-07
Posts: 275

Re: [SOLVED] Pacman wont upgrade any packages

fsckd wrote:

Reinstall package-query and yaourt, duh! Logic people, you can buy it in bulk at any corner drugstore. wink

No need to be mean, although I understand. I actually missed posting that I couldn't install package-query and yaourt
but that was also my fault, I had forgotten to uncomment 'testing' from then new pacman.conf. Everything works now.

Offline

#66 2012-01-18 04:58:06

geo909
Member
Registered: 2008-09-07
Posts: 275

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

That's what happens if you copy-paste commands w/o a clue why you should be doing it.

That wasn't the case. Anyway, please, enough irony for now guys. I did a mistake (though I always do try to
follow the forum's savoir-vivre, RTFM's, etc) and I apologize for wasting your time.

Cheers

Offline

#67 2012-01-18 05:58:10

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,831

Re: [SOLVED] Pacman wont upgrade any packages

geo909 wrote:
fsckd wrote:

Reinstall package-query and yaourt, duh! Logic people, you can buy it in bulk at any corner drugstore. wink

No need to be mean, although I understand. I actually missed posting that I couldn't install package-query and yaourt
but that was also my fault, I had forgotten to uncomment 'testing' from then new pacman.conf. Everything works now.

How is uncommenting [testing] related to getting AUR packages to work?


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#68 2012-01-18 06:43:09

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

Maybe he meant [archlinuxfr]?

Offline

#69 2012-01-18 12:35:44

geo909
Member
Registered: 2008-09-07
Posts: 275

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

Maybe he meant [archlinuxfr]?

Yes, you're right.. Sorry, I was posting late at night, I was kind of lost
with the new situation and very tired. Shouldn't be posting.

Offline

#70 2012-01-18 21:35:13

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] Pacman wont upgrade any packages

@karol, just the fact that there is a lot of walls for new installs now. Unless you use netbook ;-)

To install from 2011.08.19 iso, you need to all of this following steps now.

-- pacman 4 moves to [core], need to upgrade pacman with above example.
-- Users of unofficial kernels must enable devtmpfs support
-- filesystem upgrade - manual intervention required
-- initscripts update - manual intervention required

and the list just keeps growing with upgrades.


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#71 2012-01-18 21:57:55

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: [SOLVED] Pacman wont upgrade any packages

So the problem is an outdated archlinux image? Is this not easily resolved or am I oversimplifying?

Edit: What karol said below, there you go.

Last edited by Earnestly (2012-01-19 11:15:38)

Offline

#72 2012-01-19 10:32:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] Pacman wont upgrade any packages

If you use a netinstall you will get just the new packages.
https://bbs.archlinux.org/viewtopic.php?id=133362

Offline

#73 2012-01-19 20:47:53

trazalca
Member
Registered: 2012-01-19
Posts: 11

Re: [SOLVED] Pacman wont upgrade any packages

ok, thanks guys..  solved!!!
+1 for u!

Last edited by trazalca (2012-01-19 20:50:26)

Offline

#74 2012-01-21 22:46:33

bhadotia
Member
From: Karnal, India
Registered: 2008-12-09
Posts: 87

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

first you update pacman, merge pacnew files and run pacman again to update the rest of the system.

Hey just wanted to point out something that happened to me while I was trying to solve this issue. I had packagekit installed so I was unable to update pacman. So, I waited for an update to packagekit to happen. When that arrived I updated packagekit which also updated pacman as a dependency:

[abhishek@Nitaichand ~]$ sudo pacman -S packagekit
Password: 
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

resolving dependencies...
looking for inter-conflicts...

Targets (3): libarchive-3.0.3-2  pacman-4.0.1-4  packagekit-0.6.21-1

Total Download Size:    0.58 MB
Total Installed Size:   12.12 MB

Proceed with installation? [Y/n] y
:: Retrieving packages from community...
 packagekit-0.6.21-...   589.1K  182.4K/s 00:00:03 [######################] 100%
(3/3) checking package integrity                   [######################] 100%
(3/3) checking for file conflicts                  [######################] 100%
(1/3) upgrading libarchive                         [######################] 100%
(2/3) upgrading pacman                             [######################] 100%
 >>> Run `pacman-key --init` to set up your pacman keyring.
(3/3) upgrading packagekit                         [######################] 100%

Now when I tried to merge my new pacman.conf I found that I did not recieve any pacman.conf.pacnew. Any on ideas why this happened.
BTW, I ran the pacman-key --init command and this is what I got:

[abhishek@Nitaichand ~]$ sudo pacman-key --init
Password: 
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: Generating pacman keychain master key...

Not enough random bytes available.  Please do some other work to give
the OS a chance to collect more entropy! (Need 128 more bytes)
.......+++++
+++++
gpg: key blahblah marked as ultimately trusted
gpg: Done
==> Updating trust database...
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u

Is this alright?

Last edited by bhadotia (2012-02-16 18:29:31)

Offline

#75 2012-01-21 22:57:21

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: [SOLVED] Pacman wont upgrade any packages

Now when I tried to merge my new pacman.conf I found that I did not recieve any pacman.conf.pacnew. Any on ideas why this happened.

If you did not change the original pacman.conf, it will just be updated with the new version. See the pacnew wiki page for how it works.

Offline

Board footer

Powered by FluxBB