You are not logged in.

#1 2012-02-12 00:58:22

cyberic
Member
Registered: 2012-01-11
Posts: 32
Website

various problems encountered when installing arch PPC (and solutions)

Hello

I've just finished to install arch on PPC

It has been harder that I thought, mainly because the installer/livecd in outdated

I will post the problems I had and their solutions here, because I do not really know where to report bugs...

During install:
1) ca-certificates cannot be installed because of the locale
see here: https://bugs.archlinux.org/task/26678
solution:
edit /etc/locale.gen, add
en_US ISO-8859-1
en_US.UTF-8 UTF-8
and run locale-gen

2) 'install kernel' menu option does not work
because it kernel names have changed
A 3.0 kernel is install anyway, but BOTH versions: linux-pmac and linux-pmac64

After install:
3) missing libraries for pacman
pacman cannot run because it needs librtmp and libnettle, which are not installed
Solution:
get nettle and librtmp for the repos, extract them and copy the missing libs

4) yaboot.conf has to be adjusted,
see here: https://bbs.archlinux.org/viewtopic.php?id=133581

5) syslog-ng needs libwrap.so.0 from tcp_wrappers, it has to be recompiled without support for tcp_wrappers.

6) add 'jbd ext3' in MODULES section of mkinitcpio.conf, otherwise the modules will not load automatically and root fs won't be mounted (might be related to kmod dependancy problem)

Maybe it's time for an updated livecd, how can I help?

7) Edit: After installing iana-etc, /etc/services and /etc/protocols wher empty!??, which prevented ntp from running
I copied this files from another box...

Thanks
Eric

Last edited by cyberic (2012-02-14 09:37:21)

Offline

#2 2012-02-12 18:57:23

schef
Member
Registered: 2009-04-16
Posts: 61

Re: various problems encountered when installing arch PPC (and solutions)

Hi..Thanks for your post..i succeded installing archlinuxppc..:)

the changes that i made was that used mkfs.ext4 instead of ext3 after installing packages through /arch/setup's pacman i chrooted into the system and installed kernel from there and yaboot loader..so i'm in the system..aha and yabootconfig asked me for kernel location /boot/vmlinuz-linux-pmac and /boot/initramfs-linux-pmac.img were.

Stef

Online

#3 2012-02-12 21:51:56

cyberic
Member
Registered: 2012-01-11
Posts: 32
Website

Re: various problems encountered when installing arch PPC (and solutions)

Great! I wonder if this is the "official" way to discuss archlinux ppc problems....
anyone knows?

I've stubled upon a bugtracker at bugs.archlinuxppc.org, but it seems outdated

I was able to find the svn repository as well, but nothing is documented!

I'll be glad to help if someone tells me where to start!

Offline

#4 2012-02-14 09:21:45

schef
Member
Registered: 2009-04-16
Posts: 61

Re: various problems encountered when installing arch PPC (and solutions)

Maybe it is. I think there shuld be a one place where everybody should share ther experiences. How did thay manage to setup drivers but with a lot of information not just b43 maybe something like a little howto (i stil didnt manage to connect to a wireless network, i cat scan it but it wont attach, i have from lspci broadcom 4306, chipset 4320), and how did thay manage to set up hwclock..and other usfull things..for example what did thay use to install pachages from ABS (i found absoultion and it works good but lecks of dependencies issue..maybe i shoud fix this script so it will be complete). And i would want to help you. So i wouldn't to have trying to rember what were my steps setting up my ibook..:)

Online

#5 2012-02-15 12:26:22

DaNiMoTh
Member
Registered: 2006-06-10
Posts: 253

Re: various problems encountered when installing arch PPC (and solutions)

I'm in the process to patch archboot, in order to make a new installation CD.

Please, share your thoughs on the bugtracker (bugs.archlinuxppc.org) and/or the mailing list ( http://groups.google.com/group/archlinuxppc-user ).

Offline

#6 2012-02-15 13:37:05

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: various problems encountered when installing arch PPC (and solutions)

schef wrote:

Maybe it is. I think there shuld be a one place where everybody should share ther experiences. How did thay manage to setup drivers but with a lot of information not just b43 maybe something like a little howto (i stil didnt manage to connect to a wireless network, i cat scan it but it wont attach, i have from lspci broadcom 4306, chipset 4320), and how did thay manage to set up hwclock..and other usfull things..for example what did thay use to install pachages from ABS (i found absoultion and it works good but lecks of dependencies issue..maybe i shoud fix this script so it will be complete). And i would want to help you. So i wouldn't to have trying to rember what were my steps setting up my ibook..:)

I had the same problem with wireless and my ibook. Changing to WEP solved my problem. I used wicd.

Offline

#7 2012-02-15 13:45:08

schef
Member
Registered: 2009-04-16
Posts: 61

Re: various problems encountered when installing arch PPC (and solutions)

My wireless at home is open. And i can't get attach with

iwconfig wlan0 essid nameofap
ifconfig wlan0 up

usualy i can connect like this with other PC-s..
Maybe i should switch to WEP..:)

When i try with netcfg i get  > WPA Authentication/Association Failed and i have no encrytion at all..

Online

#8 2012-03-01 16:46:25

MrE
Member
From: London
Registered: 2009-01-13
Posts: 18

Re: various problems encountered when installing arch PPC (and solutions)

Thanks Cyberic

With your notes I've managed to succesfully complete the installation and I now have a shiny new command line Arch PPC iBook :-)

The bigger problem seems to be that many packages are missing from the repos, well, repo as none of the others seem to work anymore.

Have you managed to get Xorg installed?


My new username is now Aerion in order to match my username on the AUR, Wiki and Bug Reports.

Offline

#9 2012-03-01 17:46:01

cyberic
Member
Registered: 2012-01-11
Posts: 32
Website

Re: various problems encountered when installing arch PPC (and solutions)

I'm glad it worked for you

I haven't updated my distrib since a while but yes, everything was there
I saw your post on the archppc list, I think this problem is only temprary...

I think we should just wait a bit....

Offline

Board footer

Powered by FluxBB