You are not logged in.

#1 2012-02-16 18:36:46

Lockheed
Member
Registered: 2010-03-16
Posts: 1,440

[solved] Can't change mouse cursor

I downloaded some cursors from gnome-look.org. I placed them where they should be and run
xfce4-mouse-settings

I selected desired cursor but it had no effect. Even after reboot I am still stuck with the default one, even though if I run xfce4-mouse-settings the correct one is still selected.

Last edited by Lockheed (2012-02-17 11:41:50)


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#2 2012-02-16 20:45:12

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: [solved] Can't change mouse cursor

Since you use xfce, maybe it is related to this? https://bbs.archlinux.org/viewtopic.php?id=131065

Offline

#3 2012-02-16 20:58:23

Lockheed
Member
Registered: 2010-03-16
Posts: 1,440

Re: [solved] Can't change mouse cursor

It does look related, although I never see the new cursor since I am running GTK throughout.
However, the solution proposed there did nothing for me.


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#4 2012-02-16 21:08:28

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: [solved] Can't change mouse cursor

How about cursors from widely-used packages? Can you use them? Do you set the xcursor in xinitrc?

Offline

#5 2012-02-16 22:24:13

Lockheed
Member
Registered: 2010-03-16
Posts: 1,440

Re: [solved] Can't change mouse cursor

I'm not sure what do you mean. I set the cursor through xfce4-mouse-settings.


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#6 2012-02-17 10:05:19

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [solved] Can't change mouse cursor

When you say you placed them where they should be, you mean the icons folder, right?

Here are some cursors:

$ pacman -S xcursor-vanilla-dmz
$ pacman -S xcursor-neutral

They will be installed in /usr/share/icons/ for system-wide availability. If you want them per user, copy their respective folders to ~/.icons (run pacman -Ql foo to find out what they are called).

I don't know about "xfce4-mouse-settings" (because I haven't tried Xfce in a very long time) but changing them using lxappearance works just fine. Give it a shot.

If that doesn't work, you could manually edit ~/.icons/default/default.theme:

nano ~/.icons/default/default.theme
[Icon Theme]
Name=Default
Comment=Default Cursor Theme
Inherits=Neutral

But this should be the last resort. It's usually not recommended because when you use something like lxappearance that also sets the GTK theme, icons, etc., your changes will be replaced by whatever was set last.


PS: Don't forget to add [SOLVED] to the topic.

Last edited by DSpider (2012-02-17 10:51:28)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#7 2012-02-17 11:19:05

Lockheed
Member
Registered: 2010-03-16
Posts: 1,440

Re: [solved] Can't change mouse cursor

Thanks, DSpider.  lxapparance did work!

Last edited by Lockheed (2012-02-17 11:41:32)


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

Board footer

Powered by FluxBB