You are not logged in.

#1 2012-02-28 23:43:38

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

[SOLVED] Google chrome/chromium freezing when typing in address bar

Hello again everyone, sorry to bother you.

Im using Arch 64 bit + kde.

Recently my chromium began freezing at random when I begin typing in the address bar. Since it persisted after several updates I installed google chrome beta from AUR, and the problem persists there. I've tried deleting the configuration directory to no avail.

I am a web developer and therefore this is kind of extremely annoying, I need more browsers than just Firefox so I thought about asking your help, are there any of you with a 64 bit arch system in which chrome works flawlessly? Did you do anything special?

Im beggining to think this is a chrome bug:
http://www.google.com/support/forum/p/C … 253b&hl=en

I found as well an old thread here in the forums:
https://bbs.archlinux.org/viewtopic.php?id=129632

But I decided to not be a thread necromancer.

My google chrome version is: 18.0.1025.39 beta
My chromium version is: 17.0.963.56

I'm willing to recompile this thing if you think that will help, but I've heard horrible stories about compiling chrome. Any help will be tremendously appreciated.

Last edited by denn1s (2012-03-10 17:46:50)


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#2 2012-02-29 14:51:58

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Hello, I have the same problem - when typing in the address bar, chromium hangs.
chromium crashes in KDE but xfce working properly.
I decided to experiment and did the following:
I created a new user account and copied to the user's home directory ~ /. kde4 (of my old user), changing the permissions for the new user.
So far, the new user account works fine chromium.
So I tried to do this:
1. Changed the theme.
2. turned off the  effects in the KDE
3. clean out ~/.cache/chromium/ and ~ /.config /chromium/
4. delete /var/tmp/kdecache-user0/
5. delete ~ /. kde4

did not work.
work only in xfce and work in the new user account in kde4.

PS: sorry for my english smile

Offline

#3 2012-02-29 15:29:15

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Looks like KDE is at fault here. Almost the same problem appears with firefox: https://bbs.archlinux.org/viewtopic.php?id=136752

Offline

#4 2012-02-29 23:04:53

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

I dont know if this is relevant, but I too am using the nvidia driver (firefox bug reported it)

@killer1804

Are you using the nvidia driver by chance?

Just trying to track down the problem smile


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#5 2012-03-01 05:17:44

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

yes, my card is nvidia 8600GT.

This morning I spent a few experiments.
1. I noticed that if you run full-screen application (game), then when you try to switch to the console - is a black screen without text, a problem arises as in KDE and in xfce, if you switch to the console without running full screen applications, the when switching to the console you can see the shell prompt to login (enter your login and password), both in KDE and in xfce.
I tried to remove the option "VGA = 773" from the boot parameter has the kernel (GRUB), and the problem with switching to the console was gone.
2. I made a nvidia-xconfig, creating a file /etc/x11/xorg.conf, rebooted (with the VGA = 773), and logged in to KDE user denis (yes my name is Denis too smile), the name of my new account, the name of the old - user0), and the Problem with switching to the console was gone, at least for now.
I think that the Problem with chromium somehow connected with the fact that the video card is Nvidia and its mode of operation, which hurt when you log in to your account.
How does chromium in KDE in your account until Dennis, I have not tested that particular - will be tested, the result accomplish your goal.

So try to remowe vga=773 from kernel line, and and see how it will work chromium.
But i still dont know, why chromium work fine in xfce, but freezing in KDE...

Last edited by killer1804 (2012-03-01 06:00:05)

Offline

#6 2012-03-01 17:46:11

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

my problem is solved as follows:

1. created a new user account.
2. copied to the new user's home directory folder ~ /. kde4
3. corrected premissons for files and directories in ~ /. kde4

now Chromium works fine.
PS: no manipulation of the video card driver did not help.

Offline

#7 2012-03-03 16:59:53

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

So, so far we know this has something to do with kde's config, and with people named dennis wink

I tried your procedure of copying another user's .kde folder, but sadly the problem still persisted, even thou it indeed was harder to reproduce.

I have a fluxbox install, I will try and see if the bug shows there and report back.

EDIT:

I can confirm fluxbox does not show this freezing behavior, only kde. so weird. Turning off desktop effects doesn't seem to fix it in kde either.

Last edited by denn1s (2012-03-03 17:02:57)


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#8 2012-03-04 13:25:04

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

If Chromium freezes in KDE, but works fine in other desktop environments, the reason for freezing of chromium in some KDE services.
I think that this is akonadi and Nepomuk.
Try to do the following:
1. log out from KDE to сonsole or fluxbox
2. remove or rename  from your home directory all that is irrelevant to the services akonadi Nepomuk (configs. db files, etc)
3. remove or rename everything from / var/tmp/kdecache- * Your user *
4. remove or rename the directory ~/.cache/chromium ~/.config/chromium
5. check free space in your ~/ directory (I had a little free space, the problem could arise for this reason)
6. check whether these files ~/.xinitrc ~/.xsession
7. log in to KDE, and turn off akonadi and Nepomuk service.

I hope that these steps will help your chrome work fine smile

EDIT:

Today chromium freezing again. well...now i try to disable nepomuk service in "system settings".

Last edited by killer1804 (2012-03-04 15:26:05)

Offline

#9 2012-03-04 20:59:44

syms
Member
Registered: 2008-12-25
Posts: 292

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Sorry for not posting solution for the original thread but i found solution quite some time ago. the problem is related to pulseaudio and libcanberra. Usually when i uninstall gnome i also uninstall pulseaudio and get back to kde, thats where the problem began. after lots of investigations i found out that the problem was with libcanberra-pulse package (it doesnt get uninstalled when i uninstall pulseadio), if you dont use pulseaudio remove that package, it solves the problem, at least for me.

Offline

#10 2012-03-04 21:30:44

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Hey... that libcanberra thing seems to have worked out smile

I did install pulseaudio to test some things and then removed it, leaving libcanberra around just as you did. Simple pacman -R libcanberra-pulse does the trick. I want to test around a bit more before marking the thread as solved since it is a random freezing after all.

It must have taken quite a lot of investigation to conclude that a seemingly graphical problem was caused by a lingering audio library, it's not like chrome's ui makes any sound or anything. Thank you for sharing smile


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#11 2012-03-05 14:23:19

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

killing services akonadi & nepomuk - did not help to me - chromium still freezing.
Also im do  pacman -R libcanberra-pulse, I will continue to monitor how hromium works now.

Offline

#12 2012-03-10 09:54:00

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

It seems that the problem is solved

Offline

#13 2012-03-10 17:46:11

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

It's been a week and I have not experienced the issue any more, for anyone experiencing this random chromium freezing when typing in the address bar after uninstalling pulse audio just do:

pacman -R libcanberra-pulse

--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#14 2012-03-12 09:20:19

josetxu
Member
Registered: 2012-03-12
Posts: 1

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Have the same problem, but with Gnome instead KDE (works flawlessy with lxde). Can't remove libcanberra-pulse (it's needed for gnome-settings), so I'm stucked, don't know what to do.

Offline

#15 2012-03-14 09:37:50

killer1804
Member
From: Russia, Zlatoust
Registered: 2010-07-26
Posts: 41

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

josetxu wrote:

Have the same problem, but with Gnome instead KDE (works flawlessy with lxde). Can't remove libcanberra-pulse (it's needed for gnome-settings), so I'm stucked, don't know what to do.

maybe write a bug-report?

Offline

#16 2012-03-18 01:20:13

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

Sadly I think killer1804 is right, we really didn't solve the problem, just worked around it. It must be a bug with either libcanberra-pulse or chromium/chrome itself. Perhaps you could ask around their respective development communities for pointers on how to further debug the issue?  Other workarounds I can think of are either downgrading or trying to change the audio backend for gnome, which may not be possible, but the problem relies not in libcanberra but in libcanberra-pulse (I still have libcanberra installed), you could try your luck in google on how to make gnome use gstreamer as a backend.

Perhaps some more risky workarounds would be to forcibly remove libcanberra-pulse or to upgrade it to an unstable version.


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#17 2013-02-07 16:14:30

Ferchu
Member
From: Buenos Aires - Argentina
Registered: 2012-06-12
Posts: 30

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

I have the same problem. And I fix deleting the path
~/.config/chromium/

You loose the config, but you can typing in address bar and set the config again throught google user.


___________________________________
Fernando Pucci
GPG:  E1AB 369F C188 9DCD F423 7090 1C88 D8FB C3FB 42EB

Offline

#18 2014-08-20 06:46:10

yoyosan
Member
Registered: 2013-11-08
Posts: 6

Re: [SOLVED] Google chrome/chromium freezing when typing in address bar

@Ferchu - that doesn't work for me.
Also, I'm using pavucontrol a lot and since libcanberra-pulse is a dependency, there's no way I'm removing it.

But I found something that worked for me. Since I always un-check the "Use system title bar and borders" check-box, I've just checked it back and no longer have any issues.

Offline

Board footer

Powered by FluxBB