You are not logged in.

#1 2012-03-15 01:05:15

Registered: 2012-03-15
Posts: 7

[Solved] Alsa on a Lenovo Thinkpad 525

Hi all,

Long time lurker here. I finally moved my Arch install out of VirtualBox under Ubuntu onto my laptop and it's all going well, except for sound. I've read the relevant wiki entry, searched various forums and tried different things. I admit I know very little about soundcards/mixers/etc and I'm at a loss of what to do now.

My setup:

Linux arch64 3.2.9-1-ARCH #1 SMP PREEMPT Thu Mar 1 09:31:13 CET 2012 x86_64 AMD A8-3500M APU with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux

on a Lenovo ThinkPad 525

I'm running KDE. I don't have [testing] enabled.
I have installed alsa-oss, alsa-utils and alsa-plugins.
I have unmuted everything using alsamixer.

My problem:
I have sound in VLC, system beeps and notification on startup but no sound in Firefox. Neither HTML5 nor flash videos give sound in Firefox.
Kmix also doesn't show volume control, just "IEC958". Under Mixer in Kmix  changing the Master setting of "HD-Audio Generic" does change the volume.

I get errors when I run speaker-test -c 2

speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

Output of lsmod | grep '^snd' | column -t

snd_hda_codec_conexant  47172  1
snd_hda_codec_hdmi      24121  1
snd_hda_intel           23375  4
snd_hda_codec           89160  3   snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_conexant
snd_hwdep               6389   1   snd_hda_codec
snd_pcm                 74780  3   snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi
snd_page_alloc          7153   2   snd_pcm,snd_hda_intel
snd_timer               19544  1   snd_pcm
snd                     59214  16  snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,thinkpad_acpi,snd_hda_codec_conexant

The output of cat /proc/asound/cards is:

0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf0b44000 irq 45
 1 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf0b40000 irq 16
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw unknow

Output of aplay -l

card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Edit: More information

I'm using systemd and I have alsa-store.service enabled

Could anyone point me in the right direction to getting sound working system wide? Any help would be greatly appreciated.

Last edited by CaliBox (2012-03-15 02:01:08)

Arch + KDE


#2 2012-03-15 01:23:54

Registered: 2009-08-25
Posts: 3,604

Re: [Solved] Alsa on a Lenovo Thinkpad 525


#3 2012-03-15 02:00:34

Registered: 2012-03-15
Posts: 7

Re: [Solved] Alsa on a Lenovo Thinkpad 525

Thank you for a super fast and helpful response!
It took me a few attempts to get it right. Last time I tried it I got the card id wrong.

For others: I created the following file


with the contents

options snd-hda-intel id=Generic1 index=1

I rebooted. I accepted the KDE prompt about devices being removed. I unmuted everything with alsamixer again.
Sound now works in VLC (audio settings to default) and Firefox, and also in both at the same time. Kmix also works as expected when I set the Master Channel to HD Audio Generic. Headphones jack also works.

Last edited by CaliBox (2012-03-15 02:00:53)

Arch + KDE


#4 2015-12-25 19:00:29

Registered: 2015-12-25
Posts: 2

Re: [Solved] Alsa on a Lenovo Thinkpad 525

Thank you CaliBox, that really helped me out after searching and trying a long time.


#5 2015-12-26 16:10:34

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,867

Re: [Solved] Alsa on a Lenovo Thinkpad 525

Please don't necrobump, shaker. … bumping.22


Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


Board footer

Powered by FluxBB