You are not logged in.

#1 2012-04-03 09:29:17

Wyrdu
Member
Registered: 2012-04-03
Posts: 5

Broadcom wireless

Hi there,

After reading all the available resources on the wiki / linuxwireless.org / ... I still have troubles with my Broadcom BCM4313.

Actually, the brcmsmac driver works fine for a classical use on my laptop. But for a couple of days, I really need to set the chipset's mode to "Access Point" (using hostapd by the way).
Unfortunately, according to linuxwireless.org the brcmsmac driver doesn't allow it and hostapd fails to initialize.

Later, a little sun in my cloudy sky appeared and I found that b43/b43legacy could solve my problem.
For each one of them, i followed this procedure :

1. Downloading/Installing the corresponding firmware from AUR
2. Editing modprobe.conf to blacklist the other one, plus bcma/brcmsmac/asus_wmi (following an user advice given on the wiki)
3. Editing rc.conf in order to add it in the MODULES section
4. Trying to manually load it using rmmod / modprobe (didn't work)
5. Rebooting

After the reboot, my wireless interface disappeared. My graphical network manager (gnome network-manager) doesn't seem to detect any wireless hardware.

Here some useful (?) resources :

1. As you can see, i haven't a wireloess interface anymore

$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500  metric 1
        inet 172.31.174.219  netmask 255.255.255.0  broadcast 172.31.174.255
        inet6 fe80::22cf:30ff:fe6c:d6fe  prefixlen 64  scopeid 0x20<link>
        ether 20:cf:30:6c:d6:fe  txqueuelen 1000  (Ethernet)
        RX packets 28145  bytes 25336718 (24.1 MiB)
        RX errors 0  dropped 756  overruns 0  frame 0
        TX packets 14889  bytes 2078293 (1.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0
        device interrupt 46  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436  metric 1
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 2  bytes 100 (100.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 100 (100.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

2. Trying to enable it

$ sudo ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device

3. iwconfig

$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions

4. Just ensuring that my hardware is switched-on

$ rfkill list
0: eeepc-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: eeepc-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no

5. Hardware info

$ lspci -vnn|grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

6. Modules info

$ lsmod|grep b43
b43                   317649  0 
ssb                    42035  1 b43
pcmcia                 31502  2 ssb,b43
mmc_core               71470  2 ssb,b43
mac80211              203227  2 iwlwifi,b43
cfg80211              147716  3 mac80211,iwlwifi,b43

To finish, I'd like to apologize for my english level, I'm french x)
Hoping someone could bring an answer to my issue, thanks in advance for your help.

Wyrdu

Offline

#2 2012-04-03 09:31:07

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: Broadcom wireless

Wyrdu wrote:

I found that b43/b43legacy could solve my problem.

Where did you find that? Because it was wrong. b43 does not support your card.

Online

#3 2012-04-03 10:49:36

Wyrdu
Member
Registered: 2012-04-03
Posts: 5

Re: Broadcom wireless

Mea culpa.
I mistook the PCI-ID for the Chip-ID ><

I guess there isn't any other way to enable the "Access-Point" of my BCM4313 ?

Because I'm pretty sure that several months ago I was able to create Ad-Hoc networks.
Presently, it's not allowed anymore.

Here's the answer of "iw list" :

Supported interface modes:
		 * managed
		 * monitor

[Edit]
Since my chipset could be set in "Ad-Hoc" mode in the past, and cannot now, I guess this is the same issue concerning the "Access-Point" mode, that's the point.
[/Edit]

Thanks for your quick answer,

Wyrdu

Last edited by Wyrdu (2012-04-03 10:52:29)

Offline

#4 2012-04-03 11:16:23

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Broadcom wireless

How come iwlwifi is loaded? And what does dmesg tell you?


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#5 2012-04-03 12:18:24

Wyrdu
Member
Registered: 2012-04-03
Posts: 5

Re: Broadcom wireless

Erm, about iwlwifi, I think it loaded during my tests.
Here's the lsmod after a new reboot :

b43                   317649  0 
ssb                    42035  1 b43
pcmcia                 31502  2 ssb,b43
mmc_core               71470  2 ssb,b43
mac80211              203227  1 b43
cfg80211              147716  2 mac80211,b43

Here's the answer of dmesg, I think it's quite a good track to follow :

$ dmesg|grep wireless
[    8.644907] eeepc_laptop: BIOS says wireless lan is blocked, but the pci device is present
[    8.644917] eeepc_laptop: skipped wireless hotplug as probably inappropriate for this model
[    8.646200] eeepc_laptop: BIOS says wireless lan is blocked, but the pci device is present
[    8.646211] eeepc_laptop: skipped wireless hotplug as probably inappropriate for this model

Thanks for answering,

Wyrdu

Offline

#6 2012-04-03 12:21:03

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Broadcom wireless

Does rfkill show the WLAN as soft-blocked now?

Did you check the BIOS for options?

Google turns this up as first result: https://answers.launchpad.net/ubuntu/+s … ion/185589

Last edited by .:B:. (2012-04-03 12:22:04)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#7 2012-04-03 12:42:39

Wyrdu
Member
Registered: 2012-04-03
Posts: 5

Re: Broadcom wireless

WLAN was in fact soft-blocked after my previous reboot, I didn't notice it.
Thus I checked the BIOS, the WLAN row was set to "Disabled", so I changed it to "Enabled".

After another reboot, rfkill tells me that everything is unblocked and dmesg doesn't return any message concerning wireless.
But I still haven't any wireless interface and I get the same error message when I try "sudo ifconfig wlan0 up".

Another time, thanks for helping,

Wyrdu

Offline

#8 2012-04-03 13:05:55

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: Broadcom wireless

Wyrdu wrote:

Mea culpa.
I mistook the PCI-ID for the Chip-ID ><

Yeah, Broadcom's fault smile

Wyrdu wrote:

But I still haven't any wireless interface and I get the same error message when I try "sudo ifconfig wlan0 up".

Which driver are you trying now? b43 won't work, you need brcmsmac or wl. wl supports ad-hoc, so maybe you were using that in the past?

Online

#9 2012-04-03 13:19:27

Wyrdu
Member
Registered: 2012-04-03
Posts: 5

Re: Broadcom wireless

Yeah, I think I'd better give up with the b43 driver since it's clearly marked as not supported.
Concerning brcmsmac, I never succeeded to get the master / ad-hoc / access-point mode, and that's quite logical (cf. linuxwireless.org).

Indeed, maybe I was using the "broadcom wl" driver in the past, I really don't remember.
But if it's the case, I guess I'll be able to get the "Ad-Hoc" mode only ? I mean : even using broadcom-wl I won't be able to make my AP, will I ?

I'm really grateful for your quick answers smile

Last edited by Wyrdu (2012-04-03 13:19:50)

Offline

#10 2012-04-11 16:30:55

mika.perlin
Member
Registered: 2011-03-22
Posts: 8

Re: Broadcom wireless

I have what I think is the same problem. I have the same wireless card (Broadcom BCM4313), and my wireless interface disappeared yesterday. The only potential trigger I can think of is an update I ran (sudo yaourt -Syu). I'm sending this off of my phone, so it's difficult to show command outputs, but "ifconfig", "iwconfig", "rfkill list", and "sudo ifconfig wlan0 up" spit out more or less the same outputs as in  Wyrdu's first post.

"iw list" returns "nl08211 not found."

"dmesg|grep wireless" and "iw list" both show no output.

Loading iwlwifi at boot (adding it to my MODULES array in rc.conf) didn't seem to change anything.

[EDIT]
Loading brcmsmac fixed my problem, but I understand that this isn't the fix Wyrdu was looking for, so sorry.

Last edited by mika.perlin (2012-04-11 16:33:40)

Offline

#11 2012-04-11 16:32:49

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: Broadcom wireless

Veeeery likely you followed the old "blacklist bcma" wisdom. As of kernel 3.3, you *need* bcma, so make sure it isn't blacklisted.

Online

#12 2012-04-11 16:41:54

mika.perlin
Member
Registered: 2011-03-22
Posts: 8

Re: Broadcom wireless

Interesting. I actually still have bcma blacklisted, and loading brcmsmac seems to work. Should I un-blacklist bcma and remove brcmsmac from my MODULES array then? If both setups work, there a particular reason why one would be preferable? (I'll try this in a bit and report the results.)

Offline

#13 2012-04-11 17:37:54

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: Broadcom wireless

The blacklist only affects autoloading. But if the blacklisted module is a dependency of something else, and you load that something else manually, the dependency will also get loaded.

I'd say remove the blacklist and also remove brcmsmac from MODULES, then udev will load everything automatically. There used to be the firmware loading issue, but Arch's udev is patched to avoid it.

Online

Board footer

Powered by FluxBB