You are not logged in.

#1 2012-03-29 17:29:30

popoffka
Member
Registered: 2012-03-29
Posts: 15

[solved] netcfg fails with no apparent reason

So, I'm trying to set up a very simple profile with netcfg:

CONNECTION='ethernet'
DESCRIPTION='ok'
INTERFACE='eth0'
IP='dhcp'

Here's what happens when I try to bring it up:

DEBUG: Loading profile eth0-dhcp
DEBUG: Configuring interface eth0
:: eth0-dhcp up
DEBUG: status reported to profile_up as:
DEBUG: Loading profile eth0-dhcp
DEBUG: Configuring interface eth0
DEBUG: ethernet_iproute_up ifup
 > No connection
DEBUG: profile_up connect failed
   [FAIL]

If I just do

sudo ifconfig eth0 up
sudo dhcpcd eth0

, the network works fine.
So, what might be the root of my problems with netcfg?

Last edited by popoffka (2012-04-03 11:46:12)

Offline

#2 2012-04-01 16:34:59

popoffka
Member
Registered: 2012-03-29
Posts: 15

Re: [solved] netcfg fails with no apparent reason

Bump. Should I submit a bug report?

Offline

#3 2012-04-01 21:06:29

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [solved] netcfg fails with no apparent reason

How long does it take for the interface to come up when you do it manually?
Looking at what looks like the relevant lines of code (30-40) it could be a timeout issue, though not necessarily. You could manually try the commands issued in the scripts at that time.

Just thinking aloud as, if it is a bug, then any info will be useful and netcfg is/has just getting a new maintainer, I think.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#4 2012-04-03 11:33:42

popoffka
Member
Registered: 2012-03-29
Posts: 15

Re: [solved] netcfg fails with no apparent reason

sudo ifconfig eth0 up takes less than a second (well, no surprise here), but sudo dhcpcd eth0 takes about 20 seconds before getting an IP and forking to background.

UPD: I increased CARRIER_TIMEOUT in my profile and now everythin works fine. Thanks, skanky smile

Last edited by popoffka (2012-04-03 11:45:21)

Offline

#5 2012-04-03 12:00:47

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [solved] netcfg fails with no apparent reason

Nice one. smile

Though it might be worth looking to see if there's a reason for the 20 seconds and if it can be reduced - often not, but you never know.

Last edited by skanky (2012-04-03 12:02:23)


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

Board footer

Powered by FluxBB