You are not logged in.

#1 2012-04-27 17:21:31

Registered: 2012-04-27
Posts: 26

Network Problems

Hi, i reinstaled arch linux today and can't connect to the internet wirelessly.

I can connect to open AP the problem is WPA.

NetworkManager keeps asking for the network password.

Wicd gives:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/", line 230, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/wicd/gtk/", line 253, in handle_connection_results
    error(self.window, language[results], block=False)
KeyError: dbus.String(u'bad_pass')

wpa_suppliant + dhcpd:

dhcpcd[1773]: version 5.5.6 starting
dhcpcd[1773]: wlan0: waiting for carrier
dhcpcd[1773]: timed out

Ethernet works fine.


[ 1356.063174] wlan0: authenticate with 00:25:9c:d5:9d:92 (try 1)
[ 1356.065246] wlan0: 00:25:9c:d5:9d:92 denied authentication (status 1)

Any ideas?

Edit: The password is correct because my phone can connect to the AP

Last edited by ziro360 (2012-04-27 17:34:06)


#2 2012-05-01 07:21:59

From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Network Problems

Did it work with wpa before the reinstall?
Maybe it is a driver issue, whats your wifi-card, incl pci ID (lspci or lsusb)?
Since you tried the manual invoking of wpa_supplicant already: whats the output in terminal/log? (dhcpcd will obviously have to time out)


#3 2012-05-28 04:29:33

Registered: 2012-05-28
Posts: 4

Re: Network Problems

I've been having this problem for a while now.  I get that exact error when I try to connect to a WPA2 network. When I try to connect to an open network (ad-hoc to another computer), I also get the same error but with the last line as "KeyError: dbus.String(u'dhcp_failed').

I can see all the available networks, but I get those messages when the connection attempt times out (from the command prompt I ran wicd from).

My relevant specs are listed below:

Fresh install of 32 bit Arch Linux
Dell Mini 10, with a BCM4322 wireless card (PCI-ID 14e4:432b)
Loaded Modules: wl, lib80211_crypt_tkip  (b43, ssb not loaded)
wireless on eth0 interface

There's probably something stupid I'm missing.


Board footer

Powered by FluxBB