You are not logged in.

#1 2012-05-25 15:32:17

SifuDaigo
Member
Registered: 2012-05-25
Posts: 3

Ubuntu One not syncing after package upgrade

Hi, everybody!
I hope I'm posting this in the right sub-forum (actual total Archlinux-Newbie). I've got the following probleme with Ubuntu One. Ubuntu One was moved to the community repos yesterday (or the day before), so I updated this one from the one I was using before (which I installed via AUR). After a reboot sync stopped working for me and now I'm interested, if somebody else can confirm this issue.

The output of u1sdtool -s leads to:

** (process:1768): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1768): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1768): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
State: READY
    connection: With User Not Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING

The above warnings shouldn't be a concern, I think. If I try to start the control-panel via the terminal, it starts, but doesn't sync and throws the following output:

ERROR:root:Could not find any typelib for Unity
ERROR:root:Could not find any typelib for Unity

I already installed libappindicator3, but this doesn't seem to help. So now, I'm stuck. Hopefully somebody knows how I can get rid of this annoying issue. Thanks!!

Offline

#2 2012-05-26 09:49:15

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

Hi,

make sure that you've installed the following packages:

# pacman -Sy ubuntuone-client ubuntu-sso-client-qt gnome-keyring

try to connect with:

$ u1sdtool -c

then check the state again:

$ u1sdtool -s

Last edited by City-busz (2012-05-26 09:51:54)


My packages | My PGP Key: 0x0901C163

Offline

#3 2012-05-26 20:16:11

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 913

Re: Ubuntu One not syncing after package upgrade

City-busz wrote:
# pacman -Sy ubuntuone-client ubuntu-sso-client-qt gnome-keyring

e'yup

City-busz wrote:
$ u1sdtool -c

Give me this error in a therminal w no launch the app

[firefly@SunFlare ~]$ u1sdtool -c

** (process:5108): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:5108): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:5108): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'

Oops, an error ocurred:
org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntuone-client/ubuntuone-syncdaemon exited with status 1
City-busz wrote:
$ u1sdtool -s

Same errors
I try to launch w no-desktopenvironment (aka tty and from xterm+twm-only-in-X using ck-launch-session dbus-launch twm)

In the wiki say "ubuntuone-control-panel" but installimg both of yours mentioned packages, not work/not exist the executable


Well, I suppose that this is somekind of signature, no?

Offline

#4 2012-05-26 21:24:46

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

What is the output if you try to run syncdaemon directly?

$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon

Last edited by City-busz (2012-05-26 21:26:36)


My packages | My PGP Key: 0x0901C163

Offline

#5 2012-05-26 21:29:21

SifuDaigo
Member
Registered: 2012-05-25
Posts: 3

Re: Ubuntu One not syncing after package upgrade

Thanks for your reply! If I try

$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon

it throws the already mentioned WARNINGs and says

Another instance is running

at first. Afterwards I killed the running one and started again, but no output is generated - except the WARNINGs.

Offline

#6 2012-05-26 21:29:57

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 913

Re: Ubuntu One not syncing after package upgrade

City-busz wrote:
$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon

this:

[firefly@SunFlare ~]$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon

** (process:8060): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:8060): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:8060): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 64, in <module>
    from ubuntuone.syncdaemon.main import Main
  File "/usr/lib/python2.7/site-packages/ubuntuone-client/ubuntuone/syncdaemon/main.py", line 38, in <module>
    from ubuntuone.syncdaemon import (
  File "/usr/lib/python2.7/site-packages/ubuntuone-client/ubuntuone/syncdaemon/action_queue.py", line 37, in <module>
    import simplejson
ImportError: No module named simplejson
[firefly@SunFlare ~]$ 

Yes my machina is SunFlare and yes I have an Ubuntuone account
and yes running lke a normal user

Edit: New dep for ubuntuone-client > python-simplejson; fix the traceback above
but ... u1sdtool -s work.....WORK WORK
Finaly Arch the first non-ubuntu distro runing ubuntuone prepackaged (not sure the firts but one of the firsths)

Last edited by Jristz (2012-05-27 04:38:15)


Well, I suppose that this is somekind of signature, no?

Offline

#7 2012-05-27 08:45:15

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

@Jristz: yes, python-simplejson was a missing dependency. Fixed in ubuntuone-client 3.0.1-3.

@SifuDaigo: you have a different problem. What is the output if you run the following command?

$ u1sdtool -c

My packages | My PGP Key: 0x0901C163

Offline

#8 2012-05-28 10:45:48

SifuDaigo
Member
Registered: 2012-05-25
Posts: 3

Re: Ubuntu One not syncing after package upgrade

Sorry for not answering earlier. Here's the output you asked for:

$ u1sdtool -c

** (process:1702): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1702): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1702): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'

That's it. Really weird...

Offline

#9 2012-05-28 14:25:16

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

I don't know what could be the problem. Maybe you could try to reset your settings by removing ~/.local/share/ubuntuone and ~/.config/ubuntuone directories, and delete your secret key from gnome-keyring with Seahorse and try to reconnect again.


My packages | My PGP Key: 0x0901C163

Offline

#10 2012-05-28 23:02:44

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 913

Re: Ubuntu One not syncing after package upgrade

@SifuDaigo: You alredy config you ubuntuone acount setted in you box?
try run in a terminal in X11 u1sdtool -s
and a tip: ubuntuone-control-panel may help to configure (GUI) the ubuntu, run by ubuntuone-control-panel-qt

Last edited by Jristz (2012-05-28 23:04:38)


Well, I suppose that this is somekind of signature, no?

Offline

#11 2012-06-13 18:09:33

pfrenssen
Member
Registered: 2012-04-09
Posts: 10

Re: Ubuntu One not syncing after package upgrade

When I try to log in with u1sdtool -c I get the following error after trying to sign in in the popup window:

This exception is raised when a process run by check_call() or check_output() ...

I then installed ubuntu-one-control-panel, but this fails too:

$ ubuntuone-control-panel-qt 
ERROR:root:Could not find any typelib for Unity
ERROR:root:Could not find any typelib for Unity
No such schema 'org.gnome.system.proxy'
No such schema 'org.gnome.system.proxy'
No such schema 'org.gnome.system.proxy'
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-control-panel-qt", line 34, in <module>
    main.main(sys.argv)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/main/__init__.py", line 103, in main
    installer=installer)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/gui.py", line 122, in start
    installer=installer)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/gui.py", line 49, in __init__
    self.ui.setupUi(self)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/mainwindow_ui.py", line 42, in setupUi
    self.control_panel = ControlPanel(self.centralwidget)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ubuntuonebin.py", line 41, in __init__
    self.ui.setupUi(self)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/controlpanel_ui.py", line 136, in setupUi
    self.folders_tab = FoldersPanel()
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ubuntuonebin.py", line 54, in __init__
    self._setup()
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/folders.py", line 118, in _setup
    self.ui.add_folder_button.add_folder_func = self.backend.create_folder
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/cache.py", line 39, in get_backend
    self._shared_objects['backend'] = backend.ControlBackend()
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/backend.py", line 138, in __init__
    self.wc = WebClient(self.get_credentials)
  File "/usr/lib/python2.7/site-packages/ubuntuone-control-panel/ubuntuone/controlpanel/web_client.py", line 45, in __init__
    self.wc = webclient_factory(APP_NAME)
  File "/usr/lib/python2.7/site-packages/ubuntu-sso-client/ubuntu_sso/utils/webclient/__init__.py", line 75, in webclient_factory
    return web_module.WebClient(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/ubuntu-sso-client/ubuntu_sso/utils/webclient/qtnetwork.py", line 103, in __init__
    self.setup_proxy()
  File "/usr/lib/python2.7/site-packages/ubuntu-sso-client/ubuntu_sso/utils/webclient/qtnetwork.py", line 109, in setup_proxy
    settings = gsettings.get_proxy_settings()
  File "/usr/lib/python2.7/site-packages/ubuntu-sso-client/ubuntu_sso/utils/webclient/gsettings.py", line 72, in get_proxy_settings
    output = subprocess.check_output(GSETTINGS_CMDLINE.split())
  File "/usr/lib/python2.7/subprocess.py", line 544, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '['gsettings', 'list-recursively', 'org.gnome.system.proxy']' returned non-zero exit status 1

Inxsible was here

Last edited by Inxsible (2012-06-13 18:13:52)

Offline

#12 2012-06-13 18:13:10

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: Ubuntu One not syncing after package upgrade

Use [ code ] tags as opposed to [ quote ] because code tags provide scrollers which avoid making the thread too long to scroll. [quote ] should be reserved for when you are quoting another posters comments.

I have edited your post this time.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#13 2012-06-13 18:15:16

pfrenssen
Member
Registered: 2012-04-09
Posts: 10

Re: Ubuntu One not syncing after package upgrade

Thanks, I'm new smile

Offline

#14 2012-06-13 22:31:39

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

@pfrenssen: Thanks for the report! You need to install 'gsettings-desktop-schemas' package. It seems that it's a missing dependency, so I'll check the packages and add this dependency the proper package soon.


My packages | My PGP Key: 0x0901C163

Offline

#15 2012-06-13 23:43:04

pfrenssen
Member
Registered: 2012-04-09
Posts: 10

Re: Ubuntu One not syncing after package upgrade

City-busz wrote:

@pfrenssen: Thanks for the report! You need to install 'gsettings-desktop-schemas' package. It seems that it's a missing dependency, so I'll check the packages and add this dependency the proper package soon.

That was it! When I installed gsettings-desktop-schemas I could successfully connect to the service. Thanks a lot!

Offline

#16 2012-06-18 14:57:00

Kelon
Member
Registered: 2012-06-18
Posts: 2

Re: Ubuntu One not syncing after package upgrade

I have the same problem as OP. "u1sdtool -s" is telling me it's ready to connect, but "u1sdtool -c" never does so (without saying why).

With the GUI I seem to be able to connect to the server, change settings and see my account information, but in the upper right corner it says that the program is trying to start the sync, which never happens (the message never changes, no error or anything).

Deleting ~/.local/share/ubuntuone, ~/.config/ubuntuone and the key from the ring didn't help and I have all the dependencies that have been mentioned in this thread installed.

Offline

#17 2012-06-21 12:02:32

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

@Kelon: in this case try to run '/usr/lib/ubuntuone-client/ubuntuone-syncdaemon' directly and please post the output here.


My packages | My PGP Key: 0x0901C163

Offline

#18 2012-06-22 09:00:59

Kelon
Member
Registered: 2012-06-18
Posts: 2

Re: Ubuntu One not syncing after package upgrade

The output is the same as OP's, only the three warnings, nothing else. Running 'u1sdtool -c' or the GUI doesn't make the syncdaemon produce any output either.

Edit: I just now realized there are logs to be found in ~/.cache/ubuntuone/log/. In the syncdaemon-exceptions files were the following error:

2012-06-22 00:47:40,831 - dbus.proxies - ERROR - Introspect error on org.freedesktop.NetworkManager:/org/freedesktop/NetworkManager: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

Since I used the 'network' daemon I switched to the 'networkmanager' daemon. Now it still doesn't connect but the output of 'u1sdtool -s' changed:

$ u1sdtool -s

** (process:1589): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1589): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1589): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
State: WAITING
    connection: With User With Network
    description: waiting before try connecting again
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING

In the syncdaemon.log there are now messages like this to be found:

2012-06-22 12:15:43,683 - ubuntuone.SyncDaemon.StorageClient - INFO - Connection lost, reason: [Failure instance: Traceback: <class 'OpenSSL.SSL.Error'>: [('SSL routines', 'SSL23_READ', 'ssl handshake failure')]
2012-06-22 12:15:43,684 - ubuntuone.SyncDaemon.ActionQueue - INFO - The request 'protocol_version' failed with the error: [('SSL routines', 'SSL23_READ', 'ssl handshake failure')]

According to google search results these happen when their service is down. Their Twitter says there was to be a hardware update a little over an hour ago, so I'm gonna wait and keep trying for now.

Edit2: It's syncing now. So the whole issue apparently was using the 'network' daemon instead of 'networkmanager'. Thanks for sticking with us, City-busz!

Last edited by Kelon (2012-06-22 10:38:42)

Offline

#19 2012-11-25 12:36:26

dead_kenny
Member
From: Berlin
Registered: 2012-11-10
Posts: 13

Re: Ubuntu One not syncing after package upgrade

Hi, I've got somewhat a likely issue. I can start the control panel in gnome and it shows me that it wants to connect but it doesn' t. Here is some output I get from the terminal.

$ u1sdtool -s
ERROR:root:Could not find any typelib for Unity
State: READY
    connection: With User Not Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING

Last edited by dead_kenny (2012-11-25 12:55:14)

Offline

#20 2012-11-25 16:27:56

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

@dead_kenny: Either remove the networkmanager package or use networkmanager for network connection, and try again.


My packages | My PGP Key: 0x0901C163

Offline

#21 2012-11-25 16:45:19

dead_kenny
Member
From: Berlin
Registered: 2012-11-10
Posts: 13

Re: Ubuntu One not syncing after package upgrade

City-busz wrote:

@dead_kenny: Either remove the networkmanager package or use networkmanager for network connection, and try again.

Okay, I've got arch running on a thinkpad w/o network manager and on an ASUS Eee pc w/ network manager but Ubuntuone doesn't connect on both systems and shows the above status message. sad

Offline

#22 2012-11-25 17:13:20

dead_kenny
Member
From: Berlin
Registered: 2012-11-10
Posts: 13

Re: Ubuntu One not syncing after package upgrade

Now I got it running again on the Eee pc using network manager. Does this implicate the mandatory usage of network manager for Ubuntuone to work? I don't hope so.

Offline

#23 2012-11-26 02:15:31

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

It's a bug in the ubuntu-sso-client. If networkmanager installed but does not handle the network connection, it assumes offline state. There is already a bug report: https://bugs.launchpad.net/ubuntu-sso-c … bug/611098

What is the output of the following command on your system where networkmanager is not used?

$ dbus-send --print-reply --system --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.state

My packages | My PGP Key: 0x0901C163

Offline

#24 2012-11-26 12:52:52

dead_kenny
Member
From: Berlin
Registered: 2012-11-10
Posts: 13

Re: Ubuntu One not syncing after package upgrade

City-busz wrote:

It's a bug in the ubuntu-sso-client.

Thank you for this info!

On my Thinkpad T42p networkmanager is not installed nor running and the output of

$ dbus-send --print-reply --system --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.state

is

Error org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.

Offline

#25 2012-11-26 20:04:42

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ubuntu One not syncing after package upgrade

Okay, please try this package: http://pkgbuild.com/~bgyorgy/packages/u … pkg.tar.xz

Install it, do a restart and check the command output of 'u1sdtool -s' again.


My packages | My PGP Key: 0x0901C163

Offline

Board footer

Powered by FluxBB