You are not logged in.

#1 2012-06-11 09:48:57

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,953

[Solved] Wicd doesn't connect, keeps scanning and trying to associate

Today wicd can't connect to my wpa2 protected network, I haven't changed anything on my network setup and connecting manually with wpa_supplicant and dhcpcd works just fine. The only possible culprits I can blame are bison and dnsutils which got updated yesterday.

Using wicd's curses interface I can see that as soon as it associates it scans for networks again and the connection goes down, wicd then starts to associate again and the loop restarts.

Is anyone seeing this and/or does anyone know what the problem is, so it can be fixed or worked around?

Edit:
Marking as solved.
Deleting /etc/wicd/manager-settings.conf seems to have solved the problem for me, I suppose this was a case of stale configuration options since I've been using wicd for quite some time.

Last edited by R00KIE (2012-06-12 14:52:49)


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#2 2012-06-11 09:56:03

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

Think I have the same here. I unchecked the "ping for checking association" or what it's called, in wicd and together with kernel 3.4.1 from testing it got a little better (ath5k). But it's not alright by far.

Offline

#3 2012-06-11 10:05:44

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,953

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

Funny, I'm using kernel 3.4.2 from testing and my card also uses ath5k, but it was working just fine yesterday and I did not update the kernel.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#4 2012-06-11 11:03:46

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

Seems that wicd AND ath5k is acting up. It gets difficult to tell where the real problem lies. And I'm not keen on testing Networkmanager - way too many deps. But Trilby posted this;
https://bbs.archlinux.org/viewtopic.php?id=143098

Which seems promising.

Offline

#5 2012-06-11 11:51:05

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,953

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

Try this: stop wicd, delete (or move/rename) /etc/wicd/manager-settings.conf then restart wicd again.

I've rebooted a few times already and wicd seems to be behaving now, I'm inclined to call this a case of stale configuration file. If it works for you too I guess I'll mark this as solved.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#6 2012-06-18 15:33:32

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

Finally came around to really trying out netcfg and net-auto-wireless. Together with qtwifimon from the AUR, they seem to replace wicd and be more stable. qtwifimon had some deps but it works really well with my openbox/fbpanel setup. I had QT installed anyway.

Offline

#7 2012-06-18 16:07:49

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,953

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

I was too lazy to try anything else once I got wicd working again. I have already tested it at another location and it seems to be working well again, but I'll keep netcfg, net-auto-wireless and qtwifimon in mind just in case wicd starts acting up again.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2012-06-19 02:07:43

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,356
Website

Re: [Solved] Wicd doesn't connect, keeps scanning and trying to associate

[shamless plug]
I recently switched from wicd to the wifi script in my sig.  It's *fast* and reliable.  It does not start automatically at boot/login, but even when wicd starts at boot I found myself waiting for it to connect after my WM was up.  I'd often open up wicd-curses just to make sure it was trying to connect.  In contrast, I can bring up a terminal start my wifi script and be connected in no time.

Perhaps others will find it useful too.
[/end plug]

Last edited by Trilby (2012-06-19 02:08:47)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB