You are not logged in.

#1 2012-06-12 16:38:50

needmoreram
Member
Registered: 2012-02-13
Posts: 8

Characters messed up is tty's

Ever since I updated all my packages today, some special characters like  '   ─  are not displayed correctly in the tty's. However, they are displayed correctly over ssh. I use bash shell.

Example 1 Apostrophe appears as âÇÿ
Example 2 ─ appears as âÇö

I have tried to re-genrate my locale but still the problem persists.

Here is my locale:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Offline

#2 2012-06-12 16:54:06

needmoreram
Member
Registered: 2012-02-13
Posts: 8

Re: Characters messed up is tty's

Problem persists even after changing font and shell. But the character substitutions are different for each font. For example, an apostrophe is âµç using Lat2Terminus16 font.

Offline

#3 2012-06-12 17:22:52

meph
Member
Registered: 2011-06-06
Posts: 160

Re: Characters messed up is tty's

needmoreram wrote:

Ever since I updated all my packages today

Which packages were updated? See /var/log/pacman.log if not sure


Running arch is like raising a puppy - if you spend a bit of time with it each day and do just a bit of training you'll end up with the most loyal partner you could want; if you lock it in a room and don't check on if for several days, it'll tear apart your stuff and poop everywhere.

Offline

#4 2012-06-12 17:32:22

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,359
Website

Re: Characters messed up is tty's

Let me guess, is you have this line in /etc/rc.conf

DAEMON_LOCALE="no"

.   If so change it to "yes".


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#5 2012-06-12 18:12:35

needmoreram
Member
Registered: 2012-02-13
Posts: 8

Re: Characters messed up is tty's

Yes. That was the problem.

I'm not sure if it has always been like that (OR)
if I mindlessly replaced rc.conf with rc.conf.pacnew that came along with the update to initscipts

Thank you both of you for your help!

Offline

#6 2012-06-12 18:40:17

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,359
Website

Re: Characters messed up is tty's

Given the flurry of people with this exact same problem "after a recent update" I suspect it must have been from too quick of a merging of a pacnew file.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB