You are not logged in.

#1 2012-08-02 20:00:31

Bonzodog
Member
From: Leicester, UK
Registered: 2008-02-14
Posts: 106

Pacman broken -- GLibc 2.16 error

Ok, went to do an upgrade earlier, but it went wrong. At first, I started with a plain pacman -Syu, and it advised me to upgrade pacman itself first, which I told it to do.

 [root@blackstar bonzodog]# pacman -Syu
:: Synchronising package databases...
 testing                                                                                                        177.0 KiB   761K/s 00:00 [-----------------------------------------------------------------------------------] 100%
 multilib-testing                                                                                                29.0   B   301K/s 00:00 [-----------------------------------------------------------------------------------] 100%
 multilib                                                                                                        91.4 KiB   842K/s 00:00 [-----------------------------------------------------------------------------------] 100%
 core                                                                                                           107.5 KiB   951K/s 00:00 [-----------------------------------------------------------------------------------] 100%
 extra                                                                                                         1410.1 KiB  2.43M/s 00:01 [-----------------------------------------------------------------------------------] 100%
 community-testing                                                                                                9.7 KiB   785K/s 00:00 [-----------------------------------------------------------------------------------] 100%
 community                                                                                                     1752.1 KiB  2.54M/s 00:01 [-----------------------------------------------------------------------------------] 100%
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] Y

resolving dependencies...
looking for inter-conflicts...

Targets (1): pacman-4.0.3-3

Total Download Size:    0.50 MiB
Total Installed Size:   3.54 MiB
Net Upgrade Size:       0.27 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 pacman-4.0.3-3-x86_64                                                                                          508.6 KiB  1728K/s 00:00 [-----------------------------------------------------------------------------------] 100%
(1/1) checking package integrity                                                                                                         [-----------------------------------------------------------------------------------] 100%
(1/1) loading package files                                                                                                              [-----------------------------------------------------------------------------------] 100%
(1/1) checking for file conflicts                                                                                                        [-----------------------------------------------------------------------------------] 100%
(1/1) checking available disk space                                                                                                      [-----------------------------------------------------------------------------------] 100%
(1/1) upgrading pacman                                                                                                                   [-----------------------------------------------------------------------------------] 100%

ok, so we got this far, no real problems to show.

I then proceeded to continue the update:

[root@blackstar bonzodog]# pacman -Syu
:: Synchronising package databases...
 testing is up to date
 multilib-testing is up to date
 multilib is up to date
 core is up to date
 extra is up to date
 community-testing is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace pyxdg with extra/python2-xdg? [Y/n] Y
resolving dependencies...
looking for inter-conflicts...

Targets (146): alsa-plugins-1.0.25-2  audacious-3.3-1  audacious-plugins-3.3-1  automake-1.12.2-1  bash-4.2.037-1  binutils-multilib-2.22-8  bison-2.6.1-1  chromium-21.0.1180.57-1  cifs-utils-5.6-1  cogl-1.10.4-1
               coreutils-8.17-3  cryptsetup-1.5.0-1  curl-7.27.0-1  dbus-1.6.4-1  dbus-core-1.6.4-1  device-mapper-2.02.96-3  dhclient-4.2.4.1-1  dhcpcd-5.6.0-1  dialog-1.1_20120706-1  dnsutils-9.9.1.P2-1  dri2proto-2.8-1
               e2fsprogs-1.42.5-1  elfutils-0.154-1  ffmpeg-1:0.11.1-1  ffmpegthumbnailer-2.0.7-5  filesystem-2012.7-1  finch-2.10.6-1  firefox-14.0.1-1  flex-2.5.36-1  gcc-4.7.1-5  gcc-libs-4.7.1-5  gegl-0.2.0-2
               git-1.7.11.4-1  glew-1.8.0-1  glib2-2.32.4-1  glibc-2.16.0-2  glibmm-2.32.1-1  glproto-1.4.16-1  gnutls-3.0.21-2  gpm-1.20.6-10  grep-2.13-2  gstreamer0.10-ugly-0.10.19-2  gstreamer0.10-ugly-plugins-0.10.19-2
               gtk-update-icon-cache-2.24.11-2  gtk2-2.24.11-2  gtk3-3.4.4-1  gvfs-1.12.3-3  hwids-20120711-1  iana-etc-2.30-3  icu-49.1.2-2  initscripts-2012.07.5-1  iputils-20101006-4  kbd-1.15.3-3  khrplatform-devel-8.0.4-2
               kmod-9-2  krb5-1.10.2-3  lib32-dbus-core-1.6.4-1  lib32-e2fsprogs-1.42.4-1  lib32-gcc-libs-4.7.1-5  lib32-glib2-2.32.4-1  lib32-glibc-2.16.0-2  lib32-gnutls-3.0.21-1  lib32-gtk2-2.24.11-1  lib32-libcups-1.6.1-1
               lib32-libgl-8.0.4-4  lib32-libglapi-8.0.4-4  lib32-libjpeg-turbo-1.2.1-1  lib32-libpng-1.5.12-1  lib32-nettle-2.5-1  lib32-pcre-8.31-1  lib32-pixman-0.26.2-1  lib32-qt-4.8.2-2  lib32-readline-6.2.004-1
               libburn-1.2.4-1  libcups-1.6.1-1  libegl-8.0.4-2  libgl-8.0.4-2  libglapi-8.0.4-2  libimobiledevice-1.1.4-1  libisofs-1.2.4-1  libjpeg-turbo-1.2.1-1  libldap-2.4.32-1  libmp4v2-2.0.0-2  libmysqlclient-5.5.25.a-1
               libpng-1.5.12-1  libpulse-2.1-1  libpurple-2.10.6-1  libsystemd-187-4  libthai-0.1.18-1  libtracker-sparql-0.14.2-1  libusb-compat-0.1.4-2  libxrandr-1.4.0-1  linux-3.5-2  linux-api-headers-3.4.6-1
               lirc-utils-1:0.9.0-25  lvm2-2.02.96-3  mc-4.8.4-1  mesa-8.0.4-2  mkinitcpio-0.10-1  mpfr-3.1.1-1  mpg123-1.14.4-1  mplayer-35014-1  nettle-2.5-1  nspr-4.9.2-1  oxygen-icons-svg-4.9.0-1  pcmanfm-0.9.10-3
               pcre-8.31-1  perl-error-0.17018-1  perl-xml-simple-2.20-1  pidgin-2.10.6-1  pkg-config-0.27-1  poppler-0.20.2-1  poppler-glib-0.20.2-1  procps-ng-3.3.3-3  python-urwid-1.0.2-1  python2-urwid-1.0.2-1
               python2-xdg-0.23-1  pyxdg-0.19-3 [removal]  qt-4.8.2-3  randrproto-1.4.0-1  readline-6.2.004-1  skype-4.0.0.8-1  slim-1.3.4-2  sox-14.4.0-3  syslog-ng-3.3.5-2  systemd-tools-187-4  taglib-1.7.2-2
               transmission-gtk-2.61-1  ttf-liberation-2.00.0-1  tzdata-2012d-1  unetbootin-578-1  upower-0.9.17-2  usbmuxd-1.0.8-1  usbutils-006-1  util-linux-2.21.2-5  x264-20120705-1  xf86-input-evdev-2.7.1-1
               xf86-video-dummy-0.3.6-1  xf86-video-fbdev-0.4.3-1  xf86-video-sisusb-0.9.6-1  xf86-video-vesa-2.3.2-1  xorg-server-1.12.3-1  xorg-server-common-1.12.3-1  xorg-server-devel-1.12.3-1  xulrunner-14.0.1-1
               zsh-5.0.0-2

Total Download Size:    533.21 MiB
Total Installed Size:   1475.24 MiB
Net Upgrade Size:       17.46 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from testing...
<list snipped>
:: Retrieving packages from multilib...
<list snipped>
:: Retrieving packages from core...
<list snipped>
:: Retrieving packages from extra...
<list snipped>
:: Retrieving packages from community...
<list snipped>
(145/145) checking package integrity                                                                                                     [-----------------------------------------------------------------------------------] 100%
(145/145) loading package files                                                                                                          [-----------------------------------------------------------------------------------] 100%
(145/145) checking for file conflicts                                                                                                    [-----------------------------------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
Errors occurred, no packages were upgraded.

Ok, so I had already read that this could happen, so followed the advice given:

[root@blackstar bonzodog]# pacman -Syu --ignore glibc
:: Synchronising package databases...
 testing is up to date
 multilib-testing is up to date
 multilib is up to date
 core is up to date
 extra is up to date
 community-testing is up to date
 community is up to date
:: Starting full system upgrade...
warning: glibc: ignoring package upgrade (2.15-12 => 2.16.0-2)
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
<This went on for about 30 lines>
:: Replace pyxdg with extra/python2-xdg? [Y/n] Y
resolving dependencies...
warning: ignoring package glibc-2.16.0-2
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      audacious  binutils-multilib  chromium  cryptsetup  dbus  dbus-core  device-mapper  elfutils  ffmpeg  ffmpegthumbnailer  firefox  gcc  gcc-libs  gegl  git  glew  glib2  glibmm  gnutls  grep  gtk2  gtk3  icu  initscripts lib32-dbus-core  lib32-gcc-libs  lib32-glib2  lib32-gnutls  lib32-gtk2  lib32-libcups  lib32-libgl  lib32-pcre  lib32-qt  libcups  libegl  libgl  libimobiledevice  libmp4v2  libpulse  libtracker-sparql  linux  lvm2  mc mesa  mkinitcpio  mplayer  pcmanfm  pcre  pkg-config  poppler  poppler-glib  qt  skype  syslog-ng  systemd-tools  taglib  transmission-gtk  unetbootin  upower  xorg-server  xulrunner  zsh

Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...

Targets (83): alsa-plugins-1.0.25-2  audacious-plugins-3.3-1  automake-1.12.2-1  bash-4.2.037-1  bison-2.6.1-1  cifs-utils-5.6-1  cogl-1.10.4-1  coreutils-8.17-3  curl-7.27.0-1  dhclient-4.2.4.1-1  dhcpcd-5.6.0-1
              dialog-1.1_20120706-1  dnsutils-9.9.1.P2-1  dri2proto-2.8-1  e2fsprogs-1.42.5-1  filesystem-2012.7-1  finch-2.10.6-1  flex-2.5.36-1  glproto-1.4.16-1  gpm-1.20.6-10  gstreamer0.10-ugly-0.10.19-2
              gstreamer0.10-ugly-plugins-0.10.19-2  gtk-update-icon-cache-2.24.11-2  gvfs-1.12.3-3  hwids-20120711-1  iana-etc-2.30-3  iputils-20101006-4  kbd-1.15.3-3  khrplatform-devel-8.0.4-2  kmod-9-2  krb5-1.10.2-3
              lib32-e2fsprogs-1.42.4-1  lib32-glibc-2.16.0-2  lib32-libglapi-8.0.4-4  lib32-libjpeg-turbo-1.2.1-1  lib32-libpng-1.5.12-1  lib32-nettle-2.5-1  lib32-pixman-0.26.2-1  lib32-readline-6.2.004-1  libburn-1.2.4-1
              libglapi-8.0.4-2  libisofs-1.2.4-1  libjpeg-turbo-1.2.1-1  libldap-2.4.32-1  libmysqlclient-5.5.25.a-1  libpng-1.5.12-1  libpurple-2.10.6-1  libsystemd-187-4  libthai-0.1.18-1  libusb-compat-0.1.4-2
              libxrandr-1.4.0-1  linux-api-headers-3.4.6-1  lirc-utils-1:0.9.0-25  mpfr-3.1.1-1  mpg123-1.14.4-1  nettle-2.5-1  nspr-4.9.2-1  oxygen-icons-svg-4.9.0-1  perl-error-0.17018-1  perl-xml-simple-2.20-1
              pidgin-2.10.6-1  procps-ng-3.3.3-3  python-urwid-1.0.2-1  python2-urwid-1.0.2-1  python2-xdg-0.23-1  pyxdg-0.19-3 [removal]  randrproto-1.4.0-1  readline-6.2.004-1  slim-1.3.4-2  sox-14.4.0-3
              ttf-liberation-2.00.0-1  tzdata-2012d-1  usbmuxd-1.0.8-1  usbutils-006-1  util-linux-2.21.2-5  x264-20120705-1  xf86-input-evdev-2.7.1-1  xf86-video-dummy-0.3.6-1  xf86-video-fbdev-0.4.3-1
              xf86-video-sisusb-0.9.6-1  xf86-video-vesa-2.3.2-1  xorg-server-common-1.12.3-1  xorg-server-devel-1.12.3-1

Total Installed Size:   541.44 MiB
Net Upgrade Size:       9.59 MiB

Proceed with installation? [Y/n] Y

So, I skipped the above packages as advised in the developer usrlib wiki. It proceeded as normal to download and install the remaining packages.

I then followed its advice further, and proceeded with the following command:

[root@blackstar bonzodog]# pacman -Sd audacious binutils-multilib chromium cryptsetup dbus dbus-core device-mapper elfutils ffmpeg ffmpegthumbnailer firefox gcc gcc-libs gegl git glew glib2 glibmm gnutls grep gtk2 gtk3 icu initscripts lib32-dbus-core lib32-gcc-libs lib32-glib2 lib32-gnutls lib32-gtk2 lib32-libcups lib32-libgl lib32-pcre lib32-qt libcups libegl libgl libimobiledevice libmp4v2 libpulse libtracker-sparql linux lvm2 mc mesa mkinitcpio mplayer pcmanfm pcre pkg-config poppler poppler-glib qt skype syslog-ng systemd-tools taglib transmission-gtk unetbootin upower xorg-server xulrunner zsh
pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/libcurl.so.4)

Thats when the error above occured.

I then tried to manually download the GLibc package as advised by allen.

[root@blackstar bonzodog]# pacman -U http://pkgbuild.com/~allan/glibc-2.16.0-1-x86_64.pkg.tar.xz
pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/libcurl.so.4)

A complete fail, as you can see.

I then fetched the above file with wget, and I am now stuck as to where I proceed with this. Any ideas as to what to do?

Offline

#2 2012-08-02 20:43:39

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,514

Re: Pacman broken -- GLibc 2.16 error

Others with a similar problem https://bbs.archlinux.org/viewtopic.php?id=146308.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#3 2012-08-02 21:03:16

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: Pacman broken -- GLibc 2.16 error

I then fetched the above file with wget, and I am now stuck as to where I proceed with this. Any ideas as to what to do?

Install it with pacman -U /local/path/pkg.tar.xz

Offline

Board footer

Powered by FluxBB