You are not logged in.

#1 2012-07-11 09:38:56

rekahsoft
Member
Registered: 2010-07-18
Posts: 33
Website

FreeNX issue

Hi all..I am trying to connect to my freenx server (i have set up freenx before with ssh public key auth + passwd auth). Anyways i am having a weird issue. I connect using opennx and get the following error dialog:

The remote proxy closed the connection while negotiating the session. This may be due to the wrong authentication credentials passed to the server.

The logs read as follows from the client:
~/.nx/session-name/session:

NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '5075'.
Session: Starting session at 'Wed Jul 11 04:14:07 2012'.
Error: The remote NX proxy closed the connection.
Error: Failure negotiating the session in stage '7'.
Error: Wrong version or invalid session authentication cookie.
Session: Terminating session at 'Wed Jul 11 04:14:07 2012'.
Session: Session terminated at 'Wed Jul 11 04:14:07 2012'.

~/.nx/session-name/errors:

Loop: PANIC! The remote NX proxy closed the connection.
Loop: PANIC! Failure negotiating the session in stage '7'.
Loop: PANIC! Wrong version or invalid session authentication cookie.

~/.nx/session-name/options:

nx/nx,cookie=cookie-data,shmem=1,shpix=1,font=1,encryption=1,session=session,client=linux,id=alarmpi-1000-A356769494CD8D8A3F05EB62114722DF:1000

~/.nx/session-name/stats is empty

On the server:
/var/log/nxserver: http://pastebin.ca/2169644

I am using the exact same configs for my other freenx server which is working fine (this includes /etc/sshd/sshd_config and /etc/nxserver/node.conf) so i have no idea why this is happening? Any ideas?

Offline

#2 2012-07-14 17:07:35

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

i have got the same problem on my raspberry pi.

any ideas to track down the problem?

thx & rgds
hcjl

Offline

#3 2012-07-14 20:37:18

rekahsoft
Member
Registered: 2010-07-18
Posts: 33
Website

Re: FreeNX issue

i am experiencing this on my pi too..quiet upsetting..my guess right now is that the nx proxy times out before being able to negotiate a session with the client. Tried setting AGENT_STARTUP_TIME to 120 instead of the default 60 and it doesn't help. Auth works so i don't know why this is happening and google doesn't have anything (i spent a few hours looking into this). If you figure out anything i'd love to hear about it smile

hcjl: I assume its never worked on your pi?

Last edited by rekahsoft (2012-07-14 20:44:00)

Offline

#4 2012-07-14 21:09:45

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

@rekahsoft: yep, it never worked. although it is the same setup as i use on my other machines (x86 and x86_64).

for me it sounds like a bug of the arm version of freenx. maybe we should file a bug report, but i do not know where. on archlinuxarm.org i could not find anything.

Offline

#5 2012-07-17 10:29:38

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

i opened a bug report https://github.com/archlinuxarm/PKGBUILDs/issues/203

sorry, but i used your logs, cause i am a lazy ass;-)

Offline

#6 2012-07-17 18:19:35

rekahsoft
Member
Registered: 2010-07-18
Posts: 33
Website

Re: FreeNX issue

lol thanks hcjl smile i was lazy myself and was hoping i wouldn't have to file a bug report..so all good smile glad i could save you the time smile Going to try playing with it today..i'll let you know if i achieve anything tongue

Offline

#7 2012-07-19 21:37:49

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

still no progress, but do have any further information, which could help?

> https://github.com/archlinuxarm/PKGBUILDs/issues/203

Offline

#8 2012-08-03 04:27:37

undici77
Member
Registered: 2012-08-03
Posts: 4

Re: FreeNX issue

Hi Friends, I got the same problem too: On my Raspberry Pi, following this guide https://wiki.archlinux.org/index.php/FreeNX I got the same errors you got too.

Any new ideas?? I google alot without success...

Offline

#9 2012-08-03 07:56:36

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

no, the problem still exists. and kmihelich closed my bug report (link in my former post), because debug information was insufficient. but i couldn't provide more...

on i686 or x86_64 i could use x2go, but there is no arm version available.

Offline

#10 2012-08-03 09:43:49

undici77
Member
Registered: 2012-08-03
Posts: 4

Re: FreeNX issue

Hi hcjl,
do you know which debug info he need? I have all environment ready on my Rasp and my Win 7 with noMachine client.

Offline

#11 2012-08-03 10:54:01

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

i have no clue what kind of info he needs.

as a workaround i now installed x2goserver on my pi. i built it from aur. i just hat to change the arch flag in the pkgbuilds from

arch=('i686' 'x86_64')

to

arch=('any')

.

it's a bit slow via adsl, but it works.

there's also a wiki page https://wiki.archlinux.org/index.php/X2go and a windows client available http://www.x2go.org/doku.php/download:start.

hopefully freenx will work in the future, because it has much better performance than x2go.

rgds
hcjl

Offline

#12 2012-08-09 22:35:59

undici77
Member
Registered: 2012-08-03
Posts: 4

Re: FreeNX issue

Hi hcjl,
I have compiled x2go server from this link http://aur.archlinux.org/packages.php?ID=18028 with all dependencies and I follow the arch linux guide about x2go but it's still not running.

With the client (from windows) I can see "connecting..." and nothing more...

I have a fresh arch linux installation and LXDE.
I setup .xinitrc in my user (alessandro) and nothing more...

Can you explain me what have you done?

Thanks

Offline

#13 2012-08-10 13:41:07

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 265

Re: FreeNX issue

are you able to ssh into your server, e.g. via putty?

in x2client i chose "alternative desktop environment" (i do not know whether this exactly the name, i just translated it from german) an i start lxde with "exec startlxde".

it takes a while, but then the sessions starts.

Last edited by hcjl (2012-08-10 13:41:34)

Offline

#14 2012-08-10 14:51:58

undici77
Member
Registered: 2012-08-03
Posts: 4

Re: FreeNX issue

Yes, I can log in with ssh.
Better, my user (admin) with startx launch the execution of lxde (i add .xinitrc in my home).

This is the log from x2goclient:

Info: Proxy running in client mode with pid '7076'.
Session: Starting session at 'Fri Aug 10 16:45:23 2012'.
Info: Connecting to remote host 'localhost:30007'.
Info: Connection to remote proxy 'localhost:30007' established.
Connection timeout

I tried with exec startx from "custom command" but it's not running...

Offline

#15 2012-08-10 18:20:32

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: FreeNX issue

Hello undici77, you sent your comment to the mods via report.

undici77 wrote:

OK!!! I have done it!!

It was a very stupid thing:
My client was an old version.

With the last version everything is working and the performances are not so bad...

Honestly It's fast like FreeNX. Only login is really slow....

Thanks for help!!

About 4 minutes after this.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

Board footer

Powered by FluxBB