You are not logged in.

#1 2005-09-21 15:47:03

sven
Member
Registered: 2005-02-01
Posts: 311

problems with wlan and wep

Here is my problem: If I connect without wep protection, everything works smoothly and after 'iwconfig wlan0 up' I'll just do 'dhcpcd wlan0 up' and instantly get an IP address.

But now I am forced to use a connection that is shared between me and another person and we are using wep protection. She is using a windows computer so has no problems at all, but for me it has been almost 4 days of a nightmare of searching and trying things and none of them work in Arch.

Finally I have tried to use Knoppix and I got the connection to work from there. Here are the commands I am using there:
After inserting the card, it is recognized immediately and then I'll do 'ifconfig eth1 up' to make it visible in ifconfig. Then I use this command: 'iwconfig eth1 key xx-xx-xx-xx-xx' and then finally 'pump -i eth1' - and I'll get the ip address from wlan router.

In Arch the latest command that I have tried is this  'iwconfig eth1 key xx-xx-xx-xx-xx' but it gives an error:

Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Operation not supported.

Offline

#2 2005-09-21 16:17:07

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: problems with wlan and wep

OK - you need to learn how to properky use networking in Arch first, then maybe you can get your wireless going.  Read rc.conf for how to properly configure your network devices.

To point out the obvious:

iwconfig eth1 key xx-xx-xx-xx-xx

Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Operation not supported.

What's that about then?

Offline

#3 2005-09-21 16:33:48

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: problems with wlan and wep

I'd reckon that's a typo - am I right Sven? What I'd like to know is what wireless hardware you have, what driver you  used in Knoppix, and what driver you are trying to use in Arch. It's a bit unusual to have ethx in one distro and wlanx in another.

Offline

#4 2005-09-21 17:10:38

sven
Member
Registered: 2005-02-01
Posts: 311

Re: problems with wlan and wep

Yes, that was a typo indeed. Wlanning has been a bit of my weak point because I got the connecton to work so smoothly in Arch when no wep was involved.

So in Knoppix dmesg shows this information:

orinoco 0.15rc2STA (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu
.org>, et al)

Then in dmesg there is a lot of information like these lines:

eth1: Hardware identity 8002:0000:0001:0000
eth1: Station identity  001f:0000:0000:0008
eth1: Firmware determined as Intersil 0.8.0
eth1: Ad-hoc demo mode supported
eth1: IEEE standard IBSS ad-hoc mode supported
eth1: WEP supported, 104-bit key
. . .

In Arch I have been using linux-wlan-ng-0.2.2 driver and custom compiled 2.6.12.4 kernel. In kernel I have compiled each wlan-related driver as module. From that wlan-ng - driver I selected only  prism2_cs and it compiled cleanly.

I have not been able to use the kernel's orinoco driver in Arch  because for some reason it did not work with my wlan card. The card is Zyxel Zyair 100 - and it is over two years old.

Offline

#5 2005-09-21 17:59:45

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: problems with wlan and wep

wlan-ng is not fully integrated with wireless_tools, which provides the iwconfig command, among others. You should either use the config files provided by wlan-ng - they're in /etc/wlan and /etc/rc.d - or else write your own script for the card using the wlan-ng commands. I'm using 0.2.1pre26, and I did the latter, because I couldn't get the provided configs to work, and I didn't have time to figure out why. If it helps you, here's my script, which I've put in /etc/rc.d and listed in rc.conf DAEMONS:

#!/bin/bash

. /etc/rc.conf
. /etc/rc.d/functions

exec 1>/dev/null

case "$1" in
  start)
    stat_busy "Enabling WLAN device"
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    wlanctl-ng wlan0 dot11req_mibset mibattribute=p2CnfRoamingMode=1
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKeyID=0
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11ExcludeUnencrypted=true
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11PrivacyInvoked=true
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKey0=<your_wep_key>
    wlanctl-ng wlan0 lnxreq_autojoin ssid=<your_ssid> authtype=opensystem
    if [ $? -gt 0 ]; then
     stat_fail
    else
      stat_done
      add_daemon wlan-tk
    fi
    ;;
  stop)
    stat_busy "Disabling WLAN device"
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=disable
    if [ $? -gt 0 ]; then
      stat_fail
    else
      stat_done
      rm_daemon wlan-tk
    fi
    ;;
  restart)
    $0 stop
    sleep 1
    $0 start
    ;;
  *)
    echo "usage: $0 {start|stop|restart}"  
esac

Offline

#6 2005-09-21 19:53:07

sven
Member
Registered: 2005-02-01
Posts: 311

Re: problems with wlan and wep

tomk, thank you big_smile ::REALLY HAPPY::: Your script was the thing I needed - I got wlan to work finally.

Offline

#7 2005-09-21 21:43:08

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: problems with wlan and wep

Excellent - glad it worked out for you.

Offline

#8 2005-09-22 19:07:10

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: problems with wlan and wep

Wow, tomk - nice job.  Maybe you can give something like this to whoever maintains the wlan-ng, so it can be added by default...

Offline

#9 2005-09-22 22:23:44

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: problems with wlan and wep

Thanks phrak. TBH, it never occurred to me to give it to anyone. The package already has /etc/rc.d/wlan and /etc/wlan/shared, per-ssid config files, etc - none of which worked for me, so a small bit of googling turned up these commands. All I did was daemonise them.

I'm not sure who to send it to either - the wlan-ng package comes up with "Maintainer: None" on the website.

Offline

#10 2005-09-23 10:50:04

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: problems with wlan and wep

That's cos of libtool slay - they are all sharing at the moment.  Whack it in flyspray as a feature request and attach your script smile

Offline

Board footer

Powered by FluxBB