You are not logged in.

#1 2012-08-10 19:17:56

louis058
Member
Registered: 2010-11-12
Posts: 29

Dual booting, when restarting Windows, it's made first in boot list

Dual booting with GRUB2 (grub2-efi-x86_64), obviously using EFI and GPT, dual booting Arch, and Windows 7 64x.

I followed installation instructions I think, installing Windows first (I made the EFI partition, and a 'MSDOS Reserved Partition' which the guide I was looking at told me to make, and the Windows partition all from the Windows Install disk).
Then I installed Arch, with GRUB2.

Everything seemed fine, except I noticed that even when I set GRUB2 to be booted first in the boot priority list (in UEFI/BIOS - whatever it's called), when using Windows, upon the reboot after I have used it, the boot priority list has set Windows Boot Manager to be top again, over GRUB2.

My motherboard is a Asrock H61M/USB3 if that info is needed (supports UEFI obviously, and has a H61 chipset). Anyone had a similar problem before? Or can offer a solution?

Offline

#2 2012-08-11 17:57:11

Lennie
Member
From: Sweden
Registered: 2011-10-12
Posts: 146

Re: Dual booting, when restarting Windows, it's made first in boot list

https://wiki.archlinux.org/index.php/Gr … ious_entry

I'm not sure I understand what you mean, speaking of different "boot managers". Do you have more than one hard drive, Grub2 on one, and Windows boot loader on the other, and that BIOS switch which one to boot from? Or, as described in the link, that Grub saves the last booted option as default for next time?

Offline

#3 2012-08-11 18:26:30

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Dual booting, when restarting Windows, it's made first in boot list

I haven't switched to UEFI yet--so someone else can better explain this--but that's the sort of behavior you'd get when installing GRUB to the "/" partition rather than the MBR.  Both may be installed, but since BOOTMGR is still found on the disk before GRUB, it's going to be run first.

Offline

#4 2012-08-11 18:31:47

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Dual booting, when restarting Windows, it's made first in boot list

Yeah, don't install to /dev/sda1 or something like that. You want to install to /dev/sda (or /dev/sdb, whichever is set to boot first in the BIO...um, whatever menu UEFI systems use).


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#5 2012-08-14 03:02:32

bcforres
Member
Registered: 2012-08-13
Posts: 1

Re: Dual booting, when restarting Windows, it's made first in boot list

Try this:

https://wiki.archlinux.org/index.php/UEFI#UEFI_Shell

Put the efi shell on a flash drive, (instructions there), boot from it in UEFI mode, and then using the bcfg command, you can list and move around UEFI boot entries.  (all the information you need should be there)

Offline

#6 2012-10-09 15:22:51

nehaljwani
Member
Registered: 2012-10-09
Posts: 6

Re: Dual booting, when restarting Windows, it's made first in boot list

You don't necessarily need to dual boot Windows and Linux on UEFI. Follow the guide http://www.youtube.com/watch?v=PEou2dIcMSE to convert your UEFI to MBR-BIOS without loss of data.

Offline

#7 2012-10-09 15:39:38

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,947

Re: Dual booting, when restarting Windows, it's made first in boot list

Windows probably changed the boot flag on the partition to boot itself first if Grub is not loaded first into the MBR.
I've noticed several occassions where windows will boot regardless of grub (from a hibernation, e.g.)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#8 2012-10-09 15:59:37

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Dual booting, when restarting Windows, it's made first in boot list

So I have never actually tried this, but is it still possible to chainload windows from grub by simply pointing it to the system partition it creates?  If so, I would think that there is no need for a boot manager entry for windows.  To mee it seems like the boot manager entry is only for boting directly.  So if you are using a boot manager/loader anyway, I would assume you always want to go through that first. 

Other than that, maybe make your own uefi boot manager entry for windows?  Maybe something that it wouldn't recognize as its own.  I'm really just speculating, but that would really piss me off.


Edit: I am sorry that everyone is giving you answers that are not relevent to uefi.

Last edited by WonderWoofy (2012-10-09 16:00:15)

Offline

#9 2012-10-09 17:12:15

bsilbaugh
Member
From: Maryland, USA
Registered: 2011-11-15
Posts: 141

Re: Dual booting, when restarting Windows, it's made first in boot list

louis058 wrote:

Everything seemed fine, except I noticed that even when I set GRUB2 to be booted first in the boot priority list (in UEFI/BIOS - whatever it's called), when using Windows, upon the reboot after I have used it, the boot priority list has set Windows Boot Manager to be top again, over GRUB2.

First, in your statement, "the boot priority list has set Windows Boot Manager to be on top again...", did you mean, "set Windows Boot Loader to be on top..."? The latter would make a little more sense in the context of UEFI. GRUB's design blurs the distinction between boot manager and boot loader, but formally the component that gives you a list of boot options is regarded as distinct from the component that actually loads the OS. That said, it sounds like you are probably using the boot manager that is built into your UEFI firmware?

Also, does the pivoting of Windows to the top of the boot priority list only happen upon reboot, or does it also happen when you do a full shutdown then power up?

Based on the information you've given, the only explanations I can think of are: 1) Windows is mucking with the boot order upon reboot/shutdown; 2) your boot manager has a built-in preference for Windows; 3) your boot manager tries to pivot the last OS you booted to the top of the list, but for some reason this is failing with Arch/GRUB; 4) little, bit flipping, nano trolls are running around inside your computer wreaking havoc for the sole purpose of pissing you off.

If worse comes to worse, you might consider switching to rEFInd as your boot manager. rEFInd is much easier to configure than most stock boot managers. At least, that is what the developer of rEFInd claims smile I've been using rEFInd on my MacBook to dual boot Arch and OS X. I have been rather pleased with it.

P.S. I'm not sure why so many are recommending that you revert back to BIOS emulation to dual boot Windows and Arch. Like it or not, UEFI is here to stay. It's time to move on and embrace change.

Last edited by bsilbaugh (2012-10-09 17:13:22)


- Good judgement comes from experience; experience comes from bad judgement. -- Mark Twain
- There's a remedy for everything but death. -- The wise fool, Sancho Panza
- The purpose of a system is what it does. -- Anthony Stafford Beer

Offline

#10 2012-10-09 18:16:23

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,947

Re: Dual booting, when restarting Windows, it's made first in boot list

I think grub2 has a bootloader for windows, but chainloading was how you booted windows with grub-legacy.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#11 2012-10-10 04:32:17

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Dual booting, when restarting Windows, it's made first in boot list

But bsilbaugh, isn't refind controlled by a uefi boot manager entry anyway.  It would seem to me that if windows is taking over boot priority anyway, it would also steal from that.  Again, just speculation but it seems to me it would be on equal footing as a grub entry would. 

@nomorewindows, is chainloading a thing of the past with uefi?  I use the efi stub loader, so my knowledge of uefi grub or any other uefi bootloader is minimal.  When I want to change boot parameters, I simply use the uefi shell (which I had to install BTW)

Offline

#12 2012-10-10 11:38:31

bsilbaugh
Member
From: Maryland, USA
Registered: 2011-11-15
Posts: 141

Re: Dual booting, when restarting Windows, it's made first in boot list

WonderWoofy wrote:

But bsilbaugh, isn't refind controlled by a uefi boot manager entry anyway.  It would seem to me that if windows is taking over boot priority anyway, it would also steal from that.  Again, just speculation but it seems to me it would be on equal footing as a grub entry would.

You bring up a good point. If Windows is modifying the boot manager upon reboot/shutdown, then rEFInd isn't going to help. However, for cases (2) and (3), rEFInd might help.

The more I think about it, the more I wonder if this could perhaps be a bug/feature in the firmware itself; i.e. something along the lines of case (2). But, I'm merely speculating at this point.

@louis058 (the OP) did you try contacting Asrock, or post this on their forum?


- Good judgement comes from experience; experience comes from bad judgement. -- Mark Twain
- There's a remedy for everything but death. -- The wise fool, Sancho Panza
- The purpose of a system is what it does. -- Anthony Stafford Beer

Offline

#13 2012-10-10 12:06:08

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Dual booting, when restarting Windows, it's made first in boot list

It would be a pretty sh*tty feature if that is the case.

Offline

#14 2012-10-10 13:45:02

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,947

Re: Dual booting, when restarting Windows, it's made first in boot list

You know you really want Windows (8) for its' self-promoting secure boot loader.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#15 2014-02-10 23:28:11

Lazarus555
Member
Registered: 2013-07-22
Posts: 12

Re: Dual booting, when restarting Windows, it's made first in boot list

Hello everyone,

i have the exact same problem using GRUB to boot Arch and Win 8.1.
When i boot Win up it puts itself as first priority again in the boot manager of the UEFI setup.
I can set i back each time or just choose manually to start GRUB.
That's quite annoying to be honest.

I'm also using a Asrock board (Z68M) with the newest firmware flashed.

As this topic is not flagged [solved] i am guessing this is still unresolved?
Ahhh....stupid M$

Have a good one,
Lazarus

Offline

#16 2014-03-15 17:34:56

bheinks
Member
Registered: 2011-03-27
Posts: 7

Re: Dual booting, when restarting Windows, it's made first in boot list

Hate to necro this thread, but I'm experiencing the same issue and have been unable to find much in terms of answers (or even reports of others with the same issue, other than this thread).

Coincidentally enough, I happen to be using an Asrock board as well (970 Extreme3, latest firmware) along with an Arch/Win8.1 dual boot using gummiboot. While I initially suspected Win8 to be the culprit, I'm beginning to think it has something to do with the BIOS (and perhaps the integration with Windows 8).

I don't recall ever having these issues with my Arch/Win7 dual boot, and it happened only occasionally with Arch/Win8 (usually whenever it failed to shutdown properly). Without a hitch, Windows Boot Manager under Win8.1 steals the #1 spot in my boot priority after every single Windows reboot.

Last edited by bheinks (2014-03-17 15:29:34)

Offline

#17 2014-03-15 19:42:15

srs5694
Member
From: Woonsocket, RI
Registered: 2012-11-06
Posts: 719
Website

Re: Dual booting, when restarting Windows, it's made first in boot list

Try using the Windows bcdedit utility in an Administrator command prompt window:

bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi

Change "\EFI\refind\refind_x64.efi" to the path to whatever EFI boot manager you're using (GRUB 2, gummiboot, etc.). Note that the path is relative to the root on the ESP, which is normally mounted at /boot or /boot/efi in Linux.

This usually fixes the problem. If it doesn't work for you, try updating your firmware and do it again. If it still doesn't work, file bug reports with Microsoft and with the computer/motherboard manufacturer.

Offline

#18 2014-03-17 22:32:12

bheinks
Member
Registered: 2011-03-27
Posts: 7

Re: Dual booting, when restarting Windows, it's made first in boot list

srs5694 wrote:

Try using the Windows bcdedit utility in an Administrator command prompt window:

bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi

Change "\EFI\refind\refind_x64.efi" to the path to whatever EFI boot manager you're using (GRUB 2, gummiboot, etc.). Note that the path is relative to the root on the ESP, which is normally mounted at /boot or /boot/efi in Linux.

This usually fixes the problem. If it doesn't work for you, try updating your firmware and do it again. If it still doesn't work, file bug reports with Microsoft and with the computer/motherboard manufacturer.

Mother of god, it worked. Weeks of frustration mitigated by one bcdedit command.

Thanks friend. Were I of age, I'd buy you a beer.

Offline

#19 2014-03-17 22:57:41

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Dual booting, when restarting Windows, it's made first in boot list

bheinks wrote:

Thanks friend. Were I of age, I'd buy you a beer.

srs5694 is the man, and also the author of rEFInd.

Offline

#20 2014-03-26 18:37:23

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: Dual booting, when restarting Windows, it's made first in boot list

old thread revived twice and looks like its solved too.

Closing...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB