You are not logged in.

#1 2012-09-18 21:54:27

bygmhra
Member
Registered: 2011-12-22
Posts: 25

[solved] could not parse package description file

So I was trying to install anki…

$ sudo pacman -Syu anki
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: could not parse package description file 'gogglesmm-0.12.6-1/depends' from db 'community'
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "python2-sqlalchemy", a dependency of "anki"
warning: cannot resolve "python-simplejson", a dependency of "anki"
:: The following package cannot be upgraded due to unresolvable dependencies:
      anki

Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (unexpected error)

It seems like pacman isn't able to fetch packages from community?
Any ideas how to fix this?
I took a look at this thread but it didn't solve my problem (unless I did it wrong?) & I found nothing else on the internet about this :\

Last edited by bygmhra (2012-09-19 00:17:32)

Offline

#2 2012-09-18 22:00:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [solved] could not parse package description file

Post the output of 'pacman -Q pacman;

Offline

#3 2012-09-18 22:03:04

bygmhra
Member
Registered: 2011-12-22
Posts: 25

Re: [solved] could not parse package description file

$ pacman -Q pacman
pacman 4.0.3-3

Offline

#4 2012-09-18 22:25:39

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: [solved] could not parse package description file

"type -a pacman" would tell you if you're actually running /usr/bin/pacman or something else...

Offline

#5 2012-09-18 22:26:28

bygmhra
Member
Registered: 2011-12-22
Posts: 25

Re: [solved] could not parse package description file

Yes, it's /usr/bin/pacman

Offline

#6 2012-09-18 23:01:19

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: [solved] could not parse package description file

So what version does /usr/bin/pacman report as? Do you get the same result as in the original post running sudo /usr/bin/pacman ?

Offline

#7 2012-09-18 23:11:55

bygmhra
Member
Registered: 2011-12-22
Posts: 25

Re: [solved] could not parse package description file

sudo /usr/bin/pacman -Syu gives me the same error

how do I check the version of /usr/bin/pacman?
I tried

$ pacman -Q /usr/bin/pacman
error: package '/usr/bin/pacman' was not found
warning: '/usr/bin/pacman' is a file, you might want to use -p/--file.

so then I tried this, but I think it's wrong

$ pacman -Q --file /usr/bin/pacman
error: could not load package '/usr/bin/pacman': cannot open package file

Offline

#8 2012-09-18 23:17:58

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [solved] could not parse package description file

What about '/usr/bin/pacman --version'?

Offline

#9 2012-09-18 23:26:41

bygmhra
Member
Registered: 2011-12-22
Posts: 25

Re: [solved] could not parse package description file

$ /usr/bin/pacman --version

 .--.                  Pacman v4.0.3 - libalpm v7.0.3
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2012 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

Offline

#10 2012-09-19 00:01:08

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,430
Website

Re: [solved] could not parse package description file

Force a redownload of the community database with "pacman -Syy".   If that does not work, try a different mirror.

Offline

#11 2012-09-19 00:17:18

bygmhra
Member
Registered: 2011-12-22
Posts: 25

Re: [solved] could not parse package description file

Ah thank you! It's fixed big_smile

initially pacman -Syy didn't change anything
so I then specified a mirror in my /etc/pacman.conf, ran another pacman -Syy on a whim, and then
commented out the mirror I had just added
and that error is now gone

Thanks everyone for your help

Offline

#12 2012-09-19 20:46:35

deviouskoopa
Member
Registered: 2012-09-19
Posts: 2

Re: [solved] could not parse package description file

I'm still getting this exact error, and this thread is the only thing a search turns up... It just started doing this a day or 2 ago too, weird.
I have the latest pacman and about 20 mirrors specified in /etc/pacman.d/mirrorlist.
I've tried removing and adding different combos of mirrors but no luck.

Also should note that I have an updated mirrorlist from the pacman mirror generator page.

Last edited by deviouskoopa (2012-09-19 21:09:49)

Offline

#13 2012-09-20 08:59:11

ubort
Member
Registered: 2012-08-15
Posts: 2

Re: [solved] could not parse package description file

same problem...

error: could not parse package description file 'gogglesmm-0.12.6-1/depends' from db 'community'

and the mirror used is
//mirrors.kernel.org/archlinux/

Offline

#14 2012-09-20 14:29:50

deviouskoopa
Member
Registered: 2012-09-19
Posts: 2

Re: [solved] could not parse package description file

fixed mine... after reading https://bbs.archlinux.org/viewtopic.php?id=149280 i removed kernel.org mirror and it works!

Offline

#15 2012-09-20 21:36:50

ubort
Member
Registered: 2012-08-15
Posts: 2

Re: [solved] could not parse package description file

ok fixed... thank you.

Offline

Board footer

Powered by FluxBB